]> git.pld-linux.org Git - packages/python-py.git/commitdiff
automatic change: use py_build/py_install macros
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:43 +0000 (18:06 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:43 +0000 (18:06 +0100)
python-py.spec

index b74996b260cad5eec1834f509921107ef886765b..47708d0ad561ddae6d2455379fbd44e0213a0f42 100644 (file)
@@ -78,12 +78,12 @@ cp -p %{SOURCE1} doc
 
 %build
 %if %{with python2}
-%{__python} setup.py build \
+%py_build \
        --build-base build-2
 %endif
 
 %if %{with python3}
-%{__python3} setup.py build \
+%py3_build \
        --build-base build-3
 %endif
 
@@ -96,11 +96,7 @@ PYTHONPATH=$(pwd) \
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%py_install
 
 %py_postclean
 %endif
This page took 0.17759 seconds and 4 git commands to generate.