]> git.pld-linux.org Git - packages/python-neovim.git/blob - python-neovim.spec
up to 0.1.13
[packages/python-neovim.git] / python-neovim.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          neovim
7 %define         egg_name        neovim
8 Summary:        Python client to neovim
9 Name:           python-%{module}
10 Version:        0.1.13
11 Release:        1
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 Source0:        https://github.com/neovim/python-client/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  f98f7cd11f2831f4f73bb88971b34701
16 URL:            https://github.com/neovim/python-client
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules
25 BuildRequires:  python3-setuptools
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Implements support for Python plugins in nvim
32
33 %package -n python3-neovim
34 Summary:        Python client to neovim
35 Group:          Libraries/Python
36
37 %description -n python3-neovim
38 Implements support for Python plugins in nvim
39
40 %prep
41 %setup -q -n python-client-%{version}
42
43 %build
44 %if %{with python2}
45 %py_build
46 %endif
47
48 %if %{with python3}
49 %py3_build
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %if %{with python2}
55 %py_install
56 %py_postclean
57 %endif
58
59 %if %{with python3}
60 %py3_install
61 %endif
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %if %{with python3}
67 %files
68 %defattr(644,root,root,755)
69 %doc README.md
70 %{py_sitescriptdir}/%{module}
71 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
72 %endif
73
74 %if %{with python3}
75 %files -n python3-neovim
76 %defattr(644,root,root,755)
77 %doc README.md
78 %{py3_sitescriptdir}/%{module}
79 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
80 %endif
This page took 1.149261 seconds and 3 git commands to generate.