]> git.pld-linux.org Git - packages/python-lxml.git/commitdiff
- added Skip-failing-test-test_html_prefix_nsmap patch from Fedora (adjusted to work...
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Sep 2023 16:29:54 +0000 (18:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Sep 2023 16:29:54 +0000 (18:29 +0200)
lxml-Skip-failing-test-test_html_prefix_nsmap.patch [new file with mode: 0644]
python-lxml.spec

diff --git a/lxml-Skip-failing-test-test_html_prefix_nsmap.patch b/lxml-Skip-failing-test-test_html_prefix_nsmap.patch
new file mode 100644 (file)
index 0000000..6271dcb
--- /dev/null
@@ -0,0 +1,34 @@
+From 91729cf581f764c3321f644206568f18d0fc92f4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
+Date: Thu, 18 May 2023 08:00:48 +0200
+Subject: [PATCH] Skip failing test test_html_prefix_nsmap
+
+Upstream issue: https://bugs.launchpad.net/lxml/+bug/2016939
+---
+ src/lxml/tests/test_etree.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/lxml/tests/test_etree.py b/src/lxml/tests/test_etree.py
+index 0339796..1994a7f 100644
+--- a/src/lxml/tests/test_etree.py
++++ b/src/lxml/tests/test_etree.py
+@@ -27,6 +27,8 @@ from .common_imports import SillyFileLike, LargeFileLikeUnicode, doctest, make_d
+ from .common_imports import canonicalize, _str, _bytes
+ from .common_imports import SimpleFSPath
++from unittest import skip
++
+ print("""
+ TESTED VERSION: %s""" % etree.__version__ + """
+     Python:           %r""" % (sys.version_info,) + """
+@@ -3067,6 +3069,7 @@ class ETreeOnlyTestCase(HelperTestCase):
+         self.assertEqual(re, e.nsmap)
+         self.assertEqual(r,  s.nsmap)
++    @skip("broken with libxml2 2.10.4+")
+     def test_html_prefix_nsmap(self):
+         etree = self.etree
+         el = etree.HTML('<hha:page-description>aa</hha:page-description>').find('.//page-description')
+-- 
+2.40.1
+
index 41cd1cbe61ccb934fc3a424421143986266ec422..b54fef8fc45e87b798de73e651249bd1ea30d611 100644 (file)
@@ -16,6 +16,7 @@ Group:                Libraries/Python
 #Source0Download: https://pypi.org/simple/lxml/
 Source0:       https://files.pythonhosted.org/packages/source/l/lxml/%{module}-%{version}.tar.gz
 # Source0-md5: e27240a7319d80d0c1e5390ca31eb1d8
+Patch0:                lxml-Skip-failing-test-test_html_prefix_nsmap.patch
 URL:           https://lxml.de/
 BuildRequires: libxml2-devel >= 1:2.9.2
 BuildRequires: libxslt-devel >= 1.1.28
@@ -67,6 +68,7 @@ Dokumentacja API moduĊ‚u lxml.
 
 %prep
 %setup -q -n %{module}-%{version}
+%patch0 -p1
 
 %build
 %if %{with python2}
This page took 0.230445 seconds and 4 git commands to generate.