]> git.pld-linux.org Git - packages/python-linux-procfs.git/blob - python-linux-procfs.spec
- release 2 (by relup.sh)
[packages/python-linux-procfs.git] / python-linux-procfs.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Linux /proc abstraction classes for Python 2
7 Summary(pl.UTF-8):      Klasy abstrakcji linuksowego /proc dla Pythona 2
8 Name:           python-linux-procfs
9 Version:        0.4.9
10 Release:        2
11 License:        GPL v2
12 Group:          Libraries/Python
13 Source0:        https://www.kernel.org/pub/software/libs/python/python-linux-procfs/%{name}-%{version}.tar.xz
14 # Source0-md5:  d8c96bcca75edd44970ea0f123bda823
15 URL:            https://rt.wiki.kernel.org/index.php/Tuna
16 BuildRequires:  python-modules >= 2
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.612
19 %if %{with python3}
20 BuildRequires:  python3-modules >= 1:3.2
21 %endif
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Python 2 abstractions to extract information from the Linux kernel
29 /proc files.
30
31 %description -l pl.UTF-8
32 Abstrakcje Pythona 2 do wydobywania informacji z plików /proc jądra
33 Linuksa.
34
35 %package -n python3-linux-procfs
36 Summary:        Linux /proc abstraction classes for Python 3
37 Summary(pl.UTF-8):      Klasy abstrakcji linuksowego /proc dla Pythona 3
38 Group:          Libraries/Python
39
40 %description -n python3-linux-procfs
41 Python 3 abstractions to extract information from the Linux kernel
42 /proc files.
43
44 %description -n python3-linux-procfs -l pl.UTF-8
45 Abstrakcje Pythona 3 do wydobywania informacji z plików /proc jądra
46 Linuksa.
47
48 %prep
49 %setup -q
50
51 %build
52 %if %{with python2}
53 %py_build
54 %endif
55
56 %if %{with python3}
57 %py3_build
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %if %{with python2}
64 %py_install
65
66 %py_postclean
67 %endif
68
69 %if %{with python3}
70 %py3_install
71 %endif
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %files
78 %defattr(644,root,root,755)
79 %{py_sitescriptdir}/procfs
80 %if "%{py_ver}" > "2.4"
81 %{py_sitescriptdir}/python_linux_procfs-%{version}-py*.egg-info
82 %endif
83 %endif
84
85 %if %{with python3}
86 %files -n python3-linux-procfs
87 %defattr(644,root,root,755)
88 %{py3_sitescriptdir}/procfs
89 %{py3_sitescriptdir}/python_linux_procfs-%{version}-py*.egg-info
90 %endif
This page took 0.047763 seconds and 3 git commands to generate.