]> git.pld-linux.org Git - packages/python-libvirt.git/commitdiff
- up to 2.5.0 auto/th/python-libvirt-2.5.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 31 Dec 2016 10:24:35 +0000 (11:24 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 31 Dec 2016 10:24:35 +0000 (11:24 +0100)
libvirt-python-build.patch [new file with mode: 0644]
python-libvirt.spec

diff --git a/libvirt-python-build.patch b/libvirt-python-build.patch
new file mode 100644 (file)
index 0000000..3b98f4b
--- /dev/null
@@ -0,0 +1,30 @@
+From f5edaf1ba5bc2db38ae0c7f595e17aff9d89dcfa Mon Sep 17 00:00:00 2001
+From: Daniel P. Berrange <berrange@redhat.com>
+Date: Wed, 21 Dec 2016 10:35:17 +0000
+Subject: [PATCH 1/1] Remove bogus \o escape in regex
+
+One of the regexes has a bogus \o instead of plain 'o'. Somehow
+this magically worked on all versions of python, until 3.6 came
+along and complained
+
+Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
+---
+ generator.py |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/generator.py b/generator.py
+index 730e456..2c3b667 100755
+--- a/generator.py
++++ b/generator.py
+@@ -1091,7 +1091,7 @@ def is_integral_type (name):
+     return not re.search ("^(unsigned)? ?(int|long)$", name) is None
+ def is_optional_arg(info):
+-    return re.search("^\(?\optional\)?", info) is not None
++    return re.search("^\(?optional\)?", info) is not None
+ # Functions returning lists which need special rules to check for errors
+ # and raise exceptions.
+ functions_list_exception_test = {
+-- 
+1.7.1
+
index ee1ec13bc55f1f965c92e98e99594b9103e74d78..b389ac592103443d5a99113c34a9c0c4ac100c47 100644 (file)
 Summary:       Python 2.x bindings to interact with virtualization capabilities
 Summary(pl.UTF-8):     Wiązania Pythona 2.x do współpracy z funkcjami wirtualizacji
 Name:          python-libvirt
-Version:       1.2.20
-Release:       4
+Version:       2.5.0
+Release:       1
 License:       LGPL v2.1+
 Group:         Development/Languages/Python
 Source0:       ftp://ftp.libvirt.org/libvirt/python/%{origname}-%{version}.tar.gz
-# Source0-md5: 2e17b3047c80291874bb96f0a80816db
+# Source0-md5: 6a064196181adcb7769e42c312a65610
+Patch0:                libvirt-python-build.patch
 URL:           http://www.libvirt.org/
 BuildRequires: libvirt-devel >= 1.0.2
 BuildRequires: pkgconfig
@@ -66,6 +67,7 @@ Ten pakiet zawiera wiązania Pythona 3.x do biblioteki libvirt.
 
 %prep
 %setup -q -n %{origname}-%{version}
+%patch0 -p1
 
 %build
 %py_build
This page took 0.101481 seconds and 4 git commands to generate.