]> git.pld-linux.org Git - packages/python-josepy.git/blob - python-josepy.spec
- release 2 (by relup.sh)
[packages/python-josepy.git] / python-josepy.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5 #
6 %define         module  josepy
7 Summary:        JOSE protocol implementation
8 Name:           python-%{module}
9 Version:        1.1.0
10 Release:        2
11 License:        Apache v2.0
12 Group:          Development/Languages/Python
13 Source0:        https://files.pythonhosted.org/packages/source/j/josepy/josepy-%{version}.tar.gz
14 # Source0-md5:  b582dbfd70ccdbe5926e4dc46ba6719c
15 URL:            https://josepy.readthedocs.io/en/latest/
16 %if %{with python2}
17 BuildRequires:  python-devel >= 1:2.6
18 BuildRequires:  python-setuptools
19 %endif
20 %if %{with python3}
21 BuildRequires:  python3-devel >= 1:3.2
22 BuildRequires:  python3-setuptools
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This package provides JOSE protocol implementation.
28
29 %package -n python3-%{module}
30 Summary:        JOSE protocol implementation in Python 3
31 Group:          Development/Languages/Python
32
33 %description -n python3-%{module}
34 This package provides JOSE protocol implementation in Python 3.
35
36 %prep
37 %setup -q -n %{module}-%{version}
38
39 %build
40 %if %{with python2}
41 %py_build
42 %endif
43 %if %{with python3}
44 %py3_build
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %if %{with python3}
51 %py3_install
52 %endif
53
54 %if %{with python2}
55 %py_install
56 %endif
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %if %{with python2}
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/jws
65 %{py_sitescriptdir}/josepy-*-py*.egg-info
66 %{py_sitescriptdir}/josepy
67 %endif
68
69 %if %{with python3}
70 %files -n python3-%{module}
71 %defattr(644,root,root,755)
72 %{py3_sitescriptdir}/josepy-*-py*.egg-info
73 %{py3_sitescriptdir}/josepy
74 %endif
This page took 0.238971 seconds and 3 git commands to generate.