]> git.pld-linux.org Git - packages/python-httplib2.git/blob - python-httplib2.spec
- release 5 (by relup.sh)
[packages/python-httplib2.git] / python-httplib2.spec
1 #
2 # Conditional build:
3 %bcond_without  python3 # Python 3.x module
4
5 Summary:        A comprehensive HTTP client library
6 Summary(pl.UTF-8):      Obszerna biblioteka klienta HTTP
7 Name:           python-httplib2
8 Version:        0.8
9 Release:        5
10 License:        MIT
11 Group:          Development/Languages/Python
12 Source0:        http://httplib2.googlecode.com/files/httplib2-%{version}.zip
13 # Source0-md5:  0803da81fe1bb92f864715665defe65f
14 URL:            http://bitworking.org/projects/httplib2/
15 BuildRequires:  python >= 2.3
16 BuildRequires:  python-modules
17 BuildRequires:  sed >= 4.0
18 %if %{with python3}
19 BuildRequires:  python3-devel
20 BuildRequires:  python3-distribute
21 BuildRequires:  python3-modules
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 A comprehensive HTTP client library, httplib2.py supports many
29 features left out of other HTTP libraries. Supports:
30 - HTTP and HTTPS
31 - Keep-Alive
32 - Authentication
33 - Caching
34 - All Methods
35 - Redirects
36 - Compression
37 - Lost update support
38 - Unit Tested
39
40 %description -l pl.UTF-8
41 httplib2.py to obszerna biblioteka klienta HTTP, obsługująca wiele
42 cech pomijanych przez inne biblioteki. Obsługuje:
43 - HTTP i HTTPS
44 - Keep-Alive
45 - uwierzytelnianie
46 - buforowanie
47 - wszystkie metody
48 - przekierowania
49 - kompresję
50 - Lost update
51 - podlega testom jednostkowym.
52
53 %package -n python3-httplib2
54 Summary:        A comprehensive HTTP client library
55 Summary(pl.UTF-8):      Obszerna biblioteka klienta HTTP
56 Group:          Development/Languages/Python
57
58 %description -n python3-httplib2
59 A comprehensive HTTP client library, httplib2.py supports many
60 features left out of other HTTP libraries. Supports:
61 - HTTP and HTTPS
62 - Keep-Alive
63 - Authentication
64 - Caching
65 - All Methods
66 - Redirects
67 - Compression
68 - Lost update support
69 - Unit Tested
70
71 %description -n python3-httplib2 -l pl.UTF-8
72 httplib2.py to obszerna biblioteka klienta HTTP, obsługująca wiele
73 cech pomijanych przez inne biblioteki. Obsługuje:
74 - HTTP i HTTPS
75 - Keep-Alive
76 - uwierzytelnianie
77 - buforowanie
78 - wszystkie metody
79 - przekierowania
80 - kompresję
81 - Lost update
82 - podlega testom jednostkowym.
83
84 %prep
85 %setup -q -n httplib2-%{version}
86
87 %build
88 %py_build
89
90 %if %{with python3}
91 %py3_build
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %py_install
97
98 %if %{with python3}
99 %py3_install
100 %endif
101
102 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
103 %py_postclean
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README CHANGELOG
111 %{py_sitescriptdir}/httplib2
112 %{py_sitescriptdir}/httplib2-%{version}-py*.egg-info
113
114 %files -n python3-httplib2
115 %defattr(644,root,root,755)
116 %doc python3/README CHANGELOG
117 %{py3_sitescriptdir}/httplib2
118 %{py3_sitescriptdir}/httplib2-%{version}-py*.egg-info
This page took 0.20933 seconds and 3 git commands to generate.