]> git.pld-linux.org Git - packages/python-httplib2.git/blob - python-httplib2.spec
238e83b989a7a6aafd8f465aa9d4d39998b27051
[packages/python-httplib2.git] / python-httplib2.spec
1 #
2 # Conditional build:
3 %bcond_without  python3 # Python 3.x module
4
5 Summary:        A comprehensive HTTP client library
6 Summary(pl.UTF-8):      Obszerna biblioteka klienta HTTP
7 Name:           python-httplib2
8 Version:        0.17.0
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages/Python
12 Source0:        https://github.com/httplib2/httplib2/archive/v%{version}.tar.gz
13 # Source0-md5:  fbd0b80a32a4cbb1c3c459294e3a1065
14 Patch0:         %{name}.certfile.patch
15 Patch1:         %{name}-0.9-proxy-http.patch
16 URL:            https://github.com/httplib2/httplib2
17 BuildRequires:  python >= 2.3
18 BuildRequires:  python-modules
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 BuildRequires:  sed >= 4.0
21 %if %{with python3}
22 BuildRequires:  python3-devel
23 BuildRequires:  python3-distribute
24 BuildRequires:  python3-modules
25 %endif
26 BuildRequires:  rpm-pythonprov
27 Requires:       ca-certificates
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A comprehensive HTTP client library, httplib2.py supports many
33 features left out of other HTTP libraries. Supports:
34 - HTTP and HTTPS
35 - Keep-Alive
36 - Authentication
37 - Caching
38 - All Methods
39 - Redirects
40 - Compression
41 - Lost update support
42 - Unit Tested
43
44 %description -l pl.UTF-8
45 httplib2.py to obszerna biblioteka klienta HTTP, obsługująca wiele
46 cech pomijanych przez inne biblioteki. Obsługuje:
47 - HTTP i HTTPS
48 - Keep-Alive
49 - uwierzytelnianie
50 - buforowanie
51 - wszystkie metody
52 - przekierowania
53 - kompresję
54 - Lost update
55 - podlega testom jednostkowym.
56
57 %package -n python3-httplib2
58 Summary:        A comprehensive HTTP client library
59 Summary(pl.UTF-8):      Obszerna biblioteka klienta HTTP
60 Group:          Development/Languages/Python
61
62 %description -n python3-httplib2
63 A comprehensive HTTP client library, httplib2.py supports many
64 features left out of other HTTP libraries. Supports:
65 - HTTP and HTTPS
66 - Keep-Alive
67 - Authentication
68 - Caching
69 - All Methods
70 - Redirects
71 - Compression
72 - Lost update support
73 - Unit Tested
74
75 %description -n python3-httplib2 -l pl.UTF-8
76 httplib2.py to obszerna biblioteka klienta HTTP, obsługująca wiele
77 cech pomijanych przez inne biblioteki. Obsługuje:
78 - HTTP i HTTPS
79 - Keep-Alive
80 - uwierzytelnianie
81 - buforowanie
82 - wszystkie metody
83 - przekierowania
84 - kompresję
85 - Lost update
86 - podlega testom jednostkowym.
87
88 %prep
89 %setup -q -n httplib2-%{version}
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 %py_build
95
96 %if %{with python3}
97 %py3_build
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %py_install
103 rm $RPM_BUILD_ROOT%{py_sitescriptdir}/httplib2/cacerts.txt
104
105 %if %{with python3}
106 %py3_install
107 rm $RPM_BUILD_ROOT%{py3_sitescriptdir}/httplib2/cacerts.txt
108 %endif
109
110 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
111 %py_postclean
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README.md CHANGELOG
119 %{py_sitescriptdir}/httplib2
120 %{py_sitescriptdir}/httplib2-%{version}-py*.egg-info
121
122 %if %{with python3}
123 %files -n python3-httplib2
124 %defattr(644,root,root,755)
125 %doc python3/README CHANGELOG
126 %{py3_sitescriptdir}/httplib2
127 %{py3_sitescriptdir}/httplib2-%{version}-py*.egg-info
128 %endif
This page took 0.031753 seconds and 2 git commands to generate.