]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- up to 2.16.2
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.10.3
3 %define         pyorbit_req     2.14.1
4 Summary:        GNOME bindings for Python
5 Summary(pl):    Wi±zania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.16.2
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.16/%{module}-%{version}.tar.bz2
12 # Source0-md5:  b365a772c8c9eac24b368c7e26845dc8
13 BuildRequires:  GConf2-devel >= 2.16.0
14 BuildRequires:  automake
15 BuildRequires:  autoconf
16 BuildRequires:  gnome-common >= 2.12.0
17 BuildRequires:  gnome-vfs2-devel >= 2.16.1
18 BuildRequires:  gtk+2-devel >= 2:2.10.6
19 BuildRequires:  libbonobo-devel >= 2.16.0
20 BuildRequires:  libgnomeui-devel >= 2.16.1
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  popt-devel
24 BuildRequires:  python-devel >= 1:2.3.2
25 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
26 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.197
29 %pyrequires_eq  python-modules
30 Requires:       %{name}-bonobo = %{version}-%{release}
31 Requires:       %{name}-gconf = %{version}-%{release}
32 Requires:       %{name}-vfs = %{version}-%{release}
33 Requires:       libgnomeui >= 2.16.1
34 Obsoletes:      gnome-python
35 Obsoletes:      gnome-python-nautilus
36 Obsoletes:      python-gnome-nautilus
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
40
41 %description
42 GNOME bindings for Python.
43
44 %description -l pl
45 Wi±zania Pythona do bibliotek GNOME.
46
47 %package bonobo
48 Summary:        Bonobo bindings for Python
49 Summary(pl):    Wi±zania Pythona do biblioteki Bonobo
50 Group:          Libraries/Python
51 Requires:       python-pygobject >= 2.12.2
52 Requires:       python-pyorbit >= %{pyorbit_req}
53
54 %description bonobo
55 Bonobo bindings for Python.
56
57 %description bonobo -l pl
58 Wi±zania Pythona do biblioteki Bonobo.
59
60 %package bonobo-ui
61 Summary:        Bonobo User Interface bindings for Python
62 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo
63 Group:          Libraries/Python
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       %{name}-bonobo = %{version}-%{release}
66 Requires:       %{name}-canvas = %{version}-%{release}
67 Requires:       %{name}-gconf = %{version}-%{release}
68 Requires:       %{name}-vfs = %{version}-%{release}
69
70 %description bonobo-ui
71 Bonobo User Interface bindings for Python.
72
73 %description bonobo-ui -l pl
74 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo.
75
76 %package canvas
77 Summary:        GNOME Canvas bindings for Python
78 Summary(pl):    Wi±zania Pythona do biblioteki GNOME Canvas
79 Group:          Libraries/Python
80 Requires:       python-pygtk-gtk >= %{pygtk_req}
81
82 %description canvas
83 GNOME Canvas bindings for Python.
84
85 %description canvas -l pl
86 Wi±zania Pythona do biblioteki GNOME Canvas.
87
88 %package gconf
89 Summary:        GConf bindings for Python
90 Summary(pl):    Wi±zania Pythona do biblioteki GConf
91 Group:          Libraries/Python
92 Requires:       python-pygobject >= 2.12.2
93 Requires:       python-pyorbit >= %{pyorbit_req}
94
95 %description gconf
96 GConf bindings for Python.
97
98 %description gconf -l pl
99 Wi±zania Pythona do biblioteki GConf.
100
101 %package ui
102 Summary:        GNOME User Interface bindings for Python
103 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME
104 Group:          Libraries/Python
105 Requires:       %{name}-bonobo-ui = %{version}-%{release}
106
107 %description ui
108 GNOME User Interface bindings for Python.
109
110 %description ui -l pl
111 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME.
112
113 %package vfs
114 Summary:        GNOME VFS bindings for Python
115 Summary(pl):    Wi±zania Pythona do biblioteki GNOME VFS
116 Group:          Libraries/Python
117 Requires:       %{name}-bonobo = %{version}-%{release}
118 Requires:       %{name}-gconf = %{version}-%{release}
119
120 %description vfs
121 GNOME VFS bindings for Python.
122
123 %description vfs -l pl
124 Wi±zania Pythona do biblioteki GNOME VFS.
125
126 %package devel
127 Summary:        Development files for GNOME bindings for Python
128 Summary(pl):    Pliki programistyczne wi±zañ Pythona do GNOME
129 Group:          Libraries/Python
130 Requires:       %{name}-ui = %{version}-%{release}
131 Requires:       python-pygtk-devel >= %{pygtk_req}
132
133 %description devel
134 Development files for GNOME bindings for Python.
135
136 %description devel -l pl
137 Pliki programistyczne wi±zañ Pythona do GNOME.
138
139 %package examples
140 Summary:        Example programs for python-gnome
141 Summary(pl):    Przyk³adowe programy do python-gnome
142 Group:          Libraries/Python
143 Requires:       %{name}-devel = %{version}-%{release}
144
145 %description examples
146 This package contains example programs for python-gnome.
147
148 %description examples -l pl
149 Ten pakiet zawiera przyk³adowe programy dla python-gnome.
150
151 %prep
152 %setup -q -n %{module}-%{version}
153
154 %build
155 %{__libtoolize}
156 %{__aclocal}
157 %{__autoconf}
158 %{__autoheader}
159 %{__automake}
160 %configure
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
172
173 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
174 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc ChangeLog AUTHORS
185 %dir %{py_sitedir}/gtk-2.0/gnome
186 %{py_sitedir}/gtk-2.0/gnome/__init__.py?
187 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome*.so
188 %dir %{_datadir}/pygtk/2.0/argtypes
189
190 %files devel
191 %defattr(644,root,root,755)
192 %{_includedir}/%{module}-2.0
193 %{pydefsdir}/*
194 %{_pkgconfigdir}/*
195
196 %files examples
197 %defattr(644,root,root,755)
198 %{_examplesdir}/%{name}-%{version}
199
200 %files bonobo
201 %defattr(644,root,root,755)
202 %dir %{py_sitedir}/gtk-2.0/bonobo
203 %{py_sitedir}/gtk-2.0/bonobo/__init__.py?
204 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo*.so
205 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation*.so
206 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
207
208 %files bonobo-ui
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui*.so
211
212 %files canvas
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas*.so
215 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
216
217 %files gconf
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf*.so
220 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
221
222 %files ui
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui*.so
225
226 %files vfs
227 %defattr(644,root,root,755)
228 %dir %{py_sitedir}/gtk-2.0/gnomevfs
229 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/*.so
230 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/*.so
231 %{py_sitedir}/gtk-2.0/gnomevfs/*.py[co]
232 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
This page took 0.094708 seconds and 4 git commands to generate.