]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- release 3
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.12.0
3 %define         pyorbit_req     2.14.2
4 Summary:        GNOME bindings for Python
5 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.22.0
8 Release:        3
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.22/%{module}-%{version}.tar.bz2
12 # Source0-md5:  ff84c54314adec195149c59365e35a13
13 BuildRequires:  GConf2-devel >= 2.22.0
14 BuildRequires:  glib2-devel >= 1:2.16.0
15 BuildRequires:  gnome-common >= 2.20.0
16 BuildRequires:  gnome-vfs2-devel >= 2.22.0
17 BuildRequires:  gtk+2-devel >= 2:2.12.0
18 BuildRequires:  libbonoboui-devel >= 2.22.0
19 BuildRequires:  libgnomeui-devel >= 2.22.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  popt-devel
23 BuildRequires:  python-devel >= 1:2.3.2
24 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
25 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.197
28 %pyrequires_eq  python-modules
29 Requires:       %{name}-bonobo = %{version}-%{release}
30 Requires:       %{name}-gconf = %{version}-%{release}
31 Requires:       %{name}-vfs = %{version}-%{release}
32 Requires:       libgnomeui >= 2.22.0
33 Obsoletes:      gnome-python
34 Obsoletes:      gnome-python-nautilus
35 Obsoletes:      python-gnome-nautilus
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
39
40 %description
41 GNOME bindings for Python.
42
43 %description -l pl.UTF-8
44 Wiązania Pythona do bibliotek GNOME.
45
46 %package bonobo
47 Summary:        Bonobo bindings for Python
48 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Bonobo
49 Group:          Libraries/Python
50 Requires:       python-pygobject >= 2.14.0
51 Requires:       python-pyorbit >= %{pyorbit_req}
52
53 %description bonobo
54 Bonobo bindings for Python.
55
56 %description bonobo -l pl.UTF-8
57 Wiązania Pythona do biblioteki Bonobo.
58
59 %package bonobo-ui
60 Summary:        Bonobo User Interface bindings for Python
61 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo
62 Group:          Libraries/Python
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       %{name}-bonobo = %{version}-%{release}
65 Requires:       %{name}-canvas = %{version}-%{release}
66 Requires:       %{name}-gconf = %{version}-%{release}
67 Requires:       %{name}-vfs = %{version}-%{release}
68
69 %description bonobo-ui
70 Bonobo User Interface bindings for Python.
71
72 %description bonobo-ui -l pl.UTF-8
73 Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo.
74
75 %package canvas
76 Summary:        GNOME Canvas bindings for Python
77 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME Canvas
78 Group:          Libraries/Python
79 Requires:       python-pygtk-gtk >= %{pygtk_req}
80
81 %description canvas
82 GNOME Canvas bindings for Python.
83
84 %description canvas -l pl.UTF-8
85 Wiązania Pythona do biblioteki GNOME Canvas.
86
87 %package gconf
88 Summary:        GConf bindings for Python
89 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GConf
90 Group:          Libraries/Python
91 Requires:       python-pygobject >= 2.14.0
92 Requires:       python-pyorbit >= %{pyorbit_req}
93
94 %description gconf
95 GConf bindings for Python.
96
97 %description gconf -l pl.UTF-8
98 Wiązania Pythona do biblioteki GConf.
99
100 %package ui
101 Summary:        GNOME User Interface bindings for Python
102 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika GNOME
103 Group:          Libraries/Python
104 Requires:       %{name}-bonobo-ui = %{version}-%{release}
105
106 %description ui
107 GNOME User Interface bindings for Python.
108
109 %description ui -l pl.UTF-8
110 Wiązania Pythona do biblioteki interfejsu użytkownika GNOME.
111
112 %package vfs
113 Summary:        GNOME VFS bindings for Python
114 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME VFS
115 Group:          Libraries/Python
116 Requires:       %{name}-bonobo = %{version}-%{release}
117 Requires:       %{name}-gconf = %{version}-%{release}
118
119 %description vfs
120 GNOME VFS bindings for Python.
121
122 %description vfs -l pl.UTF-8
123 Wiązania Pythona do biblioteki GNOME VFS.
124
125 %package devel
126 Summary:        Development files for GNOME bindings for Python
127 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do GNOME
128 Group:          Libraries/Python
129 Requires:       %{name}-ui = %{version}-%{release}
130 Requires:       python-pygtk-devel >= %{pygtk_req}
131
132 %description devel
133 Development files for GNOME bindings for Python.
134
135 %description devel -l pl.UTF-8
136 Pliki programistyczne wiązań Pythona do GNOME.
137
138 %package examples
139 Summary:        Example programs for python-gnome
140 Summary(pl.UTF-8):      Przykładowe programy do python-gnome
141 Group:          Libraries/Python
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description examples
145 This package contains example programs for python-gnome.
146
147 %description examples -l pl.UTF-8
148 Ten pakiet zawiera przykładowe programy dla python-gnome.
149
150 %prep
151 %setup -q -n %{module}-%{version}
152
153 %build
154 ./waf configure \
155         --prefix %{_prefix} \
156         --libdir %{_libdir}
157 ./waf build
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
163
164 ./waf install \
165         --destdir $RPM_BUILD_ROOT
166
167 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
168
169 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
170 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc ChangeLog AUTHORS
181 %dir %{py_sitedir}/gtk-2.0/gnome
182 %{py_sitedir}/gtk-2.0/gnome/__init__.py[co]
183 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome.so
184
185 %files devel
186 %defattr(644,root,root,755)
187 %{_includedir}/gnome-python-2.0
188 %dir %{_datadir}/pygtk/2.0/argtypes
189 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
190 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
191 %{pydefsdir}/*.defs
192 %{_pkgconfigdir}/gnome-python-2.0.pc
193
194 %files examples
195 %defattr(644,root,root,755)
196 %{_examplesdir}/%{name}-%{version}
197
198 %files bonobo
199 %defattr(644,root,root,755)
200 %dir %{py_sitedir}/gtk-2.0/bonobo
201 %{py_sitedir}/gtk-2.0/bonobo/__init__.py[co]
202 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo.so
203 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation.so
204
205 %files bonobo-ui
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui.so
208
209 %files canvas
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas.so
212 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
213
214 %files gconf
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf.so
217
218 %files ui
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui.so
221
222 %files vfs
223 %defattr(644,root,root,755)
224 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
225 %dir %{py_sitedir}/gtk-2.0/gnomevfs
226 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/_gnomevfs.so
227 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/gnomevfsbonobo.so
228 %{py_sitedir}/gtk-2.0/gnomevfs/__init__.py[co]
229 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
This page took 0.058926 seconds and 3 git commands to generate.