]> git.pld-linux.org Git - packages/python-gevent.git/commitdiff
Version: 1.0.2
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 14 Jul 2015 13:48:18 +0000 (15:48 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 14 Jul 2015 13:48:18 +0000 (15:48 +0200)
Update known_failures-pld.patch, mark the tests 'FLAKY' so build won't
panic when they pass, on systems less restrictive than the builders.

known_failures-pld.patch
python-gevent.spec

index 93daebb036cf6aca4e2353f7326596e11374c178..22643665bfd663f4bd0b38df103ab134dae7a2d0 100644 (file)
@@ -1,6 +1,7 @@
---- gevent-1.0.1/known_failures.py~    2014-04-30 17:45:07.000000000 +0300
-+++ gevent-1.0.1/known_failures.py     2015-05-30 17:35:36.317971589 +0300
-@@ -21,6 +21,83 @@
+diff -dur -x '*.orig' gevent-1.0.2.orig/known_failures.py gevent-1.0.2/known_failures.py
+--- gevent-1.0.2.orig/known_failures.py        2015-05-23 14:04:13.000000000 +0200
++++ gevent-1.0.2/known_failures.py     2015-07-14 15:20:53.000000000 +0200
+@@ -16,6 +16,86 @@
      # Sometimes fails with AssertionError: ...\nIOError: close() called during concurrent operation on the same file object.\n'
      # Sometimes it contains "\nUnhandled exception in thread started by \nsys.excepthook is missing\nlost sys.stderr\n"
      "FLAKY test__subprocess_interrupted.py",
@@ -17,7 +18,7 @@
 +#       File "/home/users/jajcus/rpm/BUILD/gevent-1.0/gevent/hub.py", line 331, in s
 +#         return greenlet.switch(self)
 +#     Timeout: 1 second: test timed out
-+'test__pywsgi.py',
++'FLAKY test__pywsgi.py',
 +
 +######################################################
 +# Tests which fail when building with system libev
 +#     File "test__destroy.py", line 14, in <module>
 +#       assert saved_loop.fileno() is None, saved_loop
 +#   AttributeError: 'gevent.core.loop' object has no attribute 'fileno'
-+'test__destroy.py',
++'FLAKY test__destroy.py',
 +
 +# | /usr/bin/python -u test_close_backend_fd.py
 +#   Traceback (most recent call last):
 +#     File "test_close_backend_fd.py", line 11, in <module>
 +#       fileno = hub.loop.fileno()
 +#   AttributeError: 'gevent.core.loop' object has no attribute 'fileno'
-+'test_close_backend_fd.py',
++'FLAKY test_close_backend_fd.py',
 +
 +######################################################
 +# Tests which may fail on our builders
 +
 +# attempts to bind to port 53
-+'test_ares_timeout.py',
++'FLAKY test_ares_timeout.py',
 +
 +# depends on external service
-+'test__socket_ssl.py',
++'FLAKY test__socket_ssl.py',
 +
 +# depends on external URL accessibility
-+'monkey_test test_urllib2net.py',
-+'monkey_test --Event test_urllib2net.py',
++'FLAKY monkey_test test_urllib2net.py',
++'FLAKY monkey_test --Event test_urllib2net.py',
 +
 +# requires webpy, not in PLD
 +# has expectations on local TCP ports availability
-+'test___example_servers.py',
++'FLAKY test___example_servers.py',
 +
 +#    File "test__socket.py", line 140, in test_sendall_timeout
 +#      self.assertRaises(self.TIMEOUT_ERROR, client.sendall, data_sent)
 +#  AssertionError: timeout not raised
-+'test__socket.py',
++'FLAKY test__socket.py',
 +
 +# uses DNS and external URLs,
 +# requires 'sendfile' python module
-+'test__examples.py',
++'FLAKY test__examples.py',
 +
 +# expects local TCP port 6000 being available
-+'test__example_echoserver.py'
++'FLAKY test__example_echoserver.py',
++
++# another network test
++'FLAKY test__example_portforwarder.py',
 +
  ]
  
+ if sys.version_info[:2] <= (2, 6):
index c09e894bf010417b53ef6055378b969764657ead..adb9e4c8e791d51628e65fd78904d550759a9fd6 100644 (file)
@@ -1,13 +1,10 @@
 
 # TODO:
-#      - SSL Broken with python 2.7.9
-#        https://github.com/gevent/gevent/issues/477
-#
 #      - test__core_stat.py fails on 32-bit builds with system libev
 #        investigate/fix that and enable system libev
 #
 #      - investigate some other failing tests
-#        (now excluded via known_failures-pld.txt)
+#        (now excluded via known_failures-pld.patch)
 
 # Conditional build:
 %bcond_without tests   # do not run tests
 %define     module  gevent
 Summary:       A coroutine-based Python networking library
 Name:          python-%{module}
-Version:       1.0.1
+Version:       1.0.2
 Release:       1
 License:       MIT
 Group:         Development/Languages
 Source0:       http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
-# Source0-md5: 7b952591d1a0174d6eb6ac47bd975ab6
+# Source0-md5: 117f135d57ca7416203fba3720bf71c1
 Patch0:                known_failures-pld.patch
 URL:           http://www.gevent.org/
 %{?with_system_c_ares:BuildRequires:   c-ares-devel >= 1.10.0}
This page took 0.054665 seconds and 4 git commands to generate.