]> git.pld-linux.org Git - packages/python-gevent.git/commitdiff
automatic change: use py_build/py_install macros
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:42 +0000 (18:06 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 28 Nov 2015 17:06:42 +0000 (18:06 +0100)
python-gevent.spec

index 1a0fbb2fdb36ddca3052f6acebd13430f3b1df1b..02f5e1f74c1982170396b2038089eacc9f805991 100644 (file)
@@ -92,7 +92,7 @@ CC="%{__cc}" \
 CFLAGS="%{rpmcflags}" \
 %{?with_system_libev:LIBEV_EMBED=false} \
 %{?with_system_c_ares:CARES_EMBED=false} \
-%{__python} setup.py build --build-base build-2
+%py_build
 
 %if %{with tests}
 cd greentest
@@ -106,7 +106,7 @@ CC="%{__cc}" \
 CFLAGS="%{rpmcflags}" \
 %{?with_system_libev:LIBEV_EMBED=false} \
 %{?with_system_c_ares:CARES_EMBED=false} \
-%{__python3} setup.py build --build-base build-3
+%py3_build
 
 %if %{with tests}
 cd greentest
@@ -121,11 +121,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %{?with_system_libev:LIBEV_EMBED=false} \
 %{?with_system_c_ares:CARES_EMBED=false} \
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
 %py_postclean
 %endif
@@ -133,11 +129,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %{?with_system_libev:LIBEV_EMBED=false} \
 %{?with_system_c_ares:CARES_EMBED=false} \
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %clean
This page took 0.041008 seconds and 4 git commands to generate.