]> git.pld-linux.org Git - packages/python-gevent.git/commitdiff
disable system_libev - a test fails auto/th/python-gevent-1.0-2
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 22 Feb 2014 19:31:21 +0000 (20:31 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 22 Feb 2014 19:31:21 +0000 (20:31 +0100)
test__core_stat.py fails on 32-bit builders when building with
system_libev. This seems serious enough.

known_failures-pld.txt
python-gevent.spec

index 4d174b4046a61a830a206452dca110e4cad601a6..3461aa453e0193aec7eae738fdf4f787ff4ef391 100644 (file)
 ######################################################
 # Tests which fail when building with system libev
 
+# test__core_stat.py fails on 32-bit builders when using system
+# libev
+#
+##  Watcher <stat at 0x86b078c> reacted after 0.0019 seconds (write)
+##  Watcher <stat at 0x86b078c> reacted after 0.0019 seconds (unlink)
+##  Traceback (most recent call last):
+##    File "test__core_stat.py", line 54, in <module>
+##      assert watcher.attr is None, watcher.attr
+##  AssertionError: posix.stat_result(st_mode=2001, st_ino=0L, st_dev=581509237251768320L, st_nlink=1000, st_uid=0, st_gid=0, st_size=5983298792366014472L, st_atime=1393095309, st_mtime=0, st_ctime=-1)
+#* * * -u test__core_stat.py
+
+
 # When  building with system libev the 'fileno()' method of the
 # loop object is not implemented. It seems to be used only be the
 # test code, though.
index ccf52d363884c5675e0a9b001029994aed5bcab6..af0d961c1834f1f1607a2de1435e87889be37679 100644 (file)
@@ -1,11 +1,14 @@
 
 # TODO:
-#      - investigate some of the failing tests
+#      - test__core_stat.py fails on 32-bit builds with system libev
+#        investigate/fix that and enable system libev
+#
+#      - investigate some other failing tests
 #        (now excluded via known_failures-pld.txt)
 
 # Conditional build:
 %bcond_without tests   # do not run tests
-%bcond_without system_libev    # build with system libev (more tests will fail)
+%bcond_with    system_libev    # build with system libev (more tests will fail)
 %bcond_without system_c_ares   # build with system c_ares
 
 %define     module  gevent
This page took 0.071725 seconds and 4 git commands to generate.