]> git.pld-linux.org Git - packages/python-gevent.git/blob - python-gevent.spec
BR: python-devel-src for tests
[packages/python-gevent.git] / python-gevent.spec
1
2 # TODO:
3 #       - investigate some of the failing tests
4 #         (now excluded via known_failures-pld.txt)
5
6 # Conditional build:
7 %bcond_without  tests   # do not run tests
8
9 %define     module  gevent
10 Summary:        A coroutine-based Python networking library
11 Name:           python-%{module}
12 Version:        1.0
13 Release:        1
14 License:        MIT
15 Group:          Development/Languages
16 URL:            http://www.gevent.org/
17 Source0:        http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
18 # Source0-md5:  33aef51a06268f5903fea378e1388e4d
19 Source1:        known_failures-pld.txt
20 BuildRequires:  libevent-devel >= 1.4.0
21 BuildRequires:  python-devel
22 %if %{with tests}
23 BuildRequires: python-greenlet >= 0.3.2
24 BuildRequires: python-test
25 BuildRequires: python-devel-src
26 %endif
27 BuildRequires:  rpm-pythonprov
28 Requires:       python-greenlet >= 0.3.2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 gevent is a coroutine-based Python networking library that uses
33 greenlet to provide a high-level synchronous API on top of libevent
34 event loop.
35
36 Features include:
37   - convenient API around greenlets
38   - familiar synchronization primitives (gevent.event, gevent.queue)
39   - socket module that cooperates
40   - WSGI server on top of libevent-http
41   - DNS requests done through libevent-dns
42   - monkey patching utility to get pure Python modules to cooperate
43
44 %prep
45 %setup -q -n %{module}-%{version}
46
47 cat known_failures.txt %{SOURCE1} > known_failures-merged.txt
48
49 %build
50 CC="%{__cc}" \
51 CFLAGS="%{rpmcflags}" \
52 %{__python} setup.py build
53
54 %if %{with tests}
55 cd greentest
56 PYTHONPATH=.. python testrunner.py --expected ../known_failures-merged.txt
57 cd ..
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__python} setup.py install \
63     --skip-build \
64     --optimize=2 \
65     --root=$RPM_BUILD_ROOT
66
67 %py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc LICENSE README.rst
75 %dir %{py_sitedir}/%{module}
76 %{py_sitedir}/%{module}/*.py[co]
77 %attr(755,root,root) %{py_sitedir}/%{module}/_semaphore.so
78 %attr(755,root,root) %{py_sitedir}/%{module}/_util.so
79 %attr(755,root,root) %{py_sitedir}/%{module}/ares.so
80 %attr(755,root,root) %{py_sitedir}/%{module}/core.so
81 %if "%{py_ver}" > "2.4"
82 %{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
83 %endif
This page took 0.044541 seconds and 4 git commands to generate.