]> git.pld-linux.org Git - packages/python-gevent.git/blob - python-gevent.spec
local proxy settings should not cause test failures
[packages/python-gevent.git] / python-gevent.spec
1
2 # TODO:
3 #       - investigate some of the failing tests
4 #         (now excluded via known_failures-pld.txt)
5
6 # Conditional build:
7 %bcond_without  tests   # do not run tests
8
9 %define     module  gevent
10 Summary:        A coroutine-based Python networking library
11 Name:           python-%{module}
12 Version:        1.0
13 Release:        1
14 License:        MIT
15 Group:          Development/Languages
16 URL:            http://www.gevent.org/
17 Source0:        http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
18 # Source0-md5:  33aef51a06268f5903fea378e1388e4d
19 Source1:        known_failures-pld.txt
20 BuildRequires:  libevent-devel >= 1.4.0
21 BuildRequires:  python-devel
22 %if %{with tests}
23 BuildRequires:  python-greenlet >= 0.3.2
24 BuildRequires:  python-test
25 BuildRequires:  python-devel-src
26 BuildRequires:  rpm-build-macros >= 1.688
27 %endif
28 BuildRequires:  rpm-pythonprov
29 Requires:       python-greenlet >= 0.3.2
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 gevent is a coroutine-based Python networking library that uses
34 greenlet to provide a high-level synchronous API on top of libevent
35 event loop.
36
37 Features include:
38   - convenient API around greenlets
39   - familiar synchronization primitives (gevent.event, gevent.queue)
40   - socket module that cooperates
41   - WSGI server on top of libevent-http
42   - DNS requests done through libevent-dns
43   - monkey patching utility to get pure Python modules to cooperate
44
45 %prep
46 %setup -q -n %{module}-%{version}
47
48 cat known_failures.txt %{SOURCE1} > known_failures-merged.txt
49
50 %build
51 CC="%{__cc}" \
52 CFLAGS="%{rpmcflags}" \
53 %{__python} setup.py build
54
55 %if %{with tests}
56 cd greentest
57 PYTHONPATH=.. python testrunner.py --expected ../known_failures-merged.txt
58 cd ..
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__python} setup.py install \
64     --skip-build \
65     --optimize=2 \
66     --root=$RPM_BUILD_ROOT
67
68 %py_postclean
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc LICENSE README.rst
76 %dir %{py_sitedir}/%{module}
77 %{py_sitedir}/%{module}/*.py[co]
78 %attr(755,root,root) %{py_sitedir}/%{module}/_semaphore.so
79 %attr(755,root,root) %{py_sitedir}/%{module}/_util.so
80 %attr(755,root,root) %{py_sitedir}/%{module}/ares.so
81 %attr(755,root,root) %{py_sitedir}/%{module}/core.so
82 %if "%{py_ver}" > "2.4"
83 %{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
84 %endif
This page took 0.043957 seconds and 4 git commands to generate.