]> git.pld-linux.org Git - packages/python-gevent.git/blob - python-gevent.spec
Version: 1.0
[packages/python-gevent.git] / python-gevent.spec
1 %define     module  gevent
2 Summary:        A coroutine-based Python networking library
3 Name:           python-%{module}
4 Version:        1.0
5 Release:        1
6 License:        MIT
7 Group:          Development/Languages
8 URL:            http://www.gevent.org/
9 Source0:        http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
10 # Source0-md5:  33aef51a06268f5903fea378e1388e4d
11 BuildRequires:  libevent-devel >= 1.4.0
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 Requires:       python-greenlet
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 gevent is a coroutine-based Python networking library that uses
19 greenlet to provide a high-level synchronous API on top of libevent
20 event loop.
21
22 Features include:
23   - convenient API around greenlets
24   - familiar synchronization primitives (gevent.event, gevent.queue)
25   - socket module that cooperates
26   - WSGI server on top of libevent-http
27   - DNS requests done through libevent-dns
28   - monkey patching utility to get pure Python modules to cooperate
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 %build
34 CC="%{__cc}" \
35 CFLAGS="%{rpmcflags}" \
36 %{__python} setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} setup.py install \
41     --skip-build \
42     --optimize=2 \
43     --root=$RPM_BUILD_ROOT
44
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc LICENSE README.rst
53 %dir %{py_sitedir}/%{module}
54 %{py_sitedir}/%{module}/*.py[co]
55 %attr(755,root,root) %{py_sitedir}/%{module}/core.so
56 %if "%{py_ver}" > "2.4"
57 %{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
58 %endif
This page took 0.078483 seconds and 4 git commands to generate.