]> git.pld-linux.org Git - packages/python-gevent.git/blob - python-gevent.spec
R: python-greenlet >= 0.3.2
[packages/python-gevent.git] / python-gevent.spec
1
2 # TODO:
3 #       - investigate some of the failing tests
4 #         (now excluded via known_failures-pld.txt)
5
6 # Conditional build:
7 %bcond_without  tests   # do not run tests
8
9 %define     module  gevent
10 Summary:        A coroutine-based Python networking library
11 Name:           python-%{module}
12 Version:        1.0
13 Release:        1
14 License:        MIT
15 Group:          Development/Languages
16 URL:            http://www.gevent.org/
17 Source0:        http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
18 # Source0-md5:  33aef51a06268f5903fea378e1388e4d
19 Source1:        known_failures-pld.txt
20 BuildRequires:  libevent-devel >= 1.4.0
21 BuildRequires:  python-devel
22 %{?with_tests:BuildRequires: python-greenlet >= 0.3.2}
23 %{?with_tests:BuildRequires: python-test}
24 BuildRequires:  rpm-pythonprov
25 Requires:       python-greenlet >= 0.3.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 gevent is a coroutine-based Python networking library that uses
30 greenlet to provide a high-level synchronous API on top of libevent
31 event loop.
32
33 Features include:
34   - convenient API around greenlets
35   - familiar synchronization primitives (gevent.event, gevent.queue)
36   - socket module that cooperates
37   - WSGI server on top of libevent-http
38   - DNS requests done through libevent-dns
39   - monkey patching utility to get pure Python modules to cooperate
40
41 %prep
42 %setup -q -n %{module}-%{version}
43
44 cat known_failures.txt %{SOURCE1} > known_failures-merged.txt
45
46 %build
47 CC="%{__cc}" \
48 CFLAGS="%{rpmcflags}" \
49 %{__python} setup.py build
50
51 %if %{with tests}
52 cd greentest
53 PYTHONPATH=.. python testrunner.py --expected ../known_failures-merged.txt
54 cd ..
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__python} setup.py install \
60     --skip-build \
61     --optimize=2 \
62     --root=$RPM_BUILD_ROOT
63
64 %py_postclean
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc LICENSE README.rst
72 %dir %{py_sitedir}/%{module}
73 %{py_sitedir}/%{module}/*.py[co]
74 %attr(755,root,root) %{py_sitedir}/%{module}/_semaphore.so
75 %attr(755,root,root) %{py_sitedir}/%{module}/_util.so
76 %attr(755,root,root) %{py_sitedir}/%{module}/ares.so
77 %attr(755,root,root) %{py_sitedir}/%{module}/core.so
78 %if "%{py_ver}" > "2.4"
79 %{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
80 %endif
This page took 0.049691 seconds and 4 git commands to generate.