]> git.pld-linux.org Git - packages/python-flask.git/blob - python-Flask.spec
15c394a79baf570af8cd517c3103ddaa84c6a4c1
[packages/python-flask.git] / python-Flask.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  Flask
6 Summary:        A microframework based on Werkzeug, Jinja2 and good intentions
7 #Summary(pl.UTF-8):     -
8 Name:           python-%{module}
9 Version:        0.8
10 Release:        0.1
11 License:        BSD
12 Group:          Development/Languages/Python
13 Source0:        http://pypi.python.org/packages/source/F/Flask/%{module}-%{version}.tar.gz
14 # Source0-md5:  a5169306cfe49b3b369086f2a63816ab
15 URL:            http://flask.pocoo.org/
16 BuildRequires:  python-Jinja2 >= 2.4
17 BuildRequires:  python-Werkzeug >= 0.6.1
18 BuildRequires:  python-distribute
19 BuildRequires:  rpm-pythonprov
20 # if py_postclean is used
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 Requires:       python-Jinja2 >= 2.4
23 Requires:       python-Werkzeug >= 0.6.1
24 #Requires:              python-libs
25 Requires:               python-modules
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Flask is a microframework for Python based on Werkzeug, Jinja 2 and
31 good intentions.
32
33 #description -l pl.UTF-8
34
35 %prep
36 %setup -q -n %{module}-%{version}
37
38 %build
39 %{__python} setup.py build
40
41 %{?with_tests:%{__python} setup.py test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__python} setup.py install \
46         --skip-build \
47         --optimize=2 \
48         --root=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
54 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS CHANGES README
63 %{py_sitescriptdir}/flask
64 %if "%{py_ver}" > "2.4"
65 %{py_sitescriptdir}/%{module}-*.egg-info
66 %endif
67 %{_examplesdir}/%{name}-%{version}
This page took 0.05628 seconds and 2 git commands to generate.