]> git.pld-linux.org Git - packages/python-djblets.git/blob - python-djblets.spec
- release 2 (by relup.sh)
[packages/python-djblets.git] / python-djblets.spec
1 # TODO
2 # - use system jquery, jquery-ui
3 Summary:        A collection of useful classes and functions for Django
4 Name:           python-djblets
5 Version:        0.7.10
6 Release:        2
7 Group:          Applications/Networking
8 # Djblets is MIT licensed:
9 # http://code.google.com/p/reviewboard/wiki/Djblets
10 # jQuery is bundled in Djblets. Jquery is dual-licensed MIT or GPLv2, hence
11 # the package license is "MIT and (MIT or GPLv2)":
12 # https://www.redhat.com/archives/fedora-legal-list/2009-May/msg00025.html
13 License:        MIT and (MIT or GPL v2)
14 URL:            http://www.review-board.org/
15 Source0:        http://downloads.review-board.org/releases/Djblets/0.7/Djblets-%{version}.tar.gz
16 # Source0-md5:  c2e1987fc6badad138743aa0ea009922
17 BuildRequires:  fslint
18 BuildRequires:  python
19 BuildRequires:  python-devel
20 BuildRequires:  python-django-pipeline >= 1.2.24
21 BuildRequires:  python-modules
22 BuildRequires:  python-setuptools
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  sed >= 4.0
25 Requires:       python-PIL
26 Requires:       python-django >= 1.4.2
27 Requires:       python-django-pipeline >= 1.2.24
28 Requires:       python-feedparser >= 5.1.2
29 Requires:       python-pytz
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A collection of useful classes and functions for Django
35
36 %prep
37 %setup -q -n Djblets-%{version}
38
39 # Remove packaged egg-info so it's regenerated by setup.py
40 %{__rm} -r Djblets*.egg-info
41
42 %build
43 %py_build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %py_install
48
49 %py_postclean
50
51 # hardlink files with fingerprinted variants
52 findup -m $RPM_BUILD_ROOT
53
54 # Remove the "tests" subdirectory to avoid it polluting the main python namespace:
55 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS NEWS README
63 %{py_sitescriptdir}/djblets
64 %{py_sitescriptdir}/Djblets*.egg-info
This page took 0.054721 seconds and 3 git commands to generate.