]> git.pld-linux.org Git - packages/python-billiard.git/commitdiff
new spec
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 17 Nov 2015 08:04:54 +0000 (09:04 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 17 Nov 2015 08:04:54 +0000 (09:04 +0100)
python-billiard.spec [new file with mode: 0644]
unittest2.patch [new file with mode: 0644]

diff --git a/python-billiard.spec b/python-billiard.spec
new file mode 100644 (file)
index 0000000..d8f2539
--- /dev/null
@@ -0,0 +1,149 @@
+#
+# Conditional build:
+%bcond_without doc     # don't build doc
+%bcond_without tests   # do not perform "make test"
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+%define        module  billiard
+Summary:       Multiprocessing Pool Extensions
+Name:          python-%{module}
+Version:       3.3.0.21
+Release:       0.1
+License:       BSD
+Group:         Libraries/Python
+Source0:       https://pypi.python.org/packages/source/b/billiard/%{module}-%{version}.tar.gz
+# Source0-md5: 5304a48344d8f7e821d06f57da8af1f4
+Patch0:                unittest2.patch
+URL:           https://github.com/celery/billiard
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.612
+%if %{with python2}
+BuildRequires: python-devel >= 2.7
+BuildRequires: python-setuptools
+%if %{with tests}
+BuildRequires: python-mock
+BuildRequires: python-nose
+%endif
+%if %{with doc}
+BuildRequires: sphinx-pdg
+%endif
+%endif
+%if %{with python3}
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%if %{with tests}
+BuildRequires: python3-nose
+%endif
+%endif
+Requires:      python-modules
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+billiard is a fork of the Python 2.7 multiprocessing package. The
+multiprocessing package itself is a renamed and updated version of R
+Oudkerk's pyprocessing package. This standalone variant is intended to
+be compatible with Python 2.4 and 2.5, and will draw its
+fixes/improvements from python-trunk.
+
+%package -n python3-%{module}
+Summary:       Multiprocessing Pool Extensions
+Group:         Libraries/Python
+Requires:      python3-modules
+BuildArch:     noarch
+
+%description -n python3-%{module}
+billiard is a fork of the Python 2.7 multiprocessing package. The
+multiprocessing package itself is a renamed and updated version of R
+Oudkerk's pyprocessing package. This standalone variant is intended to
+be compatible with Python 2.4 and 2.5, and will draw its
+fixes/improvements from python-trunk.
+
+%package apidocs
+Summary:       %{module} API documentation
+Summary(pl.UTF-8):     Dokumentacja API %{module}
+Group:         Documentation
+
+%description apidocs
+API documentation for %{module}.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API %{module}.
+
+%prep
+%setup -q -n %{module}-%{version}
+%patch0 -p1
+
+%build
+%if %{with python2}
+CC="%{__cc}" \
+CFLAGS="%{rpmcppflags} %{rpmcflags}" \
+%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+
+%if %{with doc}
+cd Doc
+PYTHONPATH=../build-2/lib sphinx-build -b html -d .build/doctrees . .build/html
+rm -rf .build/html/_sources
+cd ..
+%endif
+%endif
+
+%if %{with python3}
+CC="%{__cc}" \
+CFLAGS="%{rpmcppflags} %{rpmcflags}" \
+%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%{__python} setup.py \
+       build --build-base build-2 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+%py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       build --build-base build-3 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%files
+%defattr(644,root,root,755)
+%doc *.txt README.rst
+%dir %{py_sitedir}/%{module}
+%{py_sitedir}/%{module}/*.py[co]
+%dir %{py_sitedir}/%{module}/dummy
+%{py_sitedir}/%{module}/dummy/*.py[co]
+%dir %{py_sitedir}/%{module}/py2
+%{py_sitedir}/%{module}/py2/*.py[co]
+%dir %{py_sitedir}/%{module}/tests
+%{py_sitedir}/%{module}/tests/*.py[co]
+%{py_sitedir}/_%{module}.so
+%{py_sitedir}/%{module}-%{version}-py*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc *.txt README.rst
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
+%endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc Doc/.build/html/*
+%endif
diff --git a/unittest2.patch b/unittest2.patch
new file mode 100644 (file)
index 0000000..cb3741e
--- /dev/null
@@ -0,0 +1,18 @@
+diff -dur billiard-3.3.0.21.orig/funtests/setup.py billiard-3.3.0.21/funtests/setup.py
+--- billiard-3.3.0.21.orig/funtests/setup.py   2015-09-09 20:37:15.000000000 +0200
++++ billiard-3.3.0.21/funtests/setup.py        2015-11-17 08:44:07.000000000 +0100
+@@ -44,7 +44,6 @@
+     test_suite='nose.collector',
+     build_requires=[
+         'nose',
+-        'unittest2',
+         'coverage>=3.0',
+     ],
+     classifiers=[
+diff -dur billiard-3.3.0.21.orig/requirements/test.txt billiard-3.3.0.21/requirements/test.txt
+--- billiard-3.3.0.21.orig/requirements/test.txt       2015-09-09 20:37:15.000000000 +0200
++++ billiard-3.3.0.21/requirements/test.txt    2015-11-17 08:43:51.000000000 +0100
+@@ -1,3 +1,2 @@
+-unittest2>=0.4.0
+ nose>=1.3.4
+ mock
This page took 0.114065 seconds and 4 git commands to generate.