]> git.pld-linux.org Git - packages/python-SOAP.git/commitdiff
- new from scratch
authormis <mis@pld-linux.org>
Wed, 5 Sep 2001 12:06:34 +0000 (12:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-SOAP.spec -> 1.1

python-SOAP.spec [new file with mode: 0644]

diff --git a/python-SOAP.spec b/python-SOAP.spec
new file mode 100644 (file)
index 0000000..7621436
--- /dev/null
@@ -0,0 +1,45 @@
+Summary:       A SOAP library for Python
+Name:          python-SOAP
+Version:       0.9.7
+Release:       1
+License:       Python License
+Source0:       http://prdownloads.sourceforge.net/pywebsvcs/SOAPpy097.tgz
+URL:           http://sourceforge.net/projects/pywebsvcs/
+Group:         Development/Languages/Python
+Group(de):     Entwicklung/Sprachen/Python
+Group(pl):     Programowanie/Jêzyki/Python
+Requires:      python >= 1.5.2
+BuildRequires: python-devel >= 1.5.2
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
+%define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
+%define python_libdir      %{python_prefix}/lib/python%{python_version}
+%define python_sitedir     %{python_libdir}/site-packages
+
+%description
+Web services for Python programmers, both client and servers. 
+This includes SOAP, WSDL, UDDI, etc.
+
+%prep
+%setup -q -n SOAPpy097
+
+%build
+python -c 'import py_compile; py_compile.compile("SOAP.py");'
+python -O -c 'import py_compile; py_compile.compile("SOAP.py");'
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{python_sitedir}
+install SOAP.py? $RPM_BUILD_ROOT%{python_sitedir}
+gzip -9nf README CHANGELOG docs/*.txt 
+rm -f SOAP.py*
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz docs/*.gz validate tests tools contrib bid *.py
+%{python_sitedir}/*.py?
This page took 0.182736 seconds and 4 git commands to generate.