]> git.pld-linux.org Git - packages/python-PyQtWebEngine.git/blame - python-PyQtWebEngine.spec
- rebuild with python 3.8
[packages/python-PyQtWebEngine.git] / python-PyQtWebEngine.spec
CommitLineData
b7bd06fb
JP
1# Conditional build:
2%bcond_without python2 # CPython 2.x modules
3%bcond_without python3 # CPython 3.x modules
4
5%define module PyQtWebEngine
6# minimal required sip version
7%define sip_ver 2:4.19.14-1
8# last qt version covered by these bindings (minimal required is currently 5.0.0)
9# %define qt_ver %{version}
10%define qt_ver 5.12.0
11
12Summary: Python 2 bindings for the Qt5WebEngine module
13Summary(pl.UTF-8): Wiązania Pythona 2 do modułu Qt5WebEngine
14Name: python-%{module}
9b68eaa4 15Version: 5.13.1
e102428a 16Release: 2
b7bd06fb
JP
17License: GPL v3
18Group: Libraries/Python
9bc70f2b 19Source0: https://www.riverbankcomputing.com/static/Downloads/PyQtWebEngine/%{version}/PyQtWebEngine_gpl-%{version}.tar.gz
9b68eaa4 20# Source0-md5: fa9137741bb6114b97bd8cb7f0925f57
b7bd06fb
JP
21Patch0: install.patch
22URL: http://www.riverbankcomputing.com/software/pyqtwebengine/
9b68eaa4 23BuildRequires: Qt5WebEngine-devel >= %{qt_ver}
b7bd06fb 24BuildRequires: pkgconfig
6b7a241c 25%if %{with python2}
636b818b 26BuildRequires: python-PyQt5
b7bd06fb
JP
27BuildRequires: python-PyQt5-sip >= %{sip_ver}
28BuildRequires: python-sip-devel >= %{sip_ver}
6b7a241c
JP
29%endif
30%if %{with python3}
636b818b 31BuildRequires: python3-PyQt5
b7bd06fb
JP
32BuildRequires: python3-PyQt5-sip >= %{sip_ver}
33BuildRequires: python3-sip-devel >= %{sip_ver}
6b7a241c 34%endif
b7bd06fb
JP
35BuildRequires: qt5-build >= %{qt_ver}
36BuildRequires: qt5-qmake >= %{qt_ver}
37BuildRequires: rpm-pythonprov
38BuildRequires: rpmbuild(macros) >= 1.219
39BuildRequires: sip-PyQt5 >= 5.12
40Requires: python-libs
41Requires: python-PyQt5-sip >= %{sip_ver}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%define _sipfilesdir %{_datadir}/sip
45
46%description
47Python 2 bindings for the Qt5WebEngine module.
48
49%description -l pl.UTF-8
50Wiązania Pythona 2 do modułu Qt5WebEngine.
51
52%package -n python3-PyQtWebEngine
53Summary: Python 3 bindings for the Qt5WebEngine module
54Summary(pl.UTF-8): Wiązania Pythona 2 do modułu Qt5WebEngine
55Group: Libraries/Python
56Requires: python3-libs
57Requires: python3-PyQt5-sip >= %{sip_ver}
58
59%description -n python3-PyQtWebEngine
60Python 3 bindings for the Qt5WebEngine module.
61
62%description -n python3-PyQtWebEngine -l pl.UTF-8
63Wiązania Pythona 2 do modułu Qt5WebEngine.
64
65%package -n sip-PyQtWebEngine
66Summary: SIP files needed to build bindings for Qt5WebEngine
67Summary(pl.UTF-8): Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine
68Group: Development/Languages/Python
69Requires: sip >= %{sip_ver}
70
71%description -n sip-PyQtWebEngine
72SIP files needed to build bindings for Qt5WebEngine.
73
74%description -n sip-PyQtWebEngine -l pl.UTF-8
75Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine.
76
77%package -n qscintilla2-%{module}-api
78Summary: PyQtWebEngine API file for QScintilla
79Summary(pl.UTF-8): Plik API PyQtWebEngine dla QScintilli
80Group: Libraries/Python
81Requires: qscintilla2-qt5 >= 2.2-2
82
83%description -n qscintilla2-%{module}-api
84PyQtWebEngine API file can be used by the QScintilla editor component
85to enable the use of auto-completion and call tips when editing
86PyQtWebEngine code.
87
88%description -n qscintilla2-%{module}-api -l pl.UTF-8
89Plik API PyQtWebEngine może być używany przez komponent edytora
90QScintilla aby umożliwić automatyczne dopełnianie i podpowiedzi przy
91modyfikowaniu kodu wykorzystującego PyQtWebEngine.
92
93%prep
94%setup -q -n PyQtWebEngine_gpl-%{version}
95%patch0 -p1
96
97%build
98%if %{with python2}
99install -d build-py2
100cd build-py2
101%{__python} ../configure.py \
102 --no-dist-info \
103 --verbose \
104 -c -j 3 \
105 -q "%{_bindir}/qmake-qt5"
106
107%{__make}
108cd ..
109%endif
110
111%if %{with python3}
112install -d build-py3
113cd build-py3
114%{__python3} ../configure.py \
115 --no-dist-info \
116 --verbose \
117 -c -j 3 \
118 -q "%{_bindir}/qmake-qt5"
119
120%{__make}
121cd ..
122%endif
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%if %{with python3}
128%{__make} -C build-py3 install \
129 INSTALL_ROOT=$RPM_BUILD_ROOT
130
131%endif
132
133%if %{with python2}
134%{__make} -C build-py2 install \
135 INSTALL_ROOT=$RPM_BUILD_ROOT
136
137%py_comp $RPM_BUILD_ROOT%{py_sitedir}
138%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
139%endif
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%if %{with python2}
145%files
146%defattr(644,root,root,755)
147%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngine.so
148%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineCore.so
149%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineWidgets.so
fd884756
JP
150%{py_sitedir}/PyQt5/QtWebEngine.pyi
151%{py_sitedir}/PyQt5/QtWebEngineCore.pyi
152%{py_sitedir}/PyQt5/QtWebEngineWidgets.pyi
b7bd06fb
JP
153%endif
154
155%if %{with python3}
156%files -n python3-PyQtWebEngine
157%defattr(644,root,root,755)
158%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngine.so
159%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineCore.so
160%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineWidgets.so
fd884756
JP
161%{py3_sitedir}/PyQt5/QtWebEngine.pyi
162%{py3_sitedir}/PyQt5/QtWebEngineCore.pyi
163%{py3_sitedir}/PyQt5/QtWebEngineWidgets.pyi
b7bd06fb
JP
164%endif
165
166%files -n sip-PyQtWebEngine
167%defattr(644,root,root,755)
168%{_sipfilesdir}/PyQt5/QtWebEngine
169%{_sipfilesdir}/PyQt5/QtWebEngineCore
170%{_sipfilesdir}/PyQt5/QtWebEngineWidgets
171
172%files -n qscintilla2-%{module}-api
173%defattr(644,root,root,755)
174%{_datadir}/qt5/qsci/api/python/PyQtWebEngine.api
This page took 0.617532 seconds and 4 git commands to generate.