]> git.pld-linux.org Git - packages/python-PyQtWebEngine.git/blame - python-PyQtWebEngine.spec
BR: python-PyQt5
[packages/python-PyQtWebEngine.git] / python-PyQtWebEngine.spec
CommitLineData
b7bd06fb
JP
1# Conditional build:
2%bcond_without python2 # CPython 2.x modules
3%bcond_without python3 # CPython 3.x modules
4
5%define module PyQtWebEngine
6# minimal required sip version
7%define sip_ver 2:4.19.14-1
8# last qt version covered by these bindings (minimal required is currently 5.0.0)
9# %define qt_ver %{version}
10%define qt_ver 5.12.0
11
12Summary: Python 2 bindings for the Qt5WebEngine module
13Summary(pl.UTF-8): Wiązania Pythona 2 do modułu Qt5WebEngine
14Name: python-%{module}
9bc70f2b 15Version: 5.13.0
b7bd06fb
JP
16Release: 1
17License: GPL v3
18Group: Libraries/Python
9bc70f2b
JP
19Source0: https://www.riverbankcomputing.com/static/Downloads/PyQtWebEngine/%{version}/PyQtWebEngine_gpl-%{version}.tar.gz
20# Source0-md5: 75ed399adfe04858e6670325fbd2be2c
b7bd06fb
JP
21Patch0: install.patch
22URL: http://www.riverbankcomputing.com/software/pyqtwebengine/
23BuildRequires: Qt5WebEngine-devel >= %{qt_ver}}
24BuildRequires: pkgconfig
636b818b 25BuildRequires: python-PyQt5
b7bd06fb
JP
26BuildRequires: python-PyQt5-sip >= %{sip_ver}
27BuildRequires: python-sip-devel >= %{sip_ver}
636b818b 28BuildRequires: python3-PyQt5
b7bd06fb
JP
29BuildRequires: python3-PyQt5-sip >= %{sip_ver}
30BuildRequires: python3-sip-devel >= %{sip_ver}
31BuildRequires: qt5-build >= %{qt_ver}
32BuildRequires: qt5-qmake >= %{qt_ver}
33BuildRequires: rpm-pythonprov
34BuildRequires: rpmbuild(macros) >= 1.219
35BuildRequires: sip-PyQt5 >= 5.12
36Requires: python-libs
37Requires: python-PyQt5-sip >= %{sip_ver}
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sipfilesdir %{_datadir}/sip
41
42%description
43Python 2 bindings for the Qt5WebEngine module.
44
45%description -l pl.UTF-8
46Wiązania Pythona 2 do modułu Qt5WebEngine.
47
48%package -n python3-PyQtWebEngine
49Summary: Python 3 bindings for the Qt5WebEngine module
50Summary(pl.UTF-8): Wiązania Pythona 2 do modułu Qt5WebEngine
51Group: Libraries/Python
52Requires: python3-libs
53Requires: python3-PyQt5-sip >= %{sip_ver}
54
55%description -n python3-PyQtWebEngine
56Python 3 bindings for the Qt5WebEngine module.
57
58%description -n python3-PyQtWebEngine -l pl.UTF-8
59Wiązania Pythona 2 do modułu Qt5WebEngine.
60
61%package -n sip-PyQtWebEngine
62Summary: SIP files needed to build bindings for Qt5WebEngine
63Summary(pl.UTF-8): Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine
64Group: Development/Languages/Python
65Requires: sip >= %{sip_ver}
66
67%description -n sip-PyQtWebEngine
68SIP files needed to build bindings for Qt5WebEngine.
69
70%description -n sip-PyQtWebEngine -l pl.UTF-8
71Pliki SIP potrzebne do budowania wiązań do Qt5WebEngine.
72
73%package -n qscintilla2-%{module}-api
74Summary: PyQtWebEngine API file for QScintilla
75Summary(pl.UTF-8): Plik API PyQtWebEngine dla QScintilli
76Group: Libraries/Python
77Requires: qscintilla2-qt5 >= 2.2-2
78
79%description -n qscintilla2-%{module}-api
80PyQtWebEngine API file can be used by the QScintilla editor component
81to enable the use of auto-completion and call tips when editing
82PyQtWebEngine code.
83
84%description -n qscintilla2-%{module}-api -l pl.UTF-8
85Plik API PyQtWebEngine może być używany przez komponent edytora
86QScintilla aby umożliwić automatyczne dopełnianie i podpowiedzi przy
87modyfikowaniu kodu wykorzystującego PyQtWebEngine.
88
89%prep
90%setup -q -n PyQtWebEngine_gpl-%{version}
91%patch0 -p1
92
93%build
94%if %{with python2}
95install -d build-py2
96cd build-py2
97%{__python} ../configure.py \
98 --no-dist-info \
99 --verbose \
100 -c -j 3 \
101 -q "%{_bindir}/qmake-qt5"
102
103%{__make}
104cd ..
105%endif
106
107%if %{with python3}
108install -d build-py3
109cd build-py3
110%{__python3} ../configure.py \
111 --no-dist-info \
112 --verbose \
113 -c -j 3 \
114 -q "%{_bindir}/qmake-qt5"
115
116%{__make}
117cd ..
118%endif
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%if %{with python3}
124%{__make} -C build-py3 install \
125 INSTALL_ROOT=$RPM_BUILD_ROOT
126
127%endif
128
129%if %{with python2}
130%{__make} -C build-py2 install \
131 INSTALL_ROOT=$RPM_BUILD_ROOT
132
133%py_comp $RPM_BUILD_ROOT%{py_sitedir}
134%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
135%endif
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%if %{with python2}
141%files
142%defattr(644,root,root,755)
143%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngine.so
144%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineCore.so
145%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebEngineWidgets.so
fd884756
JP
146%{py_sitedir}/PyQt5/QtWebEngine.pyi
147%{py_sitedir}/PyQt5/QtWebEngineCore.pyi
148%{py_sitedir}/PyQt5/QtWebEngineWidgets.pyi
b7bd06fb
JP
149%endif
150
151%if %{with python3}
152%files -n python3-PyQtWebEngine
153%defattr(644,root,root,755)
154%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngine.so
155%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineCore.so
156%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebEngineWidgets.so
fd884756
JP
157%{py3_sitedir}/PyQt5/QtWebEngine.pyi
158%{py3_sitedir}/PyQt5/QtWebEngineCore.pyi
159%{py3_sitedir}/PyQt5/QtWebEngineWidgets.pyi
b7bd06fb
JP
160%endif
161
162%files -n sip-PyQtWebEngine
163%defattr(644,root,root,755)
164%{_sipfilesdir}/PyQt5/QtWebEngine
165%{_sipfilesdir}/PyQt5/QtWebEngineCore
166%{_sipfilesdir}/PyQt5/QtWebEngineWidgets
167
168%files -n qscintilla2-%{module}-api
169%defattr(644,root,root,755)
170%{_datadir}/qt5/qsci/api/python/PyQtWebEngine.api
This page took 0.524378 seconds and 4 git commands to generate.