]> git.pld-linux.org Git - packages/python-MySQLdb.git/blob - python-MySQLdb.spec
rebuild with separate debuginfo build-ids
[packages/python-MySQLdb.git] / python-MySQLdb.spec
1 Summary:        A Python interface to MySQL
2 Summary(pl.UTF-8):      Interfejs Pythona do MySQL
3 Name:           python-MySQLdb
4 Version:        1.2.3
5 Release:        12
6 License:        GPL
7 Group:          Libraries/Python
8 Source0:        http://dl.sourceforge.net/mysql-python/MySQL-python-%{version}.tar.gz
9 # Source0-md5:  215eddb6d853f6f4be5b4afc4154292f
10 URL:            http://sourceforge.net/projects/mysql-python/
11 BuildRequires:  rpmbuild(macros) >= 1.710
12 BuildRequires:  mysql-devel >= 4.0.10
13 BuildRequires:  python-devel >= 1:2.5
14 BuildRequires:  python-modules
15 BuildRequires:  python-setuptools
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  zlib-devel
18 %pyrequires_eq  python-modules
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 An interface to the popular MySQL database server for Python. The
23 design goals are:
24
25 - Compliance with Python database API version 2.0
26 - Thread-safety
27 - Thread-friendliness (threads will not block each other)
28
29 %description -l pl.UTF-8
30 Ten pakiet zapewnia dostęp do baz danych MySQL z poziomu skryptów
31 języka Python. Projekt jest tworzony z myślą o:
32 - zgodności z bazodanowym API Pythona w wersji 2.0
33 - przyjaznością dla wątków (wątki nie zablokują się nawzajem).
34
35 %prep
36 %setup  -q -n MySQL-python-%{version}
37
38 %build
39 CFLAGS="%{rpmcflags} -DHAVE_OPENSSL=1"
40 %py_build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %py_install
46
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README doc/*
55 %attr(755,root,root) %{py_sitedir}/*.so
56 %{py_sitedir}/*.py[co]
57 %dir %{py_sitedir}/MySQLdb
58 %{py_sitedir}/MySQLdb/*.py[co]
59 %dir %{py_sitedir}/MySQLdb/constants
60 %{py_sitedir}/MySQLdb/constants/*.py[co]
61 %{py_sitedir}/*.egg-info
This page took 0.07457 seconds and 3 git commands to generate.