]> git.pld-linux.org Git - packages/python-M2Crypto.git/commitdiff
- up to 0.38.0 auto/th/python-M2Crypto-0.38.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Oct 2021 20:37:41 +0000 (22:37 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Oct 2021 20:37:41 +0000 (22:37 +0200)
python-M2Crypto-store2ssl.patch [deleted file]
python-M2Crypto-swig.patch [deleted file]
python-M2Crypto.spec

diff --git a/python-M2Crypto-store2ssl.patch b/python-M2Crypto-store2ssl.patch
deleted file mode 100644 (file)
index d1ce88d..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- m2crypto-0.17beta1/SWIG/_ssl.i.orig        2006-04-01 00:11:55.000000000 +0200
-+++ m2crypto-0.17beta1/SWIG/_ssl.i     2006-12-06 23:41:00.895934552 +0100
-@@ -699,5 +699,10 @@
- {
-   return SSL_is_init_finished(ssl);
- }
-+
-+SSL *x509_store_ctx_get_ssl(X509_STORE_CTX *ctx) {
-+  return (SSL *)X509_STORE_CTX_get_app_data(ctx);
-+}
-+
- %}
diff --git a/python-M2Crypto-swig.patch b/python-M2Crypto-swig.patch
deleted file mode 100644 (file)
index ad40a14..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
---- m2crypto-0.18.1/SWIG/_x509.i.orig  2007-06-14 00:57:34.000000000 +0200
-+++ m2crypto-0.18.1/SWIG/_x509.i       2007-11-25 21:43:40.598378211 +0100
-@@ -279,19 +279,19 @@
- %constant int XN_FLAG_SPC_EQ = (1 << 23);
- %constant int XN_FLAG_DUMP_UNKNOWN_FIELDS = (1 << 24);
- %constant int XN_FLAG_FN_ALIGN = (1 << 25);
--%constant int XN_FLAG_ONELINE =(ASN1_STRFLGS_RFC2253 | \
--            ASN1_STRFLGS_ESC_QUOTE | \
--            XN_FLAG_SEP_CPLUS_SPC | \
-+%constant int XN_FLAG_ONELINE =(ASN1_STRFLGS_RFC2253 |
-+            ASN1_STRFLGS_ESC_QUOTE |
-+            XN_FLAG_SEP_CPLUS_SPC |
-             XN_FLAG_SPC_EQ);
--%constant int XN_FLAG_MULTILINE = (ASN1_STRFLGS_ESC_CTRL | \
--            ASN1_STRFLGS_ESC_MSB | \
--            XN_FLAG_SEP_MULTILINE | \
--            XN_FLAG_SPC_EQ | \
--            XN_FLAG_FN_LN | \
-+%constant int XN_FLAG_MULTILINE = (ASN1_STRFLGS_ESC_CTRL |
-+            ASN1_STRFLGS_ESC_MSB |
-+            XN_FLAG_SEP_MULTILINE |
-+            XN_FLAG_SPC_EQ |
-+            XN_FLAG_FN_LN |
-             XN_FLAG_FN_ALIGN);
--%constant int XN_FLAG_RFC2253 = (ASN1_STRFLGS_RFC2253 | \
--            XN_FLAG_SEP_COMMA_PLUS | \
--            XN_FLAG_DN_REV | \
-+%constant int XN_FLAG_RFC2253 = (ASN1_STRFLGS_RFC2253 |
-+            XN_FLAG_SEP_COMMA_PLUS |
-+            XN_FLAG_DN_REV |
-             XN_FLAG_DUMP_UNKNOWN_FIELDS);
- /* Cribbed from rsa.h. */
---- M2Crypto-0.27.0/SWIG/_asn1.i~      2017-10-05 22:43:17.000000000 +0200
-+++ M2Crypto-0.27.0/SWIG/_asn1.i       2017-10-29 10:43:11.639300285 +0100
-@@ -107,11 +107,11 @@ extern int ASN1_INTEGER_cmp(ASN1_INTEGER
- %constant int ASN1_STRFLGS_DUMP_UNKNOWN = 0x100;
- %constant int ASN1_STRFLGS_DUMP_DER = 0x200;
--%constant int ASN1_STRFLGS_RFC2253 = (ASN1_STRFLGS_ESC_2253 | \
--                ASN1_STRFLGS_ESC_CTRL | \
--                ASN1_STRFLGS_ESC_MSB | \
--                ASN1_STRFLGS_UTF8_CONVERT | \
--                ASN1_STRFLGS_DUMP_UNKNOWN | \
-+%constant int ASN1_STRFLGS_RFC2253 = (ASN1_STRFLGS_ESC_2253 |
-+                ASN1_STRFLGS_ESC_CTRL |
-+                ASN1_STRFLGS_ESC_MSB |
-+                ASN1_STRFLGS_UTF8_CONVERT |
-+                ASN1_STRFLGS_DUMP_UNKNOWN |
-                 ASN1_STRFLGS_DUMP_DER);
- %inline %{
-
index df3fde6c6a1fe7d8542b026a576893694e24f130..9512e2edf448a323e2969f309a863a3faebce31d 100644 (file)
 Summary:       Python interface to OpenSSL
 Summary(pl.UTF-8):     Interfejs Pythona do OpenSSL
 Name:          python-M2Crypto
-Version:       0.30.1
-Release:       5
+Version:       0.38.0
+Release:       1
 License:       BSD-like
 Group:         Libraries/Python
 #Source0Download: https://pypi.python.org/simple/m2crypto/
 Source0:       https://pypi.debian.net/M2Crypto/M2Crypto-%{version}.tar.gz
-# Source0-md5: 7fce3cbf85eb84a669682892b935746b
-Patch0:                %{name}-store2ssl.patch
-Patch1:                %{name}-swig.patch
+# Source0-md5: 8f39bfac730b6567e0c2179d15318c60
 URL:           https://gitlab.com/m2crypto/m2crypto
 BuildRequires: openssl-devel >= 1.0.1e
 %if %{with python2}
@@ -85,8 +83,6 @@ pliku LICENCE.
 
 %prep
 %setup -q -n M2Crypto-%{version}
-%patch0 -p1
-%patch1 -p1
 
 %build
 %if %{with python2}
This page took 0.073332 seconds and 4 git commands to generate.