]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- swig_sources.patch for modern method signature
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1
2 Summary:        Python interface to OpenSSL
3 Summary(pl):    Interfejs Pythona do OpenSSL
4 Name:           python-M2Crypto
5 Version:        0.13
6 Release:        4
7 License:        BSD-like
8 Source0:        http://sandbox.rulemaker.net/ngps/Dist/m2crypto-%{version}.zip
9 # Source0-md5:  be2790a34349ab452dddbcfe4c95606a
10 #               http://sandbox.rulemaker.net/ngps/Dist/0.13p1.patch
11 Patch0:         %{name}-0.13p1.patch
12 Patch1:         %{name}-swig_sources.patch
13 URL:            http://sandbox.rulemaker.net/ngps/m2/
14 Group:          Development/Languages/Python
15 %pyrequires_eq  python
16 BuildRequires:  python-devel >= 2.2.1
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  swig >= 1.3.17
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  unzip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 M2Crypto makes accessible to the Python programmer the following:
25 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
26 - SSL functionality to implement clients and servers.
27 - S/MIME v2.
28
29 M2Crypto is released under a very liberal BSD-like licence. See
30 LICENCE for details.
31
32 %description -l pl
33 M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
34 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
35 - SSL do implementacji klientów i serwerów
36 - S/MIME v2.
37
38 %prep
39 %setup -q -n m2crypto-%{version}
40 %patch0 -p0
41 %patch1 -p1
42
43 %build
44 python setup.py build 
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{py_sitedir}
49
50 python setup.py install \
51         --root=$RPM_BUILD_ROOT \
52         --optimize=2
53
54 # shutup check-files
55 find $RPM_BUILD_ROOT/%{py_sitedir} -name \*.py \
56         -exec rm {} \;
57         
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc BUGS CHANGES INSTALL LICENCE README doc/*.html demo
64 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
65 %{py_sitedir}/M2Crypto/*.py[oc]
66 %dir %{py_sitedir}/M2Crypto/SSL
67 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
68 %dir %{py_sitedir}/M2Crypto/PGP
69 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
This page took 0.072029 seconds and 3 git commands to generate.