]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- proper Summary
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Name:           python-M2Crypto
3 Version:        0.06
4 Release:        1
5 License:        BSD-style
6 Source0:        http://www.pobox.org.sg/home/ngps/m2/m2crypto-%{version}.zip
7 URL:            http://www.pobox.org.sg/home/ngps/m2/
8 Group:          Development/Languages/Python
9 Group(de):      Entwicklung/Sprachen/Python
10 Group(pl):      Programowanie/Jêzyki/Python
11 Requires:       python >= 1.5.2
12 BuildRequires:  python-devel >= 1.5.2
13 BuildRequires:  openssl-devel >= 0.9.6
14 BuildRequires:  swig 
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
18 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
19 %define python_includedir  %{_includedir}/python%{python_version}
20 %define python_libdir      %{python_prefix}/lib/python%{python_version}
21 %define python_sitedir     %{python_libdir}/site-packages
22 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
23 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
24
25 %description
26 M2Crypto makes accessible to the Python programmer the following:
27 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
28 - SSL functionality to implement clients and servers.
29 - S/MIME v2.
30
31 M2Crypto is released under a very liberal BSD-style licence. See 
32 LICENCE for details.
33
34 %prep
35 %setup -q -n m2crypto-%{version}
36
37 %build
38 make -C swig INCLUDE="-I. -I%{python_includedir}"
39 cd M2Crypto
40 %{python_compile}
41 %{python_compile_opt}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{python_sitedir}
46
47 find M2Crypto -name \*.py | xargs -r rm -f
48 cp -a M2Crypto $RPM_BUILD_ROOT%{python_sitedir}
49
50 gzip -9nf BUGS CHANGES INSTALL LICENCE README STORIES
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc *.gz doc/*.html demo 
58 %{python_sitedir}/M2Crypto
This page took 0.763434 seconds and 3 git commands to generate.