]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
aa96700f2a429f4b049cdd7aa83b0b706bcdb908
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        A SOAP library for Python
2 Name:           python-M2Crypto
3 Version:        0.06
4 Release:        1
5 License:        BSD-style
6 Source0:        http://www.pobox.org.sg/home/ngps/m2/m2crypto-%{version}.zip
7 URL:            http://www.pobox.org.sg/home/ngps/m2/
8 Group:          Development/Languages/Python
9 Group(de):      Entwicklung/Sprachen/Python
10 Group(pl):      Programowanie/Jêzyki/Python
11 Requires:       python >= 1.5.2
12 BuildRequires:  python-devel >= 1.5.2
13 BuildRequires:  swig 
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
17 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
18 %define python_includedir  %{_includedir}/python%{python_version}
19 %define python_libdir      %{python_prefix}/lib/python%{python_version}
20 %define python_sitedir     %{python_libdir}/site-packages
21 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
22 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
23
24 %description
25 M2Crypto makes accessible to the Python programmer the following:
26 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
27 - SSL functionality to implement clients and servers.
28 - S/MIME v2.
29
30 M2Crypto is released under a very liberal BSD-style licence. See 
31 LICENCE for details.
32
33 %prep
34 %setup -q -n m2crypto-%{version}
35
36 %build
37 make -C swig INCLUDE="-I. -I%{python_includedir}"
38 cd M2Crypto
39 %{python_compile}
40 %{python_compile_opt}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{python_sitedir}
45
46 find M2Crypto -name \*.py | xargs -r rm -f
47 cp -a M2Crypto $RPM_BUILD_ROOT%{python_sitedir}
48
49 gzip -9nf BUGS CHANGES INSTALL LICENCE README STORIES
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc *.gz doc/*.html demo 
57 %{python_sitedir}/M2Crypto
This page took 0.138854 seconds and 2 git commands to generate.