]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
912d5625ae94b5e1eb94ebe751ce59fa824b5eba
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Summary(pl.UTF-8):      Interfejs Pythona do OpenSSL
3 Name:           python-M2Crypto
4 Version:        0.20.2
5 Release:        4
6 License:        BSD-like
7 Group:          Libraries/Python
8 Source0:        http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-%{version}.tar.gz
9 # Source0-md5:  6c24410410d6eb1920ea43f77a93613a
10 Patch0:         %{name}-swig_sources.patch
11 Patch1:         %{name}-store2ssl.patch
12 Patch2:         %{name}-swig.patch
13 Patch3:         %{name}-openssl.patch
14 URL:            http://wiki.osafoundation.org/bin/view/Projects/MeTooCrypto
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  python-modules
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  swig-python >= 1.3.24
21 BuildRequires:  unzip
22 %pyrequires_eq  python
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 M2Crypto makes accessible to the Python programmer the following:
27 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
28 - SSL functionality to implement clients and servers.
29 - S/MIME v2.
30
31 M2Crypto is released under a very liberal BSD-like licence. See
32 LICENCE for details.
33
34 %description -l pl.UTF-8
35 M2Crypto udostępnia z poziomu Pythona następujące funkcje:
36 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
37 - SSL do implementacji klientów i serwerów
38 - S/MIME v2.
39
40 %prep
41 %setup -q -n M2Crypto-%{version}
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3 -p0
46
47 find demo -type d -name CVS | xargs rm -rf
48
49 %build
50 python setup.py build
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
55
56 python setup.py install \
57         --root=$RPM_BUILD_ROOT \
58         --optimize=2
59
60 %py_postclean
61 cp -r demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CHANGES LICENCE README doc/*.html
69 %dir %{py_sitedir}/M2Crypto
70 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
71 %{py_sitedir}/M2Crypto/*.py[oc]
72 %dir %{py_sitedir}/M2Crypto/SSL
73 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
74 %dir %{py_sitedir}/M2Crypto/PGP
75 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
76 %{py_sitedir}/M2Crypto-*.egg-info
77 %dir %{_examplesdir}/%{name}-%{version}
78 %{_examplesdir}/%{name}-%{version}/*
This page took 0.052493 seconds and 2 git commands to generate.