]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- package .egg-info for python 2.5
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 # NOTE: doesn't work properly (at least TLS in cjc) when built with recent swig
2 Summary:        Python interface to OpenSSL
3 Summary(pl):    Interfejs Pythona do OpenSSL
4 Name:           python-M2Crypto
5 Version:        0.16
6 Release:        2
7 License:        BSD-like
8 Group:          Development/Languages/Python
9 Source0:        http://wiki.osafoundation.org/pub/Projects/MeTooCrypto/m2crypto-%{version}.tar.gz
10 # Source0-md5:  6fc06583a2be56fc2a46872a0540d78e
11 Patch0:         %{name}-swig_sources.patch
12 URL:            http://wiki.osafoundation.org/bin/view/Projects/MeTooCrypto
13 BuildRequires:  openssl-devel >= 0.9.7d
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  swig >= 1.3.24
16 #BuildRequires: swig-python >= 1.3.25
17 BuildRequires:  unzip
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 M2Crypto makes accessible to the Python programmer the following:
23 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
24 - SSL functionality to implement clients and servers.
25 - S/MIME v2.
26
27 M2Crypto is released under a very liberal BSD-like licence. See
28 LICENCE for details.
29
30 %description -l pl
31 M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
32 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
33 - SSL do implementacji klientów i serwerów
34 - S/MIME v2.
35
36 %prep
37 %setup -q -n m2crypto-%{version}
38 %patch0 -p1
39
40 find demo -type d -name CVS | xargs rm -rf
41
42 %build
43 python setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{py_sitedir}
48
49 python setup.py install \
50         --root=$RPM_BUILD_ROOT \
51         --optimize=2
52
53 # shutup check-files
54 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py \
55         -exec rm {} \;
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CHANGES LICENCE README doc/*.html demo
63 %dir %{py_sitedir}/M2Crypto
64 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
65 %{py_sitedir}/M2Crypto/*.py[oc]
66 %dir %{py_sitedir}/M2Crypto/SSL
67 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
68 %dir %{py_sitedir}/M2Crypto/PGP
69 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
70 %{py_sitedir}/M2Crypto-*.egg-info
This page took 0.029191 seconds and 3 git commands to generate.