]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- updated to 0.21.1
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Summary(pl.UTF-8):      Interfejs Pythona do OpenSSL
3 Name:           python-M2Crypto
4 Version:        0.21.1
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries/Python
8 Source0:        http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-%{version}.tar.gz
9 # Source0-md5:  f93d8462ff7646397a9f77a2fe602d17
10 Patch0:         %{name}-swig_sources.patch
11 Patch1:         %{name}-store2ssl.patch
12 Patch2:         %{name}-swig.patch
13 URL:            http://wiki.osafoundation.org/bin/view/Projects/MeTooCrypto
14 BuildRequires:  openssl-devel >= 0.9.7d
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 BuildRequires:  swig-python >= 1.3.24
20 BuildRequires:  unzip
21 %pyrequires_eq  python
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 M2Crypto makes accessible to the Python programmer the following:
26 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
27 - SSL functionality to implement clients and servers.
28 - S/MIME v2.
29
30 M2Crypto is released under a very liberal BSD-like licence. See
31 LICENCE for details.
32
33 %description -l pl.UTF-8
34 M2Crypto udostępnia z poziomu Pythona następujące funkcje:
35 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
36 - SSL do implementacji klientów i serwerów
37 - S/MIME v2.
38
39 %prep
40 %setup -q -n M2Crypto-%{version}
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44
45 find demo -type d -name CVS | xargs rm -rf
46
47 %build
48 %{__python} setup.py build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
53
54 %{__python} setup.py install \
55         --root=$RPM_BUILD_ROOT \
56         --optimize=2
57
58 %py_postclean
59 cp -r demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CHANGES LICENCE README doc/*.html
67 %dir %{py_sitedir}/M2Crypto
68 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
69 %{py_sitedir}/M2Crypto/*.py[oc]
70 %dir %{py_sitedir}/M2Crypto/SSL
71 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
72 %dir %{py_sitedir}/M2Crypto/PGP
73 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
74 %{py_sitedir}/M2Crypto-*.egg-info
75 %{_examplesdir}/%{name}-%{version}
This page took 0.067439 seconds and 3 git commands to generate.