]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- rel 3; fix openssl 1.0.0 build
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Summary(pl.UTF-8):      Interfejs Pythona do OpenSSL
3 Name:           python-M2Crypto
4 Version:        0.20.2
5 Release:        3
6 License:        BSD-like
7 Group:          Libraries/Python
8 Source0:        http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-%{version}.tar.gz
9 # Source0-md5:  6c24410410d6eb1920ea43f77a93613a
10 Patch0:         %{name}-swig_sources.patch
11 Patch1:         %{name}-store2ssl.patch
12 Patch2:         %{name}-swig.patch
13 Patch3:         %{name}-openssl.patch
14 URL:            http://wiki.osafoundation.org/bin/view/Projects/MeTooCrypto
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 BuildRequires:  swig-python >= 1.3.24
19 BuildRequires:  unzip
20 %pyrequires_eq  python
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 M2Crypto makes accessible to the Python programmer the following:
25 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
26 - SSL functionality to implement clients and servers.
27 - S/MIME v2.
28
29 M2Crypto is released under a very liberal BSD-like licence. See
30 LICENCE for details.
31
32 %description -l pl.UTF-8
33 M2Crypto udostępnia z poziomu Pythona następujące funkcje:
34 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
35 - SSL do implementacji klientów i serwerów
36 - S/MIME v2.
37
38 %prep
39 %setup -q -n M2Crypto-%{version}
40 %patch0 -p1
41 %patch1 -p1
42 %patch2 -p1
43 %patch3 -p0
44
45 find demo -type d -name CVS | xargs rm -rf
46
47 %build
48 python setup.py build
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
53
54 python setup.py install \
55         --root=$RPM_BUILD_ROOT \
56         --optimize=2
57
58 %py_postclean
59 cp -r demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CHANGES LICENCE README doc/*.html
67 %dir %{py_sitedir}/M2Crypto
68 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
69 %{py_sitedir}/M2Crypto/*.py[oc]
70 %dir %{py_sitedir}/M2Crypto/SSL
71 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
72 %dir %{py_sitedir}/M2Crypto/PGP
73 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
74 %{py_sitedir}/M2Crypto-*.egg-info
75 %dir %{_examplesdir}/%{name}-%{version}
76 %{_examplesdir}/%{name}-%{version}/*
This page took 0.068977 seconds and 3 git commands to generate.