]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
Do not use installed pylint for generating docs
[packages/pylint.git] / pylint.spec
1 # TODO:
2 # - include examples in package
3
4 # Conditional build:
5 %bcond_without  python2 # Python 2.x version
6 %bcond_without  python3 # Python 3.x version (available as 'py3lint')
7
8 Summary:        Python tool that checks if a module satisfy a coding standard
9 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
10 Name:           pylint
11 Version:        1.2.1
12 Release:        1
13 License:        GPL v2+
14 Group:          Development/Languages/Python
15 Source0:        https://pypi.python.org/packages/source/p/pylint/pylint-%{version}.tar.gz
16 # Source0-md5:  c49008134f2905cc88251f19d33e616c
17 Patch0:         %{name}-type_error.patch
18 URL:            http://www.pylint.org/
19 %if %{with python2}
20 BuildRequires:  python-devel
21 BuildRequires:  python-modules >= 1:2.5
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-2to3
25 BuildRequires:  python3-devel
26 BuildRequires:  python3-distribute
27 BuildRequires:  python3-modules >= 1:3.2
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.219
31 BuildRequires:  sphinx-pdg
32 Requires:       python-astroid >= 0.24.3
33 Requires:       python-logilab-common >= 0.53.0
34 Requires:       python-modules
35 Suggests:       python-devel-src
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # /etc/pylintrc is deliberately packaged to both packages with same name
40 %define         _duplicate_files_terminate_build        0
41
42 %description
43 Python tool that checks if a module satisfy a coding standard.
44
45 %description -l pl.UTF-8
46 Narzędzie sprawdzające zgodność modułów napisanych w języku Python z
47 regułami tworzenia kodu źródłowego.
48
49 %package gui
50 Summary:        GUI for pylint
51 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
52 Group:          Development/Languages/Python
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       python-tkinter
55
56 %description gui
57 Tk based GUI for pylint.
58
59 %description gui -l pl.UTF-8
60 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
61
62 %package -n py3lint
63 Summary:        Python tool that checks if a module satisfy a coding standard
64 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
65 Group:          Development/Languages/Python
66 Requires:       python3-astroid >= 0.24.3
67 Requires:       python3-logilab-common >= 0.53.0
68 Obsoletes:      pylint-python3 < 1.0.0-2
69
70 %description -n py3lint
71 Python tool that checks if a module satisfy a coding standard.
72
73 Python 3.x version, available via the 'py3lint' command.
74
75 %description -n py3lint -l pl.UTF-8
76 Narzędzie sprawdzające zgodność modułów napisanych w języku Python z
77 regułami tworzenia kodu źródłowego.
78
79 Wersja dla Pythona 3.x, dostępna przez polecenie 'py3lint'.
80
81 %package -n py3lint-gui
82 Summary:        GUI for pylint
83 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
84 Group:          Development/Languages/Python
85 Requires:       py3lint = %{version}-%{release}
86 Requires:       python3-tkinter
87 Obsoletes:      pylint-python3-gui < 1.0.0-2
88
89 %description -n py3lint-gui
90 Tk based GUI for pylint.
91
92 %description -n py3lint-gui -l pl.UTF-8
93 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %if %{with python2}
101 %{__python} setup.py build
102 %else
103 # for sphinx
104 install -d build/lib
105 ln -sf ../.. build/lib/pylint
106 %endif
107
108 %if %{with python3}
109 export NO_SETUPTOOLS=1
110 %{__python3} setup.py build --build-base=build3
111 unset NO_SETUPTOOLS
112 %endif
113
114 export PYTHONPATH=$PWD/build/lib
115 %{__make} -C doc text
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
121
122 %if %{with python3}
123 export NO_SETUPTOOLS=1
124 %{__python3} setup.py build --build-base=build3 install \
125         --optimize=2 \
126         --root=$RPM_BUILD_ROOT
127
128 unset NO_SETUPTOOLS
129 mv $RPM_BUILD_ROOT%{_bindir}/epylint $RPM_BUILD_ROOT%{_bindir}/epy3lint
130 mv $RPM_BUILD_ROOT%{_bindir}/pylint $RPM_BUILD_ROOT%{_bindir}/py3lint
131 mv $RPM_BUILD_ROOT%{_bindir}/pylint-gui $RPM_BUILD_ROOT%{_bindir}/py3lint-gui
132 mv $RPM_BUILD_ROOT%{_bindir}/pyreverse $RPM_BUILD_ROOT%{_bindir}/py3reverse
133 cp -p man/epylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/epy3lint.1
134 cp -p man/pylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint.1
135 cp -p man/pylint-gui.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint-gui.1
136 cp -p man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
137 %endif
138
139 %if %{with python2}
140 %{__python} setup.py install \
141         --optimize=2 \
142         --root=$RPM_BUILD_ROOT
143 %py_postclean
144 cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
145 %endif
146
147 cp -p examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %if %{with python2}
153 %files
154 %defattr(644,root,root,755)
155 %doc ChangeLog README examples/* doc/_build/text/*.txt
156 %attr(755,root,root) %{_bindir}/epylint
157 %attr(755,root,root) %{_bindir}/pylint
158 %attr(755,root,root) %{_bindir}/pyreverse
159 %attr(755,root,root) %{_bindir}/symilar
160 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
161 %{py_sitescriptdir}/pylint
162 %{py_sitescriptdir}/pylint-%{version}-py*.egg-info
163 %{_mandir}/man1/epylint.1*
164 %{_mandir}/man1/pylint.1*
165 %{_mandir}/man1/pyreverse.1*
166 %{_mandir}/man1/symilar.1*
167
168 %files gui
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/pylint-gui
171 %{_mandir}/man1/pylint-gui.1*
172 %endif
173
174 %if %{with python3}
175 %files -n py3lint
176 %defattr(644,root,root,755)
177 %doc ChangeLog README examples/* doc/_build/text/*.txt
178 %attr(755,root,root) %{_bindir}/epy3lint
179 %attr(755,root,root) %{_bindir}/py3lint
180 %attr(755,root,root) %{_bindir}/py3reverse
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
182 %{py3_sitescriptdir}/pylint
183 %{py3_sitescriptdir}/pylint-%{version}-py*.egg-info
184 %{_mandir}/man1/epy3lint.1*
185 %{_mandir}/man1/py3lint.1*
186 %{_mandir}/man1/py3reverse.1*
187
188 %files -n py3lint-gui
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/py3lint-gui
191 %{_mandir}/man1/py3lint-gui.1*
192 %endif
This page took 0.092449 seconds and 3 git commands to generate.