]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- ver. 0.10.0
[packages/pylint.git] / pylint.spec
1 Summary:        Python tool that checks if a module satisfy a coding standard
2 Summary(pl):    Pythonowe narzêdzie sprawdzaj±ce zgodno¶æ modu³u ze standardem kodowania
3 Name:           pylint
4 Version:        0.10.0
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages/Python
8 Source0:        ftp://ftp.logilab.fr/pub/pylint/%{name}-%{version}.tar.gz
9 # Source0-md5:  9c8dd130411eca6f16c3a5f531f44fa2
10 URL:            http://www.logilab.org/projects/pylint/view
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules >= 2.2.1
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 %pyrequires_eq  python-modules
16 Requires:       python-logilab-astng >= 0.15
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Python tool that checks if a module satisfy a coding standard.
22
23 %description -l pl
24 Narzêdzie sprawdzaj±ce zgodno¶æ modu³ów napisanych w jêzyku Python
25 z regu³ami tworzenia kodu ¼ród³owego.
26
27 %package gui
28 Summary:        GUI for pylint
29 Summary:        Graficzny interfejs u¿ytkownika dla pylinta
30 Group:          Development/Languages/Python
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       python-tkinter
33
34 %description gui
35 Tk based GUI for pylint.
36
37 %description gui -l pl
38 Oparty na bibliotece Tk graficzny interfejs u¿ytkownika dla pylinta.
39
40 %prep
41 %setup -q
42
43 %build
44 python setup.py build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
49
50 python setup.py install \
51         --optimize=2 \
52         --root=$RPM_BUILD_ROOT
53
54 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
55 tail -n 320 examples/pylintrc > $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
56
57 %py_postclean
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog TODO README examples/* doc/*.txt
65 %attr(755,root,root) %{_bindir}/pylint
66 %attr(755,root,root) %{_bindir}/symilar
67 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
68 %{py_sitescriptdir}/*
69 %{_mandir}/man1/*
70
71 %files gui
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/pylint-gui
This page took 0.059468 seconds and 3 git commands to generate.