]> git.pld-linux.org Git - packages/pylint.git/blame - pylint.spec
- release 2 (by relup.sh)
[packages/pylint.git] / pylint.spec
CommitLineData
bce5cba7
AF
1# TODO:
2# - include examples in package
f7cd7b16
JK
3
4# Conditional build:
5%bcond_without python2 # Python 2.x version
6%bcond_without python3 # Python 3.x version (available as 'py3lint')
7
df0ba447
JB
8Summary: Python 2 tool that checks if a module satisfy a coding standard
9Summary(pl.UTF-8): Narzędzie Pythona 2 sprawdzające zgodność modułu ze standardem kodowania
baeb5efa 10Name: pylint
23f8b7d8 11Version: 1.8.2
0643f9b0 12Release: 2
e6bafd81 13License: GPL v2+
baeb5efa 14Group: Development/Languages/Python
6ea1b8d5 15#Source0Download: https://pypi.python.org/pypi/pylint
19641c03 16Source0: https://github.com/PyCQA/pylint/archive/%{name}-%{version}.tar.gz
23f8b7d8 17# Source0-md5: 573874b242a49af0682c29badc5cf1b9
ad173d2e 18URL: http://www.pylint.org/
f7cd7b16 19%if %{with python2}
bc8a8990 20BuildRequires: python-astroid >= 1.5.3
19641c03
MK
21BuildRequires: python-certifi >= 2017.4.17
22BuildRequires: python-chardet >= 3.0.2
2ae24f33 23BuildRequires: python-devel
19641c03
MK
24BuildRequires: python-idna >= 2.5
25BuildRequires: python-isort
26BuildRequires: python-lazy-object-proxy
27BuildRequires: python-mccabe
e6bafd81 28BuildRequires: python-modules >= 1:2.5
71480d3a 29BuildRequires: python-setuptools >= 7.0
19641c03
MK
30BuildRequires: python-wrapt
31BuildConflicts: python-chardet >= 3.1.0
32BuildConflicts: python-idna >= 2.7
f7cd7b16
JK
33%endif
34%if %{with python3}
26ceed71 35BuildRequires: python3-2to3
bc8a8990 36BuildRequires: python3-astroid >= 1.5.3
19641c03
MK
37BuildRequires: python3-certifi >= 2017.4.17
38BuildRequires: python3-chardet >= 3.0.2
f7cd7b16 39BuildRequires: python3-devel
19641c03
MK
40BuildRequires: python3-idna >= 2.5
41BuildRequires: python3-isort
42BuildRequires: python3-lazy-object-proxy
43BuildRequires: python3-mccabe
f7cd7b16 44BuildRequires: python3-modules >= 1:3.2
71480d3a 45BuildRequires: python3-setuptools >= 7.0
19641c03
MK
46BuildRequires: python3-wrapt
47BuildConflicts: python3-chardet >= 3.1.0
48BuildConflicts: python3-idna >= 2.7
f7cd7b16 49%endif
2ae24f33 50BuildRequires: rpm-pythonprov
7c199dbc 51BuildRequires: rpmbuild(macros) >= 1.219
ad173d2e 52BuildRequires: sphinx-pdg
345b7a9d 53Requires: python-pylint = %{version}-%{release}
93850ade 54Suggests: python-devel-src
baeb5efa 55BuildArch: noarch
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
1ee582a8
ER
58# /etc/pylintrc is deliberately packaged to both packages with same name
59%define _duplicate_files_terminate_build 0
60
bc8a8990
JK
61# current Python 3.x provides all these
62%define _noautoreq python3egg.backports.functools-lru-cache python3egg.configparser python3egg.singledispatch
63
baeb5efa 64%description
df0ba447 65Python 2 tool that checks if a module satisfy a coding standard.
baeb5efa 66
65b81fbb 67%description -l pl.UTF-8
df0ba447
JB
68Narzędzie Pythona 2 sprawdzające zgodność modułów napisanych w języku
69Python z regułami tworzenia kodu źródłowego.
c85c0a5a 70
345b7a9d 71%package -n python-pylint
df0ba447
JB
72Summary: Python 2 tool that checks if a module satisfy a coding standard (modules)
73Summary(pl.UTF-8): Narzędzie Pythona sprawdzające zgodność modułu ze standardem kodowania (moduły)
345b7a9d
JK
74Group: Libraries/Python
75
76%description -n python-pylint
df0ba447 77Python 2 tool that checks if a module satisfy a coding standard.
345b7a9d 78
df0ba447 79This package contains only the Python modules used by the tool.
345b7a9d
JK
80
81%description -n python-pylint -l pl.UTF-8
df0ba447
JB
82Narzędzie Pythona 2 sprawdzające zgodność modułów napisanych w języku
83Python z regułami tworzenia kodu źródłowego.
345b7a9d 84
df0ba447 85Ten pakiet zawiera tylko moduły Pythona używane przez to narzędzie.
345b7a9d 86
704b7472 87%package -n py3lint
df0ba447
JB
88Summary: Python 3 tool that checks if a module satisfy a coding standard
89Summary(pl.UTF-8): Narzędzie Pythona 3 sprawdzające zgodność modułu ze standardem kodowania
f7cd7b16 90Group: Development/Languages/Python
345b7a9d 91Requires: python3-pylint = %{version}-%{release}
704b7472 92Obsoletes: pylint-python3 < 1.0.0-2
f7cd7b16 93
704b7472 94%description -n py3lint
df0ba447 95Python 3 tool that checks if a module satisfy a coding standard.
f7cd7b16
JK
96
97Python 3.x version, available via the 'py3lint' command.
98
704b7472 99%description -n py3lint -l pl.UTF-8
df0ba447
JB
100Narzędzie Pythona 3 sprawdzające zgodność modułów napisanych w języku
101Python z regułami tworzenia kodu źródłowego.
f7cd7b16
JK
102
103Wersja dla Pythona 3.x, dostępna przez polecenie 'py3lint'.
104
345b7a9d 105%package -n python3-pylint
df0ba447
JB
106Summary: Python 3 tool that checks if a module satisfy a coding standard (moduły)
107Summary(pl.UTF-8): Narzędzie Pythona 3 sprawdzające zgodność modułu ze standardem kodowania (modules)
345b7a9d
JK
108Group: Libraries/Python
109
110%description -n python3-pylint
df0ba447 111Python 3 tool that checks if a module satisfy a coding standard.
345b7a9d 112
df0ba447 113This package contains only the Python modules used by the tool.
345b7a9d
JK
114
115%description -n python3-pylint -l pl.UTF-8
df0ba447
JB
116Narzędzie Pythona 3 sprawdzające zgodność modułów napisanych w języku
117Python z regułami tworzenia kodu źródłowego.
345b7a9d 118
df0ba447 119Ten pakiet zawiera tylko moduły Pythona używane przez to narzędzie.
345b7a9d 120
baeb5efa 121%prep
19641c03 122%setup -q -n pylint-pylint-%{version}
8b70ac82 123
baeb5efa 124%build
f7cd7b16 125%if %{with python2}
15bfcc2d 126%py_build
f7cd7b16
JK
127%endif
128
129%if %{with python3}
15bfcc2d 130%py3_build
f7cd7b16 131%endif
baeb5efa 132
e1ce958c 133%{__make} -C doc text \
15bfcc2d 134 PYTHONPATH=$PWD
ad173d2e 135
baeb5efa 136%install
704b7472 137rm -rf $RPM_BUILD_ROOT
4ec6f79e 138install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
baeb5efa 139
f7cd7b16 140%if %{with python3}
15bfcc2d 141%py3_install
4efaa76d 142
df0ba447
JB
143%{__mv} $RPM_BUILD_ROOT%{_bindir}/epylint $RPM_BUILD_ROOT%{_bindir}/epy3lint
144%{__mv} $RPM_BUILD_ROOT%{_bindir}/pylint $RPM_BUILD_ROOT%{_bindir}/py3lint
df0ba447 145%{__mv} $RPM_BUILD_ROOT%{_bindir}/pyreverse $RPM_BUILD_ROOT%{_bindir}/py3reverse
704b7472
ER
146cp -p man/epylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/epy3lint.1
147cp -p man/pylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint.1
704b7472 148cp -p man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
f7cd7b16 149%endif
4efaa76d 150
f7cd7b16 151%if %{with python2}
15bfcc2d 152%py_install
7c199dbc 153%py_postclean
704b7472 154cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
f7cd7b16
JK
155%endif
156
704b7472 157cp -p examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
baeb5efa 158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
f7cd7b16 162%if %{with python2}
baeb5efa 163%files
164%defattr(644,root,root,755)
bc8a8990 165%doc ChangeLog README.rst examples/* doc/_build/text/*.txt
ebaa5e6b 166%attr(755,root,root) %{_bindir}/epylint
7c199dbc 167%attr(755,root,root) %{_bindir}/pylint
ebaa5e6b 168%attr(755,root,root) %{_bindir}/pyreverse
7c199dbc 169%attr(755,root,root) %{_bindir}/symilar
b4896848 170%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
6abb03ef
JB
171%{_mandir}/man1/epylint.1*
172%{_mandir}/man1/pylint.1*
173%{_mandir}/man1/pyreverse.1*
174%{_mandir}/man1/symilar.1*
7c199dbc 175
345b7a9d
JK
176%files -n python-pylint
177%defattr(644,root,root,755)
178%{py_sitescriptdir}/pylint
179%{py_sitescriptdir}/pylint-%{version}-py*.egg-info
f7cd7b16
JK
180%endif
181
182%if %{with python3}
704b7472 183%files -n py3lint
f7cd7b16 184%defattr(644,root,root,755)
bc8a8990 185%doc ChangeLog README.rst examples/* doc/_build/text/*.txt
f7cd7b16
JK
186%attr(755,root,root) %{_bindir}/epy3lint
187%attr(755,root,root) %{_bindir}/py3lint
188%attr(755,root,root) %{_bindir}/py3reverse
704b7472 189%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
f7cd7b16
JK
190%{_mandir}/man1/epy3lint.1*
191%{_mandir}/man1/py3lint.1*
192%{_mandir}/man1/py3reverse.1*
193
345b7a9d
JK
194%files -n python3-pylint
195%defattr(644,root,root,755)
196%{py3_sitescriptdir}/pylint
197%{py3_sitescriptdir}/pylint-%{version}-py*.egg-info
f7cd7b16 198%endif
This page took 0.078069 seconds and 4 git commands to generate.