]> git.pld-linux.org Git - packages/pylint.git/blame - pylint.spec
Version: 1.7.4
[packages/pylint.git] / pylint.spec
CommitLineData
bce5cba7
AF
1# TODO:
2# - include examples in package
f7cd7b16
JK
3
4# Conditional build:
5%bcond_without python2 # Python 2.x version
6%bcond_without python3 # Python 3.x version (available as 'py3lint')
7
df0ba447
JB
8Summary: Python 2 tool that checks if a module satisfy a coding standard
9Summary(pl.UTF-8): Narzędzie Pythona 2 sprawdzające zgodność modułu ze standardem kodowania
baeb5efa 10Name: pylint
bc8a8990
JK
11Version: 1.7.4
12Release: 1
e6bafd81 13License: GPL v2+
baeb5efa 14Group: Development/Languages/Python
6ea1b8d5 15#Source0Download: https://pypi.python.org/pypi/pylint
bc8a8990
JK
16Source0: https://files.pythonhosted.org/packages/source/p/pylint/%{name}-%{version}.tar.gz
17# Source0-md5: 98a1ee985a3ebc876a20eb7577dbab68
ad173d2e 18URL: http://www.pylint.org/
f7cd7b16 19%if %{with python2}
bc8a8990 20BuildRequires: python-astroid >= 1.5.3
2ae24f33 21BuildRequires: python-devel
e6bafd81 22BuildRequires: python-modules >= 1:2.5
71480d3a 23BuildRequires: python-setuptools >= 7.0
f7cd7b16
JK
24%endif
25%if %{with python3}
26ceed71 26BuildRequires: python3-2to3
bc8a8990 27BuildRequires: python3-astroid >= 1.5.3
f7cd7b16 28BuildRequires: python3-devel
f7cd7b16 29BuildRequires: python3-modules >= 1:3.2
71480d3a 30BuildRequires: python3-setuptools >= 7.0
f7cd7b16 31%endif
2ae24f33 32BuildRequires: rpm-pythonprov
7c199dbc 33BuildRequires: rpmbuild(macros) >= 1.219
ad173d2e 34BuildRequires: sphinx-pdg
345b7a9d 35Requires: python-pylint = %{version}-%{release}
93850ade 36Suggests: python-devel-src
baeb5efa 37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
1ee582a8
ER
40# /etc/pylintrc is deliberately packaged to both packages with same name
41%define _duplicate_files_terminate_build 0
42
bc8a8990
JK
43# current Python 3.x provides all these
44%define _noautoreq python3egg.backports.functools-lru-cache python3egg.configparser python3egg.singledispatch
45
baeb5efa 46%description
df0ba447 47Python 2 tool that checks if a module satisfy a coding standard.
baeb5efa 48
65b81fbb 49%description -l pl.UTF-8
df0ba447
JB
50Narzędzie Pythona 2 sprawdzające zgodność modułów napisanych w języku
51Python z regułami tworzenia kodu źródłowego.
c85c0a5a 52
345b7a9d 53%package -n python-pylint
df0ba447
JB
54Summary: Python 2 tool that checks if a module satisfy a coding standard (modules)
55Summary(pl.UTF-8): Narzędzie Pythona sprawdzające zgodność modułu ze standardem kodowania (moduły)
345b7a9d
JK
56Group: Libraries/Python
57
58%description -n python-pylint
df0ba447 59Python 2 tool that checks if a module satisfy a coding standard.
345b7a9d 60
df0ba447 61This package contains only the Python modules used by the tool.
345b7a9d
JK
62
63%description -n python-pylint -l pl.UTF-8
df0ba447
JB
64Narzędzie Pythona 2 sprawdzające zgodność modułów napisanych w języku
65Python z regułami tworzenia kodu źródłowego.
345b7a9d 66
df0ba447 67Ten pakiet zawiera tylko moduły Pythona używane przez to narzędzie.
345b7a9d 68
704b7472 69%package -n py3lint
df0ba447
JB
70Summary: Python 3 tool that checks if a module satisfy a coding standard
71Summary(pl.UTF-8): Narzędzie Pythona 3 sprawdzające zgodność modułu ze standardem kodowania
f7cd7b16 72Group: Development/Languages/Python
345b7a9d 73Requires: python3-pylint = %{version}-%{release}
704b7472 74Obsoletes: pylint-python3 < 1.0.0-2
f7cd7b16 75
704b7472 76%description -n py3lint
df0ba447 77Python 3 tool that checks if a module satisfy a coding standard.
f7cd7b16
JK
78
79Python 3.x version, available via the 'py3lint' command.
80
704b7472 81%description -n py3lint -l pl.UTF-8
df0ba447
JB
82Narzędzie Pythona 3 sprawdzające zgodność modułów napisanych w języku
83Python z regułami tworzenia kodu źródłowego.
f7cd7b16
JK
84
85Wersja dla Pythona 3.x, dostępna przez polecenie 'py3lint'.
86
345b7a9d 87%package -n python3-pylint
df0ba447
JB
88Summary: Python 3 tool that checks if a module satisfy a coding standard (moduły)
89Summary(pl.UTF-8): Narzędzie Pythona 3 sprawdzające zgodność modułu ze standardem kodowania (modules)
345b7a9d
JK
90Group: Libraries/Python
91
92%description -n python3-pylint
df0ba447 93Python 3 tool that checks if a module satisfy a coding standard.
345b7a9d 94
df0ba447 95This package contains only the Python modules used by the tool.
345b7a9d
JK
96
97%description -n python3-pylint -l pl.UTF-8
df0ba447
JB
98Narzędzie Pythona 3 sprawdzające zgodność modułów napisanych w języku
99Python z regułami tworzenia kodu źródłowego.
345b7a9d 100
df0ba447 101Ten pakiet zawiera tylko moduły Pythona używane przez to narzędzie.
345b7a9d 102
baeb5efa 103%prep
59710151 104%setup -q
8b70ac82 105
baeb5efa 106%build
f7cd7b16 107%if %{with python2}
15bfcc2d 108%py_build
f7cd7b16
JK
109%endif
110
111%if %{with python3}
15bfcc2d 112%py3_build
f7cd7b16 113%endif
baeb5efa 114
e1ce958c 115%{__make} -C doc text \
15bfcc2d 116 PYTHONPATH=$PWD
ad173d2e 117
baeb5efa 118%install
704b7472 119rm -rf $RPM_BUILD_ROOT
4ec6f79e 120install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
baeb5efa 121
f7cd7b16 122%if %{with python3}
15bfcc2d 123%py3_install
4efaa76d 124
df0ba447
JB
125%{__mv} $RPM_BUILD_ROOT%{_bindir}/epylint $RPM_BUILD_ROOT%{_bindir}/epy3lint
126%{__mv} $RPM_BUILD_ROOT%{_bindir}/pylint $RPM_BUILD_ROOT%{_bindir}/py3lint
df0ba447 127%{__mv} $RPM_BUILD_ROOT%{_bindir}/pyreverse $RPM_BUILD_ROOT%{_bindir}/py3reverse
704b7472
ER
128cp -p man/epylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/epy3lint.1
129cp -p man/pylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint.1
704b7472 130cp -p man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
f7cd7b16 131%endif
4efaa76d 132
f7cd7b16 133%if %{with python2}
15bfcc2d 134%py_install
7c199dbc 135%py_postclean
704b7472 136cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
f7cd7b16
JK
137%endif
138
704b7472 139cp -p examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
baeb5efa 140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
f7cd7b16 144%if %{with python2}
baeb5efa 145%files
146%defattr(644,root,root,755)
bc8a8990 147%doc ChangeLog README.rst examples/* doc/_build/text/*.txt
ebaa5e6b 148%attr(755,root,root) %{_bindir}/epylint
7c199dbc 149%attr(755,root,root) %{_bindir}/pylint
ebaa5e6b 150%attr(755,root,root) %{_bindir}/pyreverse
7c199dbc 151%attr(755,root,root) %{_bindir}/symilar
b4896848 152%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
6abb03ef
JB
153%{_mandir}/man1/epylint.1*
154%{_mandir}/man1/pylint.1*
155%{_mandir}/man1/pyreverse.1*
156%{_mandir}/man1/symilar.1*
7c199dbc 157
345b7a9d
JK
158%files -n python-pylint
159%defattr(644,root,root,755)
160%{py_sitescriptdir}/pylint
161%{py_sitescriptdir}/pylint-%{version}-py*.egg-info
f7cd7b16
JK
162%endif
163
164%if %{with python3}
704b7472 165%files -n py3lint
f7cd7b16 166%defattr(644,root,root,755)
bc8a8990 167%doc ChangeLog README.rst examples/* doc/_build/text/*.txt
f7cd7b16
JK
168%attr(755,root,root) %{_bindir}/epy3lint
169%attr(755,root,root) %{_bindir}/py3lint
170%attr(755,root,root) %{_bindir}/py3reverse
704b7472 171%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
f7cd7b16
JK
172%{_mandir}/man1/epy3lint.1*
173%{_mandir}/man1/py3lint.1*
174%{_mandir}/man1/py3reverse.1*
175
345b7a9d
JK
176%files -n python3-pylint
177%defattr(644,root,root,755)
178%{py3_sitescriptdir}/pylint
179%{py3_sitescriptdir}/pylint-%{version}-py*.egg-info
f7cd7b16 180%endif
This page took 0.21847 seconds and 4 git commands to generate.