]> git.pld-linux.org Git - packages/pwdutils.git/commitdiff
- updated to 3.2.19 (passwd -S fix) auto/th/pwdutils-3_2_19-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 26 May 2012 05:40:29 +0000 (05:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added selinux patch to fix function name conflict with current libselinux

Changed files:
    pwdutils-selinux.patch -> 1.1
    pwdutils.spec -> 1.105

pwdutils-selinux.patch [new file with mode: 0644]
pwdutils.spec

diff --git a/pwdutils-selinux.patch b/pwdutils-selinux.patch
new file mode 100644 (file)
index 0000000..87e2bfc
--- /dev/null
@@ -0,0 +1,55 @@
+--- pwdutils-3.2.19.orig/lib/public.h  2005-06-22 11:05:53.000000000 +0200
++++ pwdutils-3.2.19/lib/public.h       2012-05-26 07:35:09.397451177 +0200
+@@ -115,7 +115,7 @@
+ #ifdef WITH_SELINUX
+-extern int selinux_check_access (const char *__chuser,
++extern int pwdu_selinux_check_access (const char *__chuser,
+                                unsigned int __selaccess) __attribute_warn_unused_result__;
+ extern int set_default_context (const char *filename,
+                               char **prev_context) __attribute_warn_unused_result__;
+--- pwdutils-3.2.19.orig/lib/selinux_utils.c   2006-11-29 14:19:06.000000000 +0100
++++ pwdutils-3.2.19/lib/selinux_utils.c        2012-05-26 07:35:09.397451177 +0200
+@@ -33,7 +33,7 @@
+ #include "public.h"
+ int
+-selinux_check_access (const char *chuser, unsigned int selaccess)
++pwdu_selinux_check_access (const char *chuser, unsigned int selaccess)
+ {
+   int status = -1;
+   security_context_t user_context;
+--- pwdutils-3.2.19.orig/src/chfn.c    2006-11-29 14:19:39.000000000 +0100
++++ pwdutils-3.2.19/src/chfn.c 2012-05-26 07:35:09.394117844 +0200
+@@ -578,7 +578,7 @@
+   if (is_selinux_enabled () > 0)
+     {
+       if ((uid == 0) &&
+-          (selinux_check_access (pw_data->pw.pw_name, PASSWD__CHFN) != 0))
++          (pwdu_selinux_check_access (pw_data->pw.pw_name, PASSWD__CHFN) != 0))
+         {
+           security_context_t user_context;
+           if (getprevcon (&user_context) < 0)
+--- pwdutils-3.2.19.orig/src/chsh.c    2006-11-29 14:19:43.000000000 +0100
++++ pwdutils-3.2.19/src/chsh.c 2012-05-26 07:35:09.397451177 +0200
+@@ -443,7 +443,7 @@
+   if (is_selinux_enabled () > 0)
+     {
+       if ((uid == 0) &&
+-          (selinux_check_access (pw_data->pw.pw_name, PASSWD__CHSH) != 0))
++          (pwdu_selinux_check_access (pw_data->pw.pw_name, PASSWD__CHSH) != 0))
+         {
+           security_context_t user_context;
+           if (getprevcon (&user_context) < 0)
+--- pwdutils-3.2.19.orig/src/passwd.c  2012-05-08 14:12:35.000000000 +0200
++++ pwdutils-3.2.19/src/passwd.c       2012-05-26 07:35:09.390784511 +0200
+@@ -704,7 +704,7 @@
+   if (is_selinux_enabled () > 0)
+     {
+       if ((uid == 0) &&
+-        (selinux_check_access (pw->pw_name, PASSWD__PASSWD) != 0))
++        (pwdu_selinux_check_access (pw->pw_name, PASSWD__PASSWD) != 0))
+       {
+         security_context_t user_context;
+         if (getprevcon (&user_context) < 0)
index 9149ce875650123449b01cb370480e3369396b2a..9ddc36c6a028598be53c936911ae92cc234750e3 100644 (file)
@@ -9,13 +9,13 @@
 Summary:       Utilities to manage the passwd and shadow user information
 Summary(pl.UTF-8):     Narzędzia do zarządzania informacjami o użytkownikach z passwd i shadow
 Name:          pwdutils
-Version:       3.2.18
+Version:       3.2.19
 Release:       1
 License:       GPL v2
 Group:         Base
 #Source0:      ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
 Source0:       http://www.linux-nis.org/download/pwdutils/%{name}-%{version}.tar.bz2
-# Source0-md5: 7bdf1a93505a3f4e02cf6c06ee889610
+# Source0-md5: 25a77a0ab376eacf24ad5eab7af4cdce
 Source1:       %{name}.useradd
 Source2:       %{name}.rpasswdd.init
 Source3:       %{name}.login.defs
@@ -30,6 +30,7 @@ Patch0:               %{name}-f-option.patch
 Patch1:                %{name}-no_bash.patch
 Patch2:                %{name}-silent_crontab.patch
 Patch3:                %{name}-pl.po-update.patch
+Patch4:                %{name}-selinux.patch
 URL:           http://www.thkukuk.de/pam/pwdutils/
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf
@@ -157,6 +158,7 @@ funkcjonalność tylko dla jednej grupy zarządzania PAM: zmiany haseł.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.097915 seconds and 4 git commands to generate.