]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- add our pam config for rpasswd
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - review default login.defs
3 #
4 # Conditional build:
5 %bcond_without  audit           # don't build audit log plugin
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  selinux         # build without SELinux support
8 %bcond_with     bioapi          # with BioAPI support in passwd
9 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
10 #
11 Summary:        Utilities to manage the passwd and shadow user information
12 Summary(pl.UTF-8):      Narzędzia do zarządzania informacjami o użytkownikach z passwd i shadow
13 Name:           pwdutils
14 Version:        3.1.3
15 Release:        2
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
19 # Source0-md5:  b18c601e282d8695cbb5ddd87eaa473c
20 Source1:        %{name}.useradd
21 Source2:        %{name}.rpasswdd.init
22 Source3:        %{name}.login.defs
23 Source4:        chage.pamd
24 Source5:        chfn.pamd
25 Source6:        chsh.pamd
26 Source7:        passwd.pamd
27 Source8:        useradd.pamd
28 Source9:        userdb.pamd
29 Source10:       rpasswd.pamd
30 Patch0:         %{name}-f-option.patch
31 Patch1:         %{name}-no_bash.patch
32 Patch2:         %{name}-silent_crontab.patch
33 Patch3:         %{name}-pl.po-update.patch
34 URL:            http://www.thkukuk.de/pam/pwdutils/
35 %{?with_audit:BuildRequires:    audit-libs-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake >= 1:1.7
38 %{?with_bioapi:BuildRequires:   bioapi-devel}
39 BuildRequires:  gcc >= 5:3.2
40 BuildRequires:  gettext-devel
41 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.0.0}
42 BuildRequires:  libnscd-devel
43 %{?with_selinux:BuildRequires:  libselinux-devel}
44 BuildRequires:  libtool
45 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
46 BuildRequires:  openslp-devel
47 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
48 BuildRequires:  pam-devel
49 BuildRequires:  rpmbuild(macros) >= 1.268
50 BuildRequires:  sed >= 4.0
51 Requires:       pam >= 0.99.7.1
52 Provides:       shadow = 2:%{version}-%{release}
53 Provides:       shadow-extras = 2:%{version}-%{release}
54 Obsoletes:      shadow
55 Obsoletes:      shadow-extras
56 Obsoletes:      shadow-utils
57 Conflicts:      util-linux < 2.12-10
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 # for pam module in /%{_lib}/security
61 %define         _libdir         /%{_lib}
62
63 %description
64 pwdutils is a collection of utilities to manage the passwd and shadow
65 user information. The difference to the shadow suite is that these
66 utilities can also modify the information stored in NIS, NIS+, or
67 LDAP. PAM is used for user authentication and changing the pasword. It
68 contains passwd, chage, chfn, chsh, and a daemon for changing the
69 password on a remote machine over a secure SSL connection. The daemon
70 also uses PAM so that it can change passwords independent of where
71 they are stored.
72
73 %description -l pl.UTF-8
74 pwdutils to zestaw narzędzi do zarządzania informacjami o
75 użytkownikach z passwd i shadow. Różnica w stosunku do pakietu shadow
76 polega na tym, że te narzędzia mogą także modyfikować informacje
77 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest używany do
78 uwierzytelniania użytkowników i zmiany haseł. Zestaw zawiera passwd,
79 chage, chfn, chsh oraz demona do zmiany hasła na zdalnej maszynie po
80 bezpiecznym połączeniu SSL. Demon także używa PAM, więc można zmieniać
81 hasła niezależnie od tego, gdzie są przechowywane.
82
83 %package log-audit
84 Summary:        audit log plugin for pwdutils
85 Summary(pl.UTF-8):      Wtyczka logująca audit dla pwdutils
86 Group:          Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description log-audit
90 audit log plugin for pwdutils.
91
92 %description log-audit -l pl.UTF-8
93 Wtyczka logująca audit dla pwdutils.
94
95 %package -n rpasswd
96 Summary:        Remote password update client
97 Summary(pl.UTF-8):      Klient do zdalnego uaktualniania haseł
98 Group:          Applications/System
99
100 %description -n rpasswd
101 rpasswd changes passwords for user accounts on a remote server over a
102 secure SSL connection. A normal user may only change the password for
103 their own account, if the user knows the password of the administrator
104 account (in the moment this is the root password on the server), he may
105 change the password for any account if he calls rpasswd with the -a
106 option.
107
108 %description -n rpasswd -l pl.UTF-8
109 rpasswd pozwala zmieniać hasła użytkowników na zdalnym serwerze przy
110 użyciu bezpiecznego połączenia SSL. Zwykły użytkownik może zmienić
111 jedynie swoje hasło, a jeśli zna hasło administratora (obecnie jest to
112 hasło roota na serwerze), może zmienić hasło dla dowolnego konta
113 wywołując rpasswd z opcją -a.
114
115 %package -n rpasswdd
116 Summary:        Remote password update daemon
117 Summary(pl.UTF-8):      Demon do zdalnego uaktualniania haseł
118 Group:          Applications/System
119 Requires(post,preun):   /sbin/chkconfig
120 Requires:       rc-scripts
121
122 %description -n rpasswdd
123 rpasswdd is a daemon that lets users change their passwords in the
124 presence of a directory service like NIS, NIS+ or LDAP over a secure
125 SSL connection. rpasswdd behaves like the normal passwd(1) program and
126 uses PAM for authentication and changing the password, so it can be
127 configured very flexible for the local requirements.
128
129 %description -n rpasswdd -l pl.UTF-8
130 rpasswdd to demon pozwalający użytkownikom zmieniać hasła w obecności
131 usług katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
132 połączeniu SSL. rpasswdd zachowuje się tak, jak normalny program
133 passwd(1) i używam PAM do uwierzytelniania i zmiany haseł, więc może
134 być bardzo elastycznie konfigurowany dla lokalnych wymagań.
135
136 %package -n pam-pam_rpasswd
137 Summary:        pam_rpasswd - PAM module to change remote password
138 Summary(pl.UTF-8):      pam_rpasswd - moduł PAM do zdalnej zmiany hasła
139 Group:          Base
140 # rpasswd.conf is in rpasswd
141 Requires:       rpasswd = %{version}-%{release}
142
143 %description -n pam-pam_rpasswd
144 The pam_rpasswd PAM module is for changing the password of user
145 accounts on a remote server over a secure SSL connection. It only
146 provides functionality for one PAM management group: password
147 changing.
148
149 %description -n pam-pam_rpasswd -l pl.UTF-8
150 Moduł PAM pam_rpasswd służy do zmiany haseł dla kont użytkowników na
151 zdalnym serwerze po bezpiecznym połączeniu SSL. Udostępnia
152 funkcjonalność tylko dla jednej grupy zarządzania PAM: zmiany haseł.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157 %patch1 -p1
158 %patch2 -p1
159 %patch3 -p1
160
161 sed -i -e 's/-Werror //' configure.in
162
163 rm -f po/stamp-po
164
165 %build
166 %{__gettextize}
167 %{__aclocal}
168 %{__autoconf}
169 %{__autoheader}
170 %{__automake}
171 %configure \
172         %{?with_bioapi:CPPFLAGS="-I/usr/include/bioapi"} \
173         %{!?with_bioapi:ac_cv_header_bioapi_h=no ac_cv_lib_bioapi100_BioAPI_Init=no} \
174         %{?with_audit:--enable-audit-plugin} \
175         %{!?with_gnutls:--disable-gnutls} \
176         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
177         --enable-nls \
178         --enable-pam_rpasswd \
179         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
180         --enable-slp \
181         --disable-rpath
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,security,skel/tmp}
187
188 %{__make} install \
189         DESTDIR=$RPM_BUILD_ROOT
190
191 mv -f $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
192 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
193 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
194 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
195
196 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
197 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
198 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
199 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
200 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
201 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
202 install %{SOURCE10} $RPM_BUILD_ROOT/etc/pam.d/rpasswd
203
204 rm -f $RPM_BUILD_ROOT%{_libdir}/pwdutils/*.{la,a}
205 rm -f $RPM_BUILD_ROOT/etc/init.d/rpasswdd
206
207 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
208 :> $RPM_BUILD_ROOT/etc/security/chfn.allow
209 :> $RPM_BUILD_ROOT/etc/security/chsh.allow
210
211 %find_lang %{name}
212
213 %clean
214 rm -rf $RPM_BUILD_ROOT
215
216 %post
217 if [ ! -f /etc/shadow ]; then
218         %{_sbindir}/pwconv
219 fi
220
221 %post -n rpasswdd
222 /sbin/chkconfig --add rpasswdd
223 %service rpasswdd restart "rpasswdd daemon"
224
225 %preun -n rpasswdd
226 if [ "$1" = "0" ]; then
227         %service rpasswdd stop
228         /sbin/chkconfig --del rpasswdd
229 fi
230
231 %files -f %{name}.lang
232 %defattr(644,root,root,755)
233 %doc AUTHORS ChangeLog NEWS README THANKS TODO
234 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
235 %attr(750,root,root) %dir %{_sysconfdir}/default
236 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/*
237 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
238 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.local
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/logging
240 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
241 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chfn
242 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
243 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
244 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
245 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
246 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.defs
247 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chfn.allow
248 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chsh.allow
249 %dir /etc/skel
250 %dir /etc/skel/tmp
251 %attr(755,root,root) %{_bindir}/chage
252 %attr(4755,root,root) %{_bindir}/chfn
253 %attr(4755,root,root) %{_bindir}/chsh
254 %attr(4755,root,root) %{_bindir}/expiry
255 %attr(4755,root,root) %{_bindir}/gpasswd
256 %attr(755,root,root) %{_bindir}/newgrp
257 %attr(4755,root,root) %{_bindir}/passwd
258 %attr(755,root,root) %{_bindir}/sg
259 %attr(755,root,root) %{_sbindir}/chpasswd
260 %attr(755,root,root) %{_sbindir}/groupadd
261 %attr(755,root,root) %{_sbindir}/groupdel
262 %attr(755,root,root) %{_sbindir}/groupmod
263 %attr(755,root,root) %{_sbindir}/grpconv
264 %attr(755,root,root) %{_sbindir}/grpck
265 %attr(755,root,root) %{_sbindir}/grpunconv
266 %attr(755,root,root) %{_sbindir}/pwconv
267 %attr(755,root,root) %{_sbindir}/pwck
268 %attr(755,root,root) %{_sbindir}/pwunconv
269 %attr(755,root,root) %{_sbindir}/useradd
270 %attr(755,root,root) %{_sbindir}/userdel
271 %attr(755,root,root) %{_sbindir}/usermod
272 %attr(755,root,root) %{_sbindir}/vigr
273 %attr(755,root,root) %{_sbindir}/vipw
274 %dir %{_libdir}/pwdutils
275 %attr(755,root,root) %{_libdir}/pwdutils/liblog_syslog.so*
276 %{_mandir}/man?/*
277 %exclude %{_mandir}/man1/rpasswd.1*
278 %exclude %{_mandir}/man5/rpasswd.conf.5*
279 %exclude %{_mandir}/man8/rpasswdd.8*
280 %exclude %{_mandir}/man8/pam_rpasswd.8*
281
282 %if %{with audit}
283 %files log-audit
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_libdir}/pwdutils/liblog_audit.so*
286 %endif
287
288 %files -n rpasswd
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_bindir}/rpasswd
291 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rpasswd.conf
292 %{_mandir}/man1/rpasswd.1*
293 %{_mandir}/man5/rpasswd.conf.5*
294
295 %files -n rpasswdd
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_sbindir}/rpasswdd
298 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
299 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/rpasswd
300 %{_mandir}/man8/rpasswdd.8*
301
302 %files -n pam-pam_rpasswd
303 %defattr(644,root,root,755)
304 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
305 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.08436 seconds and 4 git commands to generate.