]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- O: shadow-utils (to be able to upgrade from fedora)
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.6.90
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  477703b1d538d96a0747e2ef0ee0081d
14 Source1:        %{name}.useradd
15 Source2:        %{name}.rpasswdd.init
16 Source3:        %{name}.login.defs
17 Source4:        chage.pamd
18 Source5:        chfn.pamd
19 Source6:        chsh.pamd
20 Source7:        passwd.pamd
21 Source8:        useradd.pamd
22 Source9:        userdb.pamd
23 Patch0:         %{name}-f-option.patch
24 URL:            http://www.thkukuk.de/pam/pwdutils/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  gcc >= 5:3.2
28 BuildRequires:  gettext-devel
29 BuildRequires:  libselinux-devel
30 %{?with_ldap:BuildRequires:     openldap-devel}
31 BuildRequires:  openssl-devel >= 0.9.7d
32 BuildRequires:  openslp-devel
33 BuildRequires:  pam-devel
34 BuildRequires:  sed >= 4.0
35 Provides:       shadow = 2:%{version}-%{release}
36 Provides:       shadow-extras = 2:%{version}-%{release}
37 Obsoletes:      shadow
38 Obsoletes:      shadow-extras
39 Obsoletes:      shadow-utils
40 Conflicts:      util-linux < 2.12-10
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # for pam module in /%{_lib}/security
44 %define         _libdir         /%{_lib}
45
46 %description
47 pwdutils is a collection of utilities to manage the passwd and shadow
48 user information. The difference to the shadow suite is that these
49 utilities can also modify the information stored in NIS, NIS+, or
50 LDAP. PAM is used for user authentication and changing the pasword. It
51 contains passwd, chage, chfn, chsh, and a daemon for changing the
52 password on a remote machine over a secure SSL connection. The daemon
53 also uses PAM so that it can change passwords independent of where
54 they are stored.
55
56 %description -l pl
57 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
58 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
59 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
60 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
61 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
62 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
63 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
64 has³a niezale¿nie od tego, gdzie s± przechowywane.
65
66 %package -n rpasswdd
67 Summary:        Remote password update daemon
68 Summary(pl):    Demon do zdalnego uaktualniania hase³
69 Group:          Applications/System
70
71 %description -n rpasswdd
72 rpasswdd is a daemon that lets users change their passwords in the
73 presence of a directory service like NIS, NIS+ or LDAP over a secure
74 SSL connection. rpasswdd behaves like the normal passwd(1) program and
75 uses PAM for authentication and changing the password, so it can be
76 configured very flexibel for the local requirements.
77
78 %description -n rpasswdd -l pl
79 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
80 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
81 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
82 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
83 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
84
85 %package -n pam-pam_rpasswd
86 Summary:        pam_rpasswd - PAM module to change remote password
87 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
88 Group:          Base
89 # rpasswd.conf is in base
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n pam-pam_rpasswd
93 The pam_rpasswd PAM module is for changing the password of user
94 accounts on a remote server over a secure SSL connection. It only
95 provides functionality for one PAM management group: password
96 changing.
97
98 %description -n pam-pam_rpasswd -l pl
99 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
100 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
101 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 %build
108 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
109 %{__gettextize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --enable-pam_rpasswd \
116         --enable-selinux \
117         --enable-slp \
118         --enable-ssl \
119         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
120         --enable-nls \
121         --disable-rpath
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,skel}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
134 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
135
136 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
137 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
138 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
139 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
140 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
141 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
142
143 :> $RPM_BUILD_ROOT/etc/shadow
144
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 if [ ! -f /etc/shadow ]; then
152         %{_sbindir}/pwconv
153 fi
154
155 %post -n rpasswdd
156 /sbin/chkconfig --add rpasswdd
157 if [ -f /var/lock/subsys/rpasswdd ]; then
158         /etc/rc.d/init.d/rpasswdd restart 1>&2
159 else
160         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
161 fi
162
163 %preun -n rpasswdd
164 if [ "$1" = "0" ]; then
165         if [ -f /var/lock/subsys/rpasswdd ]; then
166                 /etc/rc.d/init.d/rpasswdd stop 1>&2
167         fi
168         /sbin/chkconfig --del rpasswdd
169 fi
170
171 %files -f %{name}.lang
172 %defattr(644,root,root,755)
173 %doc ChangeLog NEWS README THANKS TODO
174 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
175 %attr(750,root,root) %dir %{_sysconfdir}/default
176 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
177 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
178 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
179 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
180 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
181 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
182 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
183 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
184 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
185 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
186 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
187 %dir /etc/skel
188 %attr(755,root,root) %{_bindir}/chage
189 %attr(4755,root,root) %{_bindir}/chfn
190 %attr(4755,root,root) %{_bindir}/chsh
191 %attr(4755,root,root) %{_bindir}/expiry
192 %attr(4755,root,root) %{_bindir}/gpasswd
193 %attr(755,root,root) %{_bindir}/newgrp
194 %attr(4755,root,root) %{_bindir}/passwd
195 %attr(755,root,root) %{_bindir}/rpasswd
196 %attr(755,root,root) %{_bindir}/sg
197 %attr(755,root,root) %{_sbindir}/chpasswd
198 %attr(755,root,root) %{_sbindir}/groupadd
199 %attr(755,root,root) %{_sbindir}/groupdel
200 %attr(755,root,root) %{_sbindir}/groupmod
201 %attr(755,root,root) %{_sbindir}/grpconv
202 %attr(755,root,root) %{_sbindir}/grpck
203 %attr(755,root,root) %{_sbindir}/grpunconv
204 %attr(755,root,root) %{_sbindir}/pwconv
205 %attr(755,root,root) %{_sbindir}/pwck
206 %attr(755,root,root) %{_sbindir}/pwunconv
207 %attr(755,root,root) %{_sbindir}/rpasswdd
208 %attr(755,root,root) %{_sbindir}/useradd
209 %attr(755,root,root) %{_sbindir}/userdel
210 %attr(755,root,root) %{_sbindir}/usermod
211 %attr(755,root,root) %{_sbindir}/vigr
212 %attr(755,root,root) %{_sbindir}/vipw
213 %{_mandir}/man?/*
214 %exclude %{_mandir}/man8/rpasswdd*
215 %exclude %{_mandir}/man8/pam_rpasswd.8*
216
217 %files -n rpasswdd
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_sbindir}/rpasswdd
220 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
221 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
222 %{_mandir}/man8/rpasswdd*
223
224 %files -n pam-pam_rpasswd
225 %defattr(644,root,root,755)
226 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
227 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.111384 seconds and 4 git commands to generate.