]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
Fix build with automake 1.13
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # don't build audit log plugin
4 %bcond_without  ldap            # build without LDAP support
5 %bcond_without  selinux         # build without SELinux support
6 %bcond_with     bioapi          # with BioAPI support in passwd
7 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
8 #
9 Summary:        Utilities to manage the passwd and shadow user information
10 Summary(pl.UTF-8):      Narzędzia do zarządzania informacjami o użytkownikach z passwd i shadow
11 Name:           pwdutils
12 Version:        3.2.19
13 Release:        1
14 License:        GPL v2
15 Group:          Base
16 #Source0:       ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
17 Source0:        http://www.linux-nis.org/download/pwdutils/%{name}-%{version}.tar.bz2
18 # Source0-md5:  25a77a0ab376eacf24ad5eab7af4cdce
19 Source1:        %{name}.useradd
20 Source2:        %{name}.rpasswdd.init
21 Source3:        %{name}.login.defs
22 Source4:        chage.pamd
23 Source5:        chfn.pamd
24 Source6:        chsh.pamd
25 Source7:        passwd.pamd
26 Source8:        useradd.pamd
27 Source9:        userdb.pamd
28 Source10:       rpasswd.pamd
29 Patch0:         %{name}-f-option.patch
30 Patch1:         %{name}-no_bash.patch
31 Patch2:         %{name}-silent_crontab.patch
32 Patch3:         %{name}-pl.po-update.patch
33 Patch4:         %{name}-selinux.patch
34 Patch5:         %{name}-am.patch
35 URL:            http://www.thkukuk.de/pam/pwdutils/
36 %{?with_audit:BuildRequires:    audit-libs-devel}
37 BuildRequires:  autoconf
38 BuildRequires:  automake >= 1:1.9
39 %{?with_bioapi:BuildRequires:   bioapi-devel}
40 BuildRequires:  gcc >= 5:3.2
41 BuildRequires:  gettext-devel
42 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.0.0}
43 BuildRequires:  libnscd-devel
44 %{?with_selinux:BuildRequires:  libselinux-devel}
45 BuildRequires:  libtool
46 BuildRequires:  libxcrypt-devel
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
48 BuildRequires:  openslp-devel
49 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
50 BuildRequires:  pam-devel
51 BuildRequires:  rpmbuild(macros) >= 1.268
52 BuildRequires:  sed >= 4.0
53 Requires:       pam >= 0.99.7.1
54 Provides:       shadow = 2:%{version}-%{release}
55 Provides:       shadow-extras = 2:%{version}-%{release}
56 Obsoletes:      shadow
57 Obsoletes:      shadow-extras
58 Obsoletes:      shadow-utils
59 Conflicts:      util-linux < 2.12-10
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # for pam module in /%{_lib}/security
63 %define         _libdir         /%{_lib}
64
65 %description
66 pwdutils is a collection of utilities to manage the passwd and shadow
67 user information. The difference to the shadow suite is that these
68 utilities can also modify the information stored in NIS, NIS+, or
69 LDAP. PAM is used for user authentication and changing the pasword. It
70 contains passwd, chage, chfn, chsh, and a daemon for changing the
71 password on a remote machine over a secure SSL connection. The daemon
72 also uses PAM so that it can change passwords independent of where
73 they are stored.
74
75 %description -l pl.UTF-8
76 pwdutils to zestaw narzędzi do zarządzania informacjami o
77 użytkownikach z passwd i shadow. Różnica w stosunku do pakietu shadow
78 polega na tym, że te narzędzia mogą także modyfikować informacje
79 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest używany do
80 uwierzytelniania użytkowników i zmiany haseł. Zestaw zawiera passwd,
81 chage, chfn, chsh oraz demona do zmiany hasła na zdalnej maszynie po
82 bezpiecznym połączeniu SSL. Demon także używa PAM, więc można zmieniać
83 hasła niezależnie od tego, gdzie są przechowywane.
84
85 %package log-audit
86 Summary:        audit log plugin for pwdutils
87 Summary(pl.UTF-8):      Wtyczka logująca audit dla pwdutils
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description log-audit
92 audit log plugin for pwdutils.
93
94 %description log-audit -l pl.UTF-8
95 Wtyczka logująca audit dla pwdutils.
96
97 %package -n rpasswd
98 Summary:        Remote password update client
99 Summary(pl.UTF-8):      Klient do zdalnego uaktualniania haseł
100 Group:          Applications/System
101
102 %description -n rpasswd
103 rpasswd changes passwords for user accounts on a remote server over a
104 secure SSL connection. A normal user may only change the password for
105 their own account, if the user knows the password of the administrator
106 account (in the moment this is the root password on the server), he
107 may change the password for any account if he calls rpasswd with the
108 -a option.
109
110 %description -n rpasswd -l pl.UTF-8
111 rpasswd pozwala zmieniać hasła użytkowników na zdalnym serwerze przy
112 użyciu bezpiecznego połączenia SSL. Zwykły użytkownik może zmienić
113 jedynie swoje hasło, a jeśli zna hasło administratora (obecnie jest to
114 hasło roota na serwerze), może zmienić hasło dla dowolnego konta
115 wywołując rpasswd z opcją -a.
116
117 %package -n rpasswdd
118 Summary:        Remote password update daemon
119 Summary(pl.UTF-8):      Demon do zdalnego uaktualniania haseł
120 Group:          Applications/System
121 Requires(post,preun):   /sbin/chkconfig
122 Requires:       rc-scripts
123
124 %description -n rpasswdd
125 rpasswdd is a daemon that lets users change their passwords in the
126 presence of a directory service like NIS, NIS+ or LDAP over a secure
127 SSL connection. rpasswdd behaves like the normal passwd(1) program and
128 uses PAM for authentication and changing the password, so it can be
129 configured very flexible for the local requirements.
130
131 %description -n rpasswdd -l pl.UTF-8
132 rpasswdd to demon pozwalający użytkownikom zmieniać hasła w obecności
133 usług katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
134 połączeniu SSL. rpasswdd zachowuje się tak, jak normalny program
135 passwd(1) i używam PAM do uwierzytelniania i zmiany haseł, więc może
136 być bardzo elastycznie konfigurowany dla lokalnych wymagań.
137
138 %package -n pam-pam_rpasswd
139 Summary:        pam_rpasswd - PAM module to change remote password
140 Summary(pl.UTF-8):      pam_rpasswd - moduł PAM do zdalnej zmiany hasła
141 Group:          Base
142 # rpasswd.conf is in rpasswd
143 Requires:       rpasswd = %{version}-%{release}
144
145 %description -n pam-pam_rpasswd
146 The pam_rpasswd PAM module is for changing the password of user
147 accounts on a remote server over a secure SSL connection. It only
148 provides functionality for one PAM management group: password
149 changing.
150
151 %description -n pam-pam_rpasswd -l pl.UTF-8
152 Moduł PAM pam_rpasswd służy do zmiany haseł dla kont użytkowników na
153 zdalnym serwerze po bezpiecznym połączeniu SSL. Udostępnia
154 funkcjonalność tylko dla jednej grupy zarządzania PAM: zmiany haseł.
155
156 %prep
157 %setup -q
158 %patch0 -p1
159 %patch1 -p1
160 %patch2 -p1
161 %patch3 -p1
162 %patch4 -p1
163 %patch5 -p1
164
165 %{__rm} po/stamp-po
166
167 %build
168 %{__gettextize}
169 %{__libtoolize}
170 %{__aclocal} -I m4
171 %{__autoconf}
172 %{__autoheader}
173 %{__automake}
174 %configure \
175         %{?with_bioapi:CPPFLAGS="-I/usr/include/bioapi"} \
176         %{!?with_bioapi:ac_cv_header_bioapi_h=no ac_cv_lib_bioapi100_BioAPI_Init=no} \
177         %{?with_audit:--enable-audit-plugin} \
178         %{!?with_gnutls:--disable-gnutls} \
179         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
180         --enable-nls \
181         --enable-pam_rpasswd \
182         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
183         --enable-slp \
184         --disable-rpath
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,security,skel/{etc,tmp}}
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 mv -f $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
195 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
196 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
197 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
198
199 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
200 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
201 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
202 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
203 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
204 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
205 install %{SOURCE10} $RPM_BUILD_ROOT/etc/pam.d/rpasswd
206
207 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pwdutils/*.{la,a}
208 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_*.la
209 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/init.d/rpasswdd
210
211 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
212 :> $RPM_BUILD_ROOT/etc/security/chfn.allow
213 :> $RPM_BUILD_ROOT/etc/security/chsh.allow
214
215 %find_lang %{name}
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %post
221 if [ ! -f %{_sysconfdir}/shadow ]; then
222         %{_sbindir}/pwconv
223 fi
224
225 %post -n rpasswdd
226 /sbin/chkconfig --add rpasswdd
227 %service rpasswdd restart "rpasswdd daemon"
228
229 %preun -n rpasswdd
230 if [ "$1" = "0" ]; then
231         %service rpasswdd stop
232         /sbin/chkconfig --del rpasswdd
233 fi
234
235 %files -f %{name}.lang
236 %defattr(644,root,root,755)
237 %doc AUTHORS ChangeLog NEWS README THANKS TODO
238 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/*
240 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
241 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.local
242 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/logging
243 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
244 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chfn
245 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
246 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
247 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
248 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
249 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.defs
250 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chfn.allow
251 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chsh.allow
252 %dir /etc/skel
253 %dir %config(missingok) %attr(750,root,root) /etc/skel/etc
254 %dir %config(missingok) %attr(700,root,root) /etc/skel/tmp
255 %attr(755,root,root) %{_bindir}/chage
256 %attr(4755,root,root) %{_bindir}/chfn
257 %attr(4755,root,root) %{_bindir}/chsh
258 %attr(4755,root,root) %{_bindir}/expiry
259 %attr(4755,root,root) %{_bindir}/gpasswd
260 %attr(4755,root,root) %{_bindir}/newgrp
261 %attr(4755,root,root) %{_bindir}/passwd
262 %attr(4755,root,root) %{_bindir}/sg
263 %attr(755,root,root) %{_sbindir}/chpasswd
264 %attr(755,root,root) %{_sbindir}/groupadd
265 %attr(755,root,root) %{_sbindir}/groupdel
266 %attr(755,root,root) %{_sbindir}/groupmod
267 %attr(755,root,root) %{_sbindir}/grpconv
268 %attr(755,root,root) %{_sbindir}/grpck
269 %attr(755,root,root) %{_sbindir}/grpunconv
270 %attr(755,root,root) %{_sbindir}/pwconv
271 %attr(755,root,root) %{_sbindir}/pwck
272 %attr(755,root,root) %{_sbindir}/pwunconv
273 %attr(755,root,root) %{_sbindir}/useradd
274 %attr(755,root,root) %{_sbindir}/userdel
275 %attr(755,root,root) %{_sbindir}/usermod
276 %attr(755,root,root) %{_sbindir}/vigr
277 %attr(755,root,root) %{_sbindir}/vipw
278 %dir %{_libdir}/pwdutils
279 %attr(755,root,root) %{_libdir}/pwdutils/liblog_syslog.so*
280 %{_mandir}/man1/chage.1*
281 %{_mandir}/man1/chfn.1*
282 %{_mandir}/man1/chsh.1*
283 %{_mandir}/man1/expiry.1*
284 %{_mandir}/man1/gpasswd.1*
285 %{_mandir}/man1/newgrp.1*
286 %{_mandir}/man1/passwd.1*
287 %{_mandir}/man1/sg.1*
288 %{_mandir}/man5/login.defs.5*
289 %{_mandir}/man8/chpasswd.8*
290 %{_mandir}/man8/groupadd.8*
291 %{_mandir}/man8/groupdel.8*
292 %{_mandir}/man8/groupmod.8*
293 %{_mandir}/man8/grpck.8*
294 %{_mandir}/man8/grpconv.8*
295 %{_mandir}/man8/grpunconv.8*
296 %{_mandir}/man8/pwck.8*
297 %{_mandir}/man8/pwconv.8*
298 %{_mandir}/man8/pwunconv.8*
299 %{_mandir}/man8/useradd.8*
300 %{_mandir}/man8/userdel.8*
301 %{_mandir}/man8/usermod.8*
302 %{_mandir}/man8/vigr.8*
303 %{_mandir}/man8/vipw.8*
304
305 %if %{with audit}
306 %files log-audit
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/pwdutils/liblog_audit.so*
309 %endif
310
311 %files -n rpasswd
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_bindir}/rpasswd
314 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpasswd.conf
315 %{_mandir}/man1/rpasswd.1*
316 %{_mandir}/man5/rpasswd.conf.5*
317
318 %files -n rpasswdd
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_sbindir}/rpasswdd
321 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
322 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/rpasswd
323 %{_mandir}/man8/rpasswdd.8*
324
325 %files -n pam-pam_rpasswd
326 %defattr(644,root,root,755)
327 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
328 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.776456 seconds and 3 git commands to generate.