]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
b3ff3fd5df1a2254fbad86b72bb9dae0c0d18c33
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 #
4 Summary:        Utilities to manage the passwd and shadow user information
5 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
6 Name:           pwdutils
7 Version:        2.4.90
8 Release:        1
9 License:        GPL
10 Group:          Applications/System
11 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
12 # Source0-md5:  8c53806b01d10fef9f21cdc4ce57490c
13 Source1:        %{name}.useradd
14 Source2:        %{name}.rpasswdd.init
15 Source3:        %{name}.login.defs
16 Source4:        chage.pamd
17 Source5:        chfn.pamd
18 Source6:        chsh.pamd
19 Source7:        passwd.pamd
20 Source8:        useradd.pamd
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gettext-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  openldap-devel
26 BuildRequires:  openssl-devel
27 BuildRequires:  pam-devel
28 Obsoletes:      shadow
29 Obsoletes:      shadow-extras
30 Provides:       shadow
31 Provides:       shadow-extras
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 pwdutils is a collection of utilities to manage the passwd and shadow
36 user information. The difference to the shadow suite is that these
37 utilities can also modify the information stored in NIS, NIS+, or
38 LDAP. PAM is used for user authentication and changing the pasword. It
39 contains passwd, chage, chfn, chsh, and a daemon for changing the
40 password on a remote machine over a secure SSL connection. The daemon
41 also uses PAM so that it can change passwords independent of where
42 they are stored.
43
44 %description -l pl
45 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
46 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
47 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
48 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
49 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
50 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
51 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
52 has³a niezale¿nie od tego, gdzie s± przechowywane.
53
54 %package -n rpasswdd
55 Summary:        Remote password update daemon
56 Summary(pl):    Demon do zdalnego uaktualniania hase³
57 Group:          Applications/System
58
59 %description -n rpasswdd
60 rpasswdd is a daemon that lets users change their passwords in the
61 presence of a directory service like NIS, NIS+ or LDAP over a secure
62 SSL connection. rpasswdd behaves like the normal passwd(1) program and
63 uses PAM for authentication and changing the password, so it can be
64 configured very flexibel for the local requirements.
65
66 %description -n rpasswdd -l pl
67 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
68 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
69 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
70 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
71 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__gettextize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         --enable-selinux \
84         --disable-rpath
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
95 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
96 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
97 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
98
99 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
100 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
101 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
102 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
103 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
104
105 :> $RPM_BUILD_ROOT/etc/shadow
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /sbin/ldconfig
114 if [ ! -f /etc/shadow ]; then
115         %{_sbindir}/pwconv
116 fi
117
118 %postun -p /sbin/ldconfig
119
120 %post -n rpasswdd
121 /sbin/chkconfig --add rpasswdd
122 if [ -f /var/lock/subsys/rpasswdd ]; then
123         /etc/rc.d/init.d/rpasswdd restart 1>&2
124 else
125         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
126 fi
127
128 %preun -n rpasswdd
129 if [ "$1" = "0" ]; then
130         if [ -f /var/lock/subsys/rpasswdd ]; then
131                 /etc/rc.d/init.d/rpasswdd stop 1>&2
132         fi
133         /sbin/chkconfig --del rpasswdd
134 fi
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc ChangeLog NEWS README THANKS TODO
139 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
140 %attr(750,root,root) %dir %{_sysconfdir}/default
141 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
142 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
143 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
144 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
145 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
146 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
147 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
148 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
149 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
150 %dir /etc/skel
151 %attr(755,root,root) %{_bindir}/chage
152 %attr(4755,root,root) %{_bindir}/chfn
153 %attr(4755,root,root) %{_bindir}/chsh
154 %attr(4755,root,root) %{_bindir}/expiry
155 %attr(4755,root,root) %{_bindir}/gpasswd
156 %attr(4755,root,root) %{_bindir}/passwd
157 %attr(755,root,root) %{_bindir}/rpasswd
158 %attr(755,root,root) %{_sbindir}/chpasswd
159 %attr(755,root,root) %{_sbindir}/groupadd
160 %attr(755,root,root) %{_sbindir}/groupdel
161 %attr(755,root,root) %{_sbindir}/groupmod
162 %attr(755,root,root) %{_sbindir}/grpconv
163 %attr(755,root,root) %{_sbindir}/pwconv
164 %attr(755,root,root) %{_sbindir}/pwunconv
165 %attr(755,root,root) %{_sbindir}/rpasswdd
166 %attr(755,root,root) %{_sbindir}/useradd
167 %attr(755,root,root) %{_sbindir}/userdel
168 %attr(755,root,root) %{_sbindir}/usermod
169 %attr(755,root,root) %{_sbindir}/vigr
170 %attr(755,root,root) %{_sbindir}/vipw
171 %{_mandir}/man?/*
172 %exclude %{_mandir}/man8/rpasswdd*
173
174 %files -n rpasswdd
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_sbindir}/rpasswdd
177 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
178 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
179 %{_mandir}/man8/rpasswdd*
This page took 0.029787 seconds and 2 git commands to generate.