]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- rel 2 for changed login.defs
[packages/pwdutils.git] / pwdutils.spec
1 # TODO: review default login.defs
2 #
3 # Conditional build:
4 %bcond_without  ldap            # build without LDAP support
5 %bcond_without  selinux         # build without SELinux support
6 #
7 Summary:        Utilities to manage the passwd and shadow user information
8 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
9 Name:           pwdutils
10 Version:        3.0
11 Release:        2
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
15 # Source0-md5:  be954620dfb8f2b36b398d7d4742d205
16 Source1:        %{name}.useradd
17 Source2:        %{name}.rpasswdd.init
18 Source3:        %{name}.login.defs
19 Source4:        chage.pamd
20 Source5:        chfn.pamd
21 Source6:        chsh.pamd
22 Source7:        passwd.pamd
23 Source8:        useradd.pamd
24 Source9:        userdb.pamd
25 Patch0:         %{name}-f-option.patch
26 Patch1:         %{name}-pl.po-update.patch
27 Patch2:         %{name}-no_bash.patch
28 Patch3:         %{name}-silent_crontab.patch
29 URL:            http://www.thkukuk.de/pam/pwdutils/
30 BuildRequires:  autoconf
31 BuildRequires:  automake >= 1:1.7
32 BuildRequires:  gcc >= 5:3.2
33 BuildRequires:  gettext-devel
34 BuildRequires:  libnscd-devel
35 %{?with_selinux:BuildRequires:  libselinux-devel}
36 BuildRequires:  libtool
37 %{?with_ldap:BuildRequires:     openldap-devel}
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  openslp-devel
40 BuildRequires:  pam-devel
41 BuildRequires:  sed >= 4.0
42 Provides:       shadow = 2:%{version}-%{release}
43 Provides:       shadow-extras = 2:%{version}-%{release}
44 Obsoletes:      shadow
45 Obsoletes:      shadow-extras
46 Obsoletes:      shadow-utils
47 Conflicts:      util-linux < 2.12-10
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # for pam module in /%{_lib}/security
51 %define         _libdir         /%{_lib}
52
53 %description
54 pwdutils is a collection of utilities to manage the passwd and shadow
55 user information. The difference to the shadow suite is that these
56 utilities can also modify the information stored in NIS, NIS+, or
57 LDAP. PAM is used for user authentication and changing the pasword. It
58 contains passwd, chage, chfn, chsh, and a daemon for changing the
59 password on a remote machine over a secure SSL connection. The daemon
60 also uses PAM so that it can change passwords independent of where
61 they are stored.
62
63 %description -l pl
64 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
65 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
66 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
67 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
68 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
69 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
70 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
71 has³a niezale¿nie od tego, gdzie s± przechowywane.
72
73 %package -n rpasswdd
74 Summary:        Remote password update daemon
75 Summary(pl):    Demon do zdalnego uaktualniania hase³
76 Group:          Applications/System
77 PreReq:         rc-scripts
78 Requires(post,preun):   /sbin/chkconfig
79
80 %description -n rpasswdd
81 rpasswdd is a daemon that lets users change their passwords in the
82 presence of a directory service like NIS, NIS+ or LDAP over a secure
83 SSL connection. rpasswdd behaves like the normal passwd(1) program and
84 uses PAM for authentication and changing the password, so it can be
85 configured very flexibel for the local requirements.
86
87 %description -n rpasswdd -l pl
88 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
89 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
90 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
91 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
92 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
93
94 %package -n pam-pam_rpasswd
95 Summary:        pam_rpasswd - PAM module to change remote password
96 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
97 Group:          Base
98 # rpasswd.conf is in base
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n pam-pam_rpasswd
102 The pam_rpasswd PAM module is for changing the password of user
103 accounts on a remote server over a secure SSL connection. It only
104 provides functionality for one PAM management group: password
105 changing.
106
107 %description -n pam-pam_rpasswd -l pl
108 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
109 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
110 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117 %patch3 -p1
118
119 rm -f po/stamp-po
120
121 sed -i -e 's/-Werror //' configure.in
122
123 %build
124 %{__gettextize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --enable-pam_rpasswd \
131         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
132         --enable-slp \
133         --enable-ssl \
134         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
135         --enable-nls \
136         --disable-rpath
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,security,skel}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 mv -f $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
147 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
148 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
149 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
150
151 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
152 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
153 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
154 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
155 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
156 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
157
158 rm -f $RPM_BUILD_ROOT%{_libdir}/pwdutils/*.{la,a}
159
160 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
161 :> $RPM_BUILD_ROOT/etc/security/chfn.allow
162 :> $RPM_BUILD_ROOT/etc/security/chsh.allow
163
164 %find_lang %{name}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post
170 if [ ! -f /etc/shadow ]; then
171         %{_sbindir}/pwconv
172 fi
173
174 %post -n rpasswdd
175 /sbin/chkconfig --add rpasswdd
176 if [ -f /var/lock/subsys/rpasswdd ]; then
177         /etc/rc.d/init.d/rpasswdd restart 1>&2
178 else
179         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
180 fi
181
182 %preun -n rpasswdd
183 if [ "$1" = "0" ]; then
184         if [ -f /var/lock/subsys/rpasswdd ]; then
185                 /etc/rc.d/init.d/rpasswdd stop 1>&2
186         fi
187         /sbin/chkconfig --del rpasswdd
188 fi
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc ChangeLog NEWS README THANKS TODO
193 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
194 %attr(750,root,root) %dir %{_sysconfdir}/default
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/*
196 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
197 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.local
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/logging
199 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chfn
201 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
202 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
203 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
204 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
205 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.defs
206 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rpasswd.conf
207 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chfn.allow
208 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chsh.allow
209 %dir /etc/skel
210 %attr(755,root,root) %{_bindir}/chage
211 %attr(4755,root,root) %{_bindir}/chfn
212 %attr(4755,root,root) %{_bindir}/chsh
213 %attr(4755,root,root) %{_bindir}/expiry
214 %attr(4755,root,root) %{_bindir}/gpasswd
215 %attr(755,root,root) %{_bindir}/newgrp
216 %attr(4755,root,root) %{_bindir}/passwd
217 %attr(755,root,root) %{_bindir}/rpasswd
218 %attr(755,root,root) %{_bindir}/sg
219 %attr(755,root,root) %{_sbindir}/chpasswd
220 %attr(755,root,root) %{_sbindir}/groupadd
221 %attr(755,root,root) %{_sbindir}/groupdel
222 %attr(755,root,root) %{_sbindir}/groupmod
223 %attr(755,root,root) %{_sbindir}/grpconv
224 %attr(755,root,root) %{_sbindir}/grpck
225 %attr(755,root,root) %{_sbindir}/grpunconv
226 %attr(755,root,root) %{_sbindir}/pwconv
227 %attr(755,root,root) %{_sbindir}/pwck
228 %attr(755,root,root) %{_sbindir}/pwunconv
229 %attr(755,root,root) %{_sbindir}/rpasswdd
230 %attr(755,root,root) %{_sbindir}/useradd
231 %attr(755,root,root) %{_sbindir}/userdel
232 %attr(755,root,root) %{_sbindir}/usermod
233 %attr(755,root,root) %{_sbindir}/vigr
234 %attr(755,root,root) %{_sbindir}/vipw
235 %dir %{_libdir}/pwdutils
236 %attr(755,root,root) %{_libdir}/pwdutils/liblog_syslog.so*
237 %{_mandir}/man?/*
238 %exclude %{_mandir}/man8/rpasswdd.8*
239 %exclude %{_mandir}/man8/pam_rpasswd.8*
240
241 %files -n rpasswdd
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_sbindir}/rpasswdd
244 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
245 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/rpasswd
246 %{_mandir}/man8/rpasswdd.8*
247
248 %files -n pam-pam_rpasswd
249 %defattr(644,root,root,755)
250 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
251 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.141057 seconds and 3 git commands to generate.