]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated to 2.3.99
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 # - subpackage with rpasswd daemon
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.3.99
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  3497ade4e60b5ed814a0ebec89cc252f
14 Source1:        %{name}.useradd
15 # missing in repo
16 #Source2:       %{name}.rpasswdd.init
17 Source3:        %{name}.login.defs
18 Source4:        chage.pamd
19 Source5:        chfn.pamd
20 Source6:        chsh.pamd
21 Source7:        passwd.pamd
22 Source8:        useradd.pamd
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gettext-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  pam-devel
29 Obsoletes:      shadow
30 Obsoletes:      shadow-extras
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 pwdutils is a collection of utilities to manage the passwd and shadow
35 user information. The difference to the shadow suite is that these
36 utilities can also modify the information stored in NIS, NIS+, or
37 LDAP. PAM is used for user authentication and changing the pasword. It
38 contains passwd, chage, chfn, chsh, and a daemon for changing the
39 password on a remote machine over a secure SSL connection. The daemon
40 also uses PAM so that it can change passwords independent of where
41 they are stored.
42
43 %description -l pl
44 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
45 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
46 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
47 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
48 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
49 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
50 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
51 has³a niezale¿nie od tego, gdzie s± przechowywane.
52
53 %prep
54 %setup -q
55
56 %build
57 %{__gettextize}
58 %{__aclocal}
59 %{__autoconf}
60 %{__autoheader}
61 %{__automake}
62 %configure \
63         --disable-rpath
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT/etc/pwdutils
74 install %{SOURCE1} $RPM_BUILD_ROOT/etc/default/useradd
75 #install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
76 install %{SOURCE3} $RPM_BUILD_ROOT/etc/login.defs
77
78 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
79 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
80 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
81 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
82 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
83
84 %find_lang %{name}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 /sbin/ldconfig
91 if [ ! -f /etc/shadow ]; then
92         %{_sbindir}/pwconv
93 fi
94
95 %postun -p /sbin/ldconfig
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc NEWS README THANKS TODO
100 %attr(750,root,root) %dir %{_sysconfdir}/default
101 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
102 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
103 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
104 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
105 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
106 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
107 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
108 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
109 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
110 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
111 %dir /etc/skel
112 %attr(755,root,root) %{_bindir}/chage
113 %attr(4755,root,root) %{_bindir}/chfn
114 %attr(4755,root,root) %{_bindir}/chsh
115 %attr(4755,root,root) %{_bindir}/expiry
116 %attr(4755,root,root) %{_bindir}/gpasswd
117 %attr(4755,root,root) %{_bindir}/passwd
118 %attr(755,root,root) %{_bindir}/rpasswd
119 %attr(755,root,root) %{_sbindir}/chpasswd
120 %attr(755,root,root) %{_sbindir}/groupadd
121 %attr(755,root,root) %{_sbindir}/groupdel
122 %attr(755,root,root) %{_sbindir}/groupmod
123 %attr(755,root,root) %{_sbindir}/rpasswdd
124 %attr(755,root,root) %{_sbindir}/useradd
125 %attr(755,root,root) %{_sbindir}/userdel
126 %attr(755,root,root) %{_sbindir}/usermod
127 %attr(755,root,root) %{_sbindir}/vigr
128 %attr(755,root,root) %{_sbindir}/vipw
129 %{_mandir}/man?/*
130 #%attr(754,root,root) /etc/rc.d/init.d/rpasswdd
This page took 0.064272 seconds and 3 git commands to generate.