]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated to 2.5.95
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 #
4 Summary:        Utilities to manage the passwd and shadow user information
5 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
6 Name:           pwdutils
7 Version:        2.5.95
8 Release:        1
9 License:        GPL
10 Group:          Applications/System
11 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
12 # Source0-md5:  635d74899b81b85d1495718f52c6df8c
13 Source1:        %{name}.useradd
14 Source2:        %{name}.rpasswdd.init
15 Source3:        %{name}.login.defs
16 Source4:        chage.pamd
17 Source5:        chfn.pamd
18 Source6:        chsh.pamd
19 Source7:        passwd.pamd
20 Source8:        useradd.pamd
21 Source9:        userdb.pamd
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gcc >= 5:3.2
25 BuildRequires:  gettext-devel
26 BuildRequires:  libselinux-devel
27 BuildRequires:  openldap-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  pam-devel
30 Provides:       shadow = 2:%{version}-%{release}
31 Provides:       shadow-extras = 2:%{version}-%{release}
32 Obsoletes:      shadow
33 Obsoletes:      shadow-extras 
34 Conflicts:      util-linux < 2.12-10
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 pwdutils is a collection of utilities to manage the passwd and shadow
39 user information. The difference to the shadow suite is that these
40 utilities can also modify the information stored in NIS, NIS+, or
41 LDAP. PAM is used for user authentication and changing the pasword. It
42 contains passwd, chage, chfn, chsh, and a daemon for changing the
43 password on a remote machine over a secure SSL connection. The daemon
44 also uses PAM so that it can change passwords independent of where
45 they are stored.
46
47 %description -l pl
48 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
49 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
50 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
51 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
52 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
53 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
54 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
55 has³a niezale¿nie od tego, gdzie s± przechowywane.
56
57 %package -n rpasswdd
58 Summary:        Remote password update daemon
59 Summary(pl):    Demon do zdalnego uaktualniania hase³
60 Group:          Applications/System
61
62 %description -n rpasswdd
63 rpasswdd is a daemon that lets users change their passwords in the
64 presence of a directory service like NIS, NIS+ or LDAP over a secure
65 SSL connection. rpasswdd behaves like the normal passwd(1) program and
66 uses PAM for authentication and changing the password, so it can be
67 configured very flexibel for the local requirements.
68
69 %description -n rpasswdd -l pl
70 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
71 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
72 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
73 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
74 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
75
76 %prep
77 %setup -q
78
79 %build
80 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
81 %{__gettextize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --enable-selinux \
88         --disable-rpath
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
100 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
101 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
102
103 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
104 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
105 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
106 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
107 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
108 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
109
110 :> $RPM_BUILD_ROOT/etc/shadow
111
112 %find_lang %{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 /sbin/ldconfig
119 if [ ! -f /etc/shadow ]; then
120         %{_sbindir}/pwconv
121 fi
122
123 %postun -p /sbin/ldconfig
124
125 %post -n rpasswdd
126 /sbin/chkconfig --add rpasswdd
127 if [ -f /var/lock/subsys/rpasswdd ]; then
128         /etc/rc.d/init.d/rpasswdd restart 1>&2
129 else
130         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
131 fi
132
133 %preun -n rpasswdd
134 if [ "$1" = "0" ]; then
135         if [ -f /var/lock/subsys/rpasswdd ]; then
136                 /etc/rc.d/init.d/rpasswdd stop 1>&2
137         fi
138         /sbin/chkconfig --del rpasswdd
139 fi
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %doc ChangeLog NEWS README THANKS TODO
144 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
145 %attr(750,root,root) %dir %{_sysconfdir}/default
146 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
147 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
148 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
149 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
150 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
151 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
152 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
153 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
154 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
155 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
156 %dir /etc/skel
157 %attr(755,root,root) %{_bindir}/chage
158 %attr(4755,root,root) %{_bindir}/chfn
159 %attr(4755,root,root) %{_bindir}/chsh
160 %attr(4755,root,root) %{_bindir}/expiry
161 %attr(4755,root,root) %{_bindir}/gpasswd
162 %attr(755,root,root) %{_bindir}/newgrp
163 %attr(4755,root,root) %{_bindir}/passwd
164 %attr(755,root,root) %{_bindir}/rpasswd
165 %attr(755,root,root) %{_sbindir}/chpasswd
166 %attr(755,root,root) %{_sbindir}/groupadd
167 %attr(755,root,root) %{_sbindir}/groupdel
168 %attr(755,root,root) %{_sbindir}/groupmod
169 %attr(755,root,root) %{_sbindir}/grpconv
170 %attr(755,root,root) %{_sbindir}/grpck
171 %attr(755,root,root) %{_sbindir}/grpunconv
172 %attr(755,root,root) %{_sbindir}/pwconv
173 %attr(755,root,root) %{_sbindir}/pwck
174 %attr(755,root,root) %{_sbindir}/pwunconv
175 %attr(755,root,root) %{_sbindir}/rpasswdd
176 %attr(755,root,root) %{_sbindir}/useradd
177 %attr(755,root,root) %{_sbindir}/userdel
178 %attr(755,root,root) %{_sbindir}/usermod
179 %attr(755,root,root) %{_sbindir}/vigr
180 %attr(755,root,root) %{_sbindir}/vipw
181 %{_mandir}/man?/*
182 %exclude %{_mandir}/man8/rpasswdd*
183
184 %files -n rpasswdd
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_sbindir}/rpasswdd
187 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
188 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
189 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
190 %{_mandir}/man8/rpasswdd*
This page took 0.062175 seconds and 3 git commands to generate.