]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
Provides user/group ftpauth
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     2
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.42
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  4022f38939f6a112b18c1a43dee552c1
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33
34 Patch5:         %{name}-passwd_location.patch
35 Patch6:         %{name}-additionalgid.patch
36 Patch7:         audit_cap.patch
37 Patch8:         %{name}-apparmor.patch
38 Patch9:         %{name}-mysql-utf8.patch
39 URL:            http://www.pureftpd.org/
40 %{?with_extra:BuildRequires:    autoconf}
41 %{?with_extra:BuildRequires:    automake}
42 BuildRequires:  libapparmor-devel
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post,preun):   /sbin/chkconfig
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(postun):       /usr/sbin/userdel
55 Requires(pre):  /bin/id
56 Requires(pre):  /usr/bin/getgid
57 Requires(pre):  /usr/sbin/groupadd
58 Requires(pre):  /usr/sbin/useradd
59 Requires:       pam >= 0.79.0
60 %{!?with_extra:Requires:        perl-base}
61 Requires:       rc-scripts
62 Provides:       ftpserver
63 Provides:       user(ftpauth)
64 Provides:       group(ftpauth)
65 Conflicts:      man-pages < 1.51
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     /etc/ftpd
69 %define         _ftpdir         /home/services/ftp
70 %define         schemadir       /usr/share/openldap/schema
71
72 %description
73 Pure-FTPd is a fast, production-quality, standard-comformant FTP
74 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
75 has no known security flaw, it is really trivial to set up and it is
76 especially designed for modern Linux kernels (setfsuid, sendfile,
77 capabilities) . Features include PAM support, IPv6, chroot()ed home
78 directories, virtual domains, built-in LS, anti-warez system, bounded
79 ports for passive downloads...
80
81 %description -l pl.UTF-8
82 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
83 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
84 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
85 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
86 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
87 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
88 LS, system anty-warezowy, ograniczanie portów dla pasywnych
89 połączeń...
90
91 %package -n openldap-schema-pureftpd
92 Summary:        Pure-FTPd LDAP schema
93 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
94 Group:          Networking/Daemons
95 Requires(post,postun):  sed >= 4.0
96 Requires:       openldap-servers
97 Requires:       sed >= 4.0
98 %if "%{_rpmversion}" >= "5"
99 BuildArch:      noarch
100 %endif
101
102 %description -n openldap-schema-pureftpd
103 This package contains an Pure-FTPd openldap schema.
104
105 %description -n openldap-schema-pureftpd -l pl.UTF-8
106 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
107
108 %prep
109 %setup -q -a 5
110 %patch0 -p0
111 %patch1 -p1
112 %patch3 -p1
113
114 %patch5 -p1
115 %patch6 -p1
116 %patch7 -p1
117 %patch8 -p1
118 %patch9 -p1
119
120 %{?with_extra:%patch2 -p1}
121
122 %build
123 %{__aclocal} -Im4
124 %{__autoconf}
125 %{__autoheader}
126 %configure \
127         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
128         --with-boring \
129         --with-altlog \
130         --with-cookie \
131         --with-diraliases \
132         --with-extauth \
133         --with-ftpwho \
134         --with-language=english \
135         %{!?with_cap:--without-capabilities} \
136         %{?with_ldap:--with-ldap} \
137         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
138         --with-pam \
139         --with-peruserlimits \
140         --with-rfc2640 \
141         %{?with_pgsql:--with-pgsql} \
142         --with-privsep \
143         %{?with_puredb:--with-puredb} \
144         --with-quotas \
145         --with-ratios \
146         --with-throttling \
147         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
148         --with-uploadscript \
149         --with-virtualchroot \
150         --with-virtualhosts \
151         --with-apparmor
152
153 %if %{with extra}
154 cd pure-config
155 %{__aclocal}
156 %{__autoconf}
157 %{__autoheader}
158 %{__automake}
159 %configure
160 %{__make}
161 %endif
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
166         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
172 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
173 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
174
175 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
176 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
177 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
178 cp -p configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
179 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
180 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
181
182 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
183
184 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
185
186 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
187 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
188
189 %if %{with extra}
190 %{__make} -C pure-config install \
191         DESTDIR=$RPM_BUILD_ROOT
192 %endif
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %post
198 /sbin/chkconfig --add %{name}
199 %service %{name} restart "PureFTPD daemon"
200
201 %pre
202 %groupadd -g 326 ftpauth
203 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
204
205 %preun
206 if [ "$1" = "0" ]; then
207         %service %{name} stop
208         /sbin/chkconfig --del %{name}
209 fi
210
211 %postun
212 if [ "$1" = "0" ]; then
213         %userremove ftpauth
214         %groupremove ftpauth
215 fi
216
217 %post -n openldap-schema-pureftpd
218 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
219 %service -q ldap restart
220
221 %postun -n openldap-schema-pureftpd
222 if [ "$1" = "0" ]; then
223         %openldap_schema_unregister %{schemadir}/pureftpd.schema
224         %service -q ldap restart
225 fi
226
227 %triggerpostun -- %{name} < 1.0.41-2
228 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
229 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
230 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
231 exit 0
232
233 %files
234 %defattr(644,root,root,755)
235 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
236 %attr(755,root,root) %{_bindir}/*
237 %attr(755,root,root) %{_sbindir}/*
238 %attr(754,root,root) /etc/rc.d/init.d/%{name}
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
240 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
241 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
242 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
243 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
244 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
245 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
246 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
247 %attr(710,root,ftp) %dir %{_sysconfdir}
248 %dir %{_sysconfdir}/vhosts
249 %dir %{_sysconfdir}/pure-ftpd
250 %dir %{_ftpdir}
251 %{_mandir}/man?/*
252 %lang(ja) %{_mandir}/ja/man5/ftpusers*
253 %lang(pl) %{_mandir}/pl/man5/ftpusers*
254 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
255 %lang(ru) %{_mandir}/ru/man5/ftpusers*
256
257 %files -n openldap-schema-pureftpd
258 %defattr(644,root,root,755)
259 %{schemadir}/pureftpd.schema
This page took 0.081912 seconds and 3 git commands to generate.