]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- packaged pure-ftpd.sysconfig
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        5%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
34 Patch5:         %{name}-auth-can-delete-pure.patch
35 URL:            http://www.pureftpd.org/
36 %{?with_extra:BuildRequires:    autoconf}
37 %{?with_extra:BuildRequires:    automake}
38 %{?with_cap:BuildRequires:      libcap-devel}
39 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
40 %{?with_mysql:BuildRequires:    mysql-devel}
41 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
42 %{?with_tls:BuildRequires:      openssl-devel}
43 BuildRequires:  pam-devel
44 %{?with_pgsql:BuildRequires:    postgresql-devel}
45 BuildRequires:  rpmbuild(macros) >= 1.304
46 Requires(post,preun):   /sbin/chkconfig
47 Requires:       pam >= 0.79.0
48 %{!?with_extra:Requires:        perl-base}
49 Requires:       rc-scripts
50 Provides:       ftpserver
51 Obsoletes:      anonftp
52 Obsoletes:      bftpd
53 Obsoletes:      ftpd-BSD
54 Obsoletes:      ftpserver
55 Obsoletes:      glftpd
56 Obsoletes:      heimdal-ftpd
57 Obsoletes:      krb5-ftpd
58 Obsoletes:      linux-ftpd
59 Obsoletes:      muddleftpd
60 Obsoletes:      proftpd
61 Obsoletes:      proftpd-common
62 Obsoletes:      proftpd-inetd
63 Obsoletes:      proftpd-standalone
64 Obsoletes:      troll-ftpd
65 Obsoletes:      vsftpd
66 Obsoletes:      wu-ftpd
67 Conflicts:      man-pages < 1.51
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _sysconfdir     /etc/ftpd
71 %define         _ftpdir         /home/services/ftp
72 %define         schemadir       /usr/share/openldap/schema
73
74 %description
75 Pure-FTPd is a fast, production-quality, standard-comformant FTP
76 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
77 has no known security flaw, it is really trivial to set up and it is
78 especially designed for modern Linux kernels (setfsuid, sendfile,
79 capabilities) . Features include PAM support, IPv6, chroot()ed home
80 directories, virtual domains, built-in LS, anti-warez system, bounded
81 ports for passive downloads...
82
83 %description -l pl.UTF-8
84 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
85 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
86 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
87 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
88 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
89 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
90 LS, system anty-warezowy, ograniczanie portów dla pasywnych
91 połączeń...
92
93 %package -n openldap-schema-pureftpd
94 Summary:        Pure-FTPd LDAP schema
95 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
96 Group:          Networking/Daemons
97 Requires(post,postun):  sed >= 4.0
98 Requires:       openldap-servers
99 Requires:       sed >= 4.0 
100
101 %description -n openldap-schema-pureftpd
102 This package contains an Pure-FTPd openldap schema.
103
104 %description -n openldap-schema-pureftpd -l pl.UTF-8
105 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
106
107 %prep
108 %setup -q -a 5
109 %patch0 -p0
110 %patch3 -p1
111 %patch4 -p1
112 %patch5 -p1
113 %{?with_extra:%patch1 -p1}
114 %{?with_extra:%patch2 -p1}
115
116 %build
117 # drop --without-cork for Th
118 %configure \
119         --without-cork \
120         --with-boring \
121         --with-altlog \
122         --with-cookie \
123         --with-diraliases \
124         --with-extauth \
125         --with-ftpwho \
126         --with-language=english \
127         --with-largefile \
128         %{!?with_cap:--without-capabilities} \
129         %{?with_ldap:--with-ldap} \
130         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
131         --with-pam \
132         --with-peruserlimits \
133         %{?with_pgsql:--with-pgsql} \
134         --with-privsep \
135         %{?with_puredb:--with-puredb} \
136         --with-quotas \
137         --with-ratios \
138         --with-throttling \
139         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
140         --with-uploadscript \
141         --with-virtualchroot \
142         --with-virtualhosts
143
144 %if %{with extra}
145 cd pure-config
146 %{__aclocal}
147 %{__autoconf}
148 %{__autoheader}
149 %{__automake}
150 %configure
151 %{__make}
152 %endif
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
157         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
163 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
164 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
165
166 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
167 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
168 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
169 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
170 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
171 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
172
173 touch $RPM_BUILD_ROOT%{_sysconfdir}/ftpusers
174
175 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
176
177 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
178 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
179
180 %if %{with extra}
181 %{__make} -C pure-config install \
182         DESTDIR=$RPM_BUILD_ROOT
183 %endif
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post
189 /sbin/chkconfig --add %{name}
190 %service %{name} restart "PureFTPD daemon"
191
192 %preun
193 if [ "$1" = "0" ]; then
194         %service %{name} stop
195         /sbin/chkconfig --del %{name}
196 fi
197
198 %post -n openldap-schema-pureftpd
199 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
200 %service -q ldap restart
201
202 %postun -n openldap-schema-pureftpd
203 if [ "$1" = "0" ]; then
204         %openldap_schema_unregister %{schemadir}/pureftpd.schema
205         %service -q ldap restart
206 fi
207
208
209 %files
210 %defattr(644,root,root,755)
211 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
212 %attr(755,root,root) %{_bindir}/*
213 %attr(755,root,root) %{_sbindir}/*
214 %attr(754,root,root) /etc/rc.d/init.d/%{name}
215 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
216 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
217 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
218 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
219 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
220 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
221 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
222 %attr(710,root,ftp) %dir %{_sysconfdir}
223 %dir %{_sysconfdir}/vhosts
224 %dir %{_sysconfdir}/pure-ftpd
225 %dir %{_ftpdir}
226 %{_mandir}/man?/*
227 %lang(ja) %{_mandir}/ja/man5/ftpusers*
228 %lang(pl) %{_mandir}/pl/man5/ftpusers*
229 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
230 %lang(ru) %{_mandir}/ru/man5/ftpusers*
231
232 %files -n openldap-schema-pureftpd
233 %defattr(644,root,root,755)
234 %{schemadir}/pureftpd.schema
This page took 0.092531 seconds and 3 git commands to generate.