]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- added krb5-ftpd to obsoletes
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        5%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        ftpusers.tar.bz2
25 # Source3-md5:  76c80b6ec9f4d079a1e27316edddbe16
26 Source4:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
27 # Source4-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
28 Patch0:         %{name}-config.patch
29 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
30 Patch2:         %{name}-pure-pw_passwd.patch
31 Patch3:         %{name}-mysql_config.patch
32 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
33 Patch5:         %{name}-auth-can-delete-pure.patch
34 URL:            http://www.pureftpd.org/
35 %{?with_extra:BuildRequires:    autoconf}
36 %{?with_extra:BuildRequires:    automake}
37 %{?with_cap:BuildRequires:      libcap-devel}
38 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
39 %{?with_mysql:BuildRequires:    mysql-devel}
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
41 %{?with_tls:BuildRequires:      openssl-devel}
42 BuildRequires:  pam-devel
43 %{?with_pgsql:BuildRequires:    postgresql-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.304
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       pam >= 0.79.0
47 %{!?with_extra:Requires:        perl-base}
48 Requires:       rc-scripts
49 Provides:       ftpserver
50 Obsoletes:      anonftp
51 Obsoletes:      bftpd
52 Obsoletes:      ftpd-BSD
53 Obsoletes:      ftpserver
54 Obsoletes:      glftpd
55 Obsoletes:      heimdal-ftpd
56 Obsoletes:      krb5-ftpd
57 Obsoletes:      linux-ftpd
58 Obsoletes:      muddleftpd
59 Obsoletes:      proftpd
60 Obsoletes:      proftpd-common
61 Obsoletes:      proftpd-inetd
62 Obsoletes:      proftpd-standalone
63 Obsoletes:      troll-ftpd
64 Obsoletes:      vsftpd
65 Obsoletes:      wu-ftpd
66 Conflicts:      man-pages < 1.51
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _sysconfdir     /etc/ftpd
70 %define         _ftpdir         /home/services/ftp
71 %define         schemadir       /usr/share/openldap/schema
72
73 %description
74 Pure-FTPd is a fast, production-quality, standard-comformant FTP
75 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
76 has no known security flaw, it is really trivial to set up and it is
77 especially designed for modern Linux kernels (setfsuid, sendfile,
78 capabilities) . Features include PAM support, IPv6, chroot()ed home
79 directories, virtual domains, built-in LS, anti-warez system, bounded
80 ports for passive downloads...
81
82 %description -l pl.UTF-8
83 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
84 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
85 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
86 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
87 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
88 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
89 LS, system anty-warezowy, ograniczanie portów dla pasywnych
90 połączeń...
91
92 %package -n openldap-schema-pureftpd
93 Summary:        Pure-FTPd LDAP schema
94 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
95 Group:          Networking/Daemons
96 Requires(post,postun):  sed >= 4.0
97 Requires:       openldap-servers
98 Requires:       sed >= 4.0 
99
100 %description -n openldap-schema-pureftpd
101 This package contains an Pure-FTPd openldap schema.
102
103 %description -n openldap-schema-pureftpd -l pl.UTF-8
104 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
105
106 %prep
107 %setup -q -a 4
108 %patch0 -p0
109 %patch3 -p1
110 %patch4 -p1
111 %patch5 -p1
112 %{?with_extra:%patch1 -p1}
113 %{?with_extra:%patch2 -p1}
114
115 %build
116 # drop --without-cork for Th
117 %configure \
118         --without-cork \
119         --with-boring \
120         --with-altlog \
121         --with-cookie \
122         --with-diraliases \
123         --with-extauth \
124         --with-ftpwho \
125         --with-language=english \
126         --with-largefile \
127         %{!?with_cap:--without-capabilities} \
128         %{?with_ldap:--with-ldap} \
129         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
130         --with-pam \
131         --with-peruserlimits \
132         %{?with_pgsql:--with-pgsql} \
133         --with-privsep \
134         %{?with_puredb:--with-puredb} \
135         --with-quotas \
136         --with-ratios \
137         --with-throttling \
138         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
139         --with-uploadscript \
140         --with-virtualchroot \
141         --with-virtualhosts
142
143 %if %{with extra}
144 cd pure-config
145 %{__aclocal}
146 %{__autoconf}
147 %{__autoheader}
148 %{__automake}
149 %configure
150 %{__make}
151 %endif
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
156         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
162 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
163
164 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
165 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
166 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
167 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
168 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
169 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
170
171 touch $RPM_BUILD_ROOT%{_sysconfdir}/ftpusers
172
173 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
174
175 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
176 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
177
178 %if %{with extra}
179 %{__make} -C pure-config install \
180         DESTDIR=$RPM_BUILD_ROOT
181 %endif
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 /sbin/chkconfig --add %{name}
188 %service %{name} restart "PureFTPD daemon"
189
190 %preun
191 if [ "$1" = "0" ]; then
192         %service %{name} stop
193         /sbin/chkconfig --del %{name}
194 fi
195
196 %post -n openldap-schema-pureftpd
197 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
198 %service -q ldap restart
199
200 %postun -n openldap-schema-pureftpd
201 if [ "$1" = "0" ]; then
202         %openldap_schema_unregister %{schemadir}/pureftpd.schema
203         %service -q ldap restart
204 fi
205
206
207 %files
208 %defattr(644,root,root,755)
209 %doc AUTHORS ChangeLog CONTACT FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
210 %attr(755,root,root) %{_bindir}/*
211 %attr(755,root,root) %{_sbindir}/*
212 %attr(754,root,root) /etc/rc.d/init.d/%{name}
213 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
214 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
215 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
216 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
217 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
218 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
219 %attr(710,root,ftp) %dir %{_sysconfdir}
220 %dir %{_sysconfdir}/vhosts
221 %dir %{_sysconfdir}/pure-ftpd
222 %dir %{_ftpdir}
223 %{_mandir}/man?/*
224 %lang(ja) %{_mandir}/ja/man5/ftpusers*
225 %lang(pl) %{_mandir}/pl/man5/ftpusers*
226 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
227 %lang(ru) %{_mandir}/ru/man5/ftpusers*
228
229 %files -n openldap-schema-pureftpd
230 %defattr(644,root,root,755)
231 %{schemadir}/pureftpd.schema
This page took 0.07395 seconds and 3 git commands to generate.