]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
- pam_shells.so on account like sshd
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11 #
12 Summary:        Small, fast and secure FTP server
13 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
14 Name:           pure-ftpd
15 Version:        1.0.21
16 Release:        17%{?with_extra:extra}
17 Epoch:          0
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ca8a8dbec0cd9c8ea92fc4c37ea9c410
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-path_to_ssl_cert_in_config.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 Patch4:         %{name}-nosymlinks-hideuidmismatch.patch
34 Patch5:         %{name}-auth-can-delete-pure.patch
35 Patch6:         %{name}-nonssl-die.patch
36 Patch7:         %{name}-del-log-path.patch
37 Patch8:         %{name}-anonymous.patch
38 Patch9:         %{name}-sleep.patch
39 Patch10:        %{name}-passwd_location.patch
40 Patch11:        %{name}-additionalgid.patch
41 URL:            http://www.pureftpd.org/
42 %{?with_extra:BuildRequires:    autoconf}
43 %{?with_extra:BuildRequires:    automake}
44 %{?with_cap:BuildRequires:      libcap-devel}
45 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post,preun):   /sbin/chkconfig
53 Requires:       pam >= 0.79.0
54 %{!?with_extra:Requires:        perl-base}
55 Requires:       rc-scripts
56 Provides:       ftpserver
57 Conflicts:      man-pages < 1.51
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _sysconfdir     /etc/ftpd
61 %define         _ftpdir         /home/services/ftp
62 %define         schemadir       /usr/share/openldap/schema
63
64 %description
65 Pure-FTPd is a fast, production-quality, standard-comformant FTP
66 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
67 has no known security flaw, it is really trivial to set up and it is
68 especially designed for modern Linux kernels (setfsuid, sendfile,
69 capabilities) . Features include PAM support, IPv6, chroot()ed home
70 directories, virtual domains, built-in LS, anti-warez system, bounded
71 ports for passive downloads...
72
73 %description -l pl.UTF-8
74 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
75 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
76 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
77 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
78 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
79 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
80 LS, system anty-warezowy, ograniczanie portów dla pasywnych
81 połączeń...
82
83 %package -n openldap-schema-pureftpd
84 Summary:        Pure-FTPd LDAP schema
85 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
86 Group:          Networking/Daemons
87 Requires(post,postun):  sed >= 4.0
88 Requires:       openldap-servers
89 Requires:       sed >= 4.0
90
91 %description -n openldap-schema-pureftpd
92 This package contains an Pure-FTPd openldap schema.
93
94 %description -n openldap-schema-pureftpd -l pl.UTF-8
95 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
96
97 %prep
98 %setup -q -a 5
99 %patch0 -p0
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p1
103 %patch6 -p0
104 %patch7 -p1
105 %patch8 -p1
106 %patch9 -p1
107 %patch10 -p1
108 %patch11 -p1
109
110 %{?with_extra:%patch1 -p1}
111 %{?with_extra:%patch2 -p1}
112
113 %build
114 # drop --without-cork for Th
115 %configure \
116         --without-cork \
117         --with-boring \
118         --with-altlog \
119         --with-cookie \
120         --with-diraliases \
121         --with-extauth \
122         --with-ftpwho \
123         --with-language=english \
124         --with-largefile \
125         %{!?with_cap:--without-capabilities} \
126         %{?with_ldap:--with-ldap} \
127         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
128         --with-pam \
129         --with-peruserlimits \
130         %{?with_pgsql:--with-pgsql} \
131         --with-privsep \
132         %{?with_puredb:--with-puredb} \
133         --with-quotas \
134         --with-ratios \
135         --with-throttling \
136         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
137         --with-uploadscript \
138         --with-virtualchroot \
139         --with-virtualhosts
140
141 %if %{with extra}
142 cd pure-config
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 %configure
148 %{__make}
149 %endif
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
154         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
160 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
161 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
162
163 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
164 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
165 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
166 install configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
167 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
168 install pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
169
170 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
171
172 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
173
174 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
175 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
176
177 %if %{with extra}
178 %{__make} -C pure-config install \
179         DESTDIR=$RPM_BUILD_ROOT
180 %endif
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post
186 /sbin/chkconfig --add %{name}
187 %service %{name} restart "PureFTPD daemon"
188
189 %preun
190 if [ "$1" = "0" ]; then
191         %service %{name} stop
192         /sbin/chkconfig --del %{name}
193 fi
194
195 %post -n openldap-schema-pureftpd
196 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
197 %service -q ldap restart
198
199 %postun -n openldap-schema-pureftpd
200 if [ "$1" = "0" ]; then
201         %openldap_schema_unregister %{schemadir}/pureftpd.schema
202         %service -q ldap restart
203 fi
204
205
206 %files
207 %defattr(644,root,root,755)
208 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
209 %attr(755,root,root) %{_bindir}/*
210 %attr(755,root,root) %{_sbindir}/*
211 %attr(754,root,root) /etc/rc.d/init.d/%{name}
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
213 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
214 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
215 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
216 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
217 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
218 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
219 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
220 %attr(710,root,ftp) %dir %{_sysconfdir}
221 %dir %{_sysconfdir}/vhosts
222 %dir %{_sysconfdir}/pure-ftpd
223 %dir %{_ftpdir}
224 %{_mandir}/man?/*
225 %lang(ja) %{_mandir}/ja/man5/ftpusers*
226 %lang(pl) %{_mandir}/pl/man5/ftpusers*
227 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
228 %lang(ru) %{_mandir}/ru/man5/ftpusers*
229
230 %files -n openldap-schema-pureftpd
231 %defattr(644,root,root,755)
232 %{schemadir}/pureftpd.schema
This page took 0.960765 seconds and 3 git commands to generate.