]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
6831f9b726ce6dbaadf78478c8389356ee27c68a
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     2
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.42
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  4022f38939f6a112b18c1a43dee552c1
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33
34 Patch5:         %{name}-passwd_location.patch
35 Patch6:         %{name}-additionalgid.patch
36 Patch7:         audit_cap.patch
37 Patch8:         %{name}-apparmor.patch
38 Patch9:         %{name}-mysql-utf8.patch
39 URL:            http://www.pureftpd.org/
40 %{?with_extra:BuildRequires:    autoconf}
41 %{?with_extra:BuildRequires:    automake}
42 BuildRequires:  libapparmor-devel
43 %{?with_cap:BuildRequires:      libcap-devel}
44 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
45 BuildRequires:  libsodium-devel
46 %{?with_mysql:BuildRequires:    mysql-devel}
47 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
48 %{?with_tls:BuildRequires:      openssl-devel}
49 BuildRequires:  pam-devel
50 %{?with_pgsql:BuildRequires:    postgresql-devel}
51 BuildRequires:  rpmbuild(macros) >= 1.304
52 Requires(post,preun):   /sbin/chkconfig
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(postun):       /usr/sbin/userdel
55 Requires(pre):  /bin/id
56 Requires(pre):  /usr/bin/getgid
57 Requires(pre):  /usr/sbin/groupadd
58 Requires(pre):  /usr/sbin/useradd
59 Requires:       pam >= 0.79.0
60 %{!?with_extra:Requires:        perl-base}
61 Requires:       rc-scripts
62 Provides:       ftpserver
63 Conflicts:      man-pages < 1.51
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     /etc/ftpd
67 %define         _ftpdir         /home/services/ftp
68 %define         schemadir       /usr/share/openldap/schema
69
70 %description
71 Pure-FTPd is a fast, production-quality, standard-comformant FTP
72 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
73 has no known security flaw, it is really trivial to set up and it is
74 especially designed for modern Linux kernels (setfsuid, sendfile,
75 capabilities) . Features include PAM support, IPv6, chroot()ed home
76 directories, virtual domains, built-in LS, anti-warez system, bounded
77 ports for passive downloads...
78
79 %description -l pl.UTF-8
80 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
81 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
82 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
83 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
84 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
85 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
86 LS, system anty-warezowy, ograniczanie portów dla pasywnych
87 połączeń...
88
89 %package -n openldap-schema-pureftpd
90 Summary:        Pure-FTPd LDAP schema
91 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
92 Group:          Networking/Daemons
93 Requires(post,postun):  sed >= 4.0
94 Requires:       openldap-servers
95 Requires:       sed >= 4.0
96 %if "%{_rpmversion}" >= "5"
97 BuildArch:      noarch
98 %endif
99
100 %description -n openldap-schema-pureftpd
101 This package contains an Pure-FTPd openldap schema.
102
103 %description -n openldap-schema-pureftpd -l pl.UTF-8
104 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
105
106 %prep
107 %setup -q -a 5
108 %patch0 -p0
109 %patch1 -p1
110 %patch3 -p1
111
112 %patch5 -p1
113 %patch6 -p1
114 %patch7 -p1
115 %patch8 -p1
116 %patch9 -p1
117
118 %{?with_extra:%patch2 -p1}
119
120 %build
121 %{__aclocal} -Im4
122 %{__autoconf}
123 %{__autoheader}
124 %configure \
125         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
126         --with-boring \
127         --with-altlog \
128         --with-cookie \
129         --with-diraliases \
130         --with-extauth \
131         --with-ftpwho \
132         --with-language=english \
133         %{!?with_cap:--without-capabilities} \
134         %{?with_ldap:--with-ldap} \
135         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
136         --with-pam \
137         --with-peruserlimits \
138         --with-rfc2640 \
139         %{?with_pgsql:--with-pgsql} \
140         --with-privsep \
141         %{?with_puredb:--with-puredb} \
142         --with-quotas \
143         --with-ratios \
144         --with-throttling \
145         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
146         --with-uploadscript \
147         --with-virtualchroot \
148         --with-virtualhosts \
149         --with-apparmor
150
151 %if %{with extra}
152 cd pure-config
153 %{__aclocal}
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure
158 %{__make}
159 %endif
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
164         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
170 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
171 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
172
173 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
174 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
175 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
176 cp -p configuration-file/pure-ftpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
177 %{!?with_extra:install configuration-file/pure-config.pl $RPM_BUILD_ROOT%{_sbindir}}
178 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
179
180 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
181
182 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
183
184 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
185 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
186
187 %if %{with extra}
188 %{__make} -C pure-config install \
189         DESTDIR=$RPM_BUILD_ROOT
190 %endif
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post
196 /sbin/chkconfig --add %{name}
197 %service %{name} restart "PureFTPD daemon"
198
199 %pre
200 %groupadd -g 326 ftpauth
201 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
202
203 %preun
204 if [ "$1" = "0" ]; then
205         %service %{name} stop
206         /sbin/chkconfig --del %{name}
207 fi
208
209 %postun
210 if [ "$1" = "0" ]; then
211         %userremove ftpauth
212         %groupremove ftpauth
213 fi
214
215 %post -n openldap-schema-pureftpd
216 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
217 %service -q ldap restart
218
219 %postun -n openldap-schema-pureftpd
220 if [ "$1" = "0" ]; then
221         %openldap_schema_unregister %{schemadir}/pureftpd.schema
222         %service -q ldap restart
223 fi
224
225 %triggerpostun -- %{name} < 1.0.41-2
226 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
227 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
228 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
229 exit 0
230
231 %files
232 %defattr(644,root,root,755)
233 %doc AUTHORS ChangeLog CONTACT COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
234 %attr(755,root,root) %{_bindir}/*
235 %attr(755,root,root) %{_sbindir}/*
236 %attr(754,root,root) /etc/rc.d/init.d/%{name}
237 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
238 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
240 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
241 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
242 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
243 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
244 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
245 %attr(710,root,ftp) %dir %{_sysconfdir}
246 %dir %{_sysconfdir}/vhosts
247 %dir %{_sysconfdir}/pure-ftpd
248 %dir %{_ftpdir}
249 %{_mandir}/man?/*
250 %lang(ja) %{_mandir}/ja/man5/ftpusers*
251 %lang(pl) %{_mandir}/pl/man5/ftpusers*
252 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
253 %lang(ru) %{_mandir}/ru/man5/ftpusers*
254
255 %files -n openldap-schema-pureftpd
256 %defattr(644,root,root,755)
257 %{schemadir}/pureftpd.schema
This page took 0.041561 seconds and 2 git commands to generate.