]> git.pld-linux.org Git - packages/pulseview.git/commitdiff
- enable tests
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 9 Mar 2013 16:30:15 +0000 (17:30 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 9 Mar 2013 16:30:15 +0000 (17:30 +0100)
pulseview-build.patch
pulseview.spec

index d7bcb56bdd43c8c0b151a9daab020fd2d56ba7e9..069da4c747ae34f2b5110045c2156d7ab8dc6c71 100644 (file)
@@ -9,3 +9,37 @@
        unsigned int logic_probe_count = 0;
        unsigned int analog_probe_count = 0;
  
+--- pulseview-a7553da/pv/view/viewport.cpp~    2013-03-09 16:09:28.000000000 +0100
++++ pulseview-a7553da/pv/view/viewport.cpp     2013-03-09 17:23:03.369361232 +0100
+@@ -104,11 +104,6 @@
+       }
+ }
+-void Viewport::mouseReleaseEvent(QMouseEvent *event)
+-{
+-      assert(event);
+-}
+-
+ void Viewport::wheelEvent(QWheelEvent *event)
+ {
+       assert(event);
+--- pulseview-a7553da/pv/view/viewport.h~      2013-03-09 16:09:28.000000000 +0100
++++ pulseview-a7553da/pv/view/viewport.h       2013-03-09 17:23:07.126116283 +0100
+@@ -48,7 +48,6 @@
+ private:
+       void mousePressEvent(QMouseEvent *event);
+       void mouseMoveEvent(QMouseEvent *event);
+-      void mouseReleaseEvent(QMouseEvent *event);
+       void wheelEvent(QWheelEvent *event);
+ private:
+--- pulseview-a7553da/test/CMakeLists.txt~     2013-03-09 16:09:28.000000000 +0100
++++ pulseview-a7553da/test/CMakeLists.txt      2013-03-09 17:27:36.806516037 +0100
+@@ -35,6 +35,7 @@
+ set(PULSEVIEW_LINK_LIBS
+       ${Boost_LIBRARIES}
++      ${CMAKE_THREAD_LIBS_INIT}
+ )
+ add_executable(pulseview-test
index 1f8a0b7d5b76a2f72a5132d4e215e2facb1399e6..2f91424ec71d10c2be25ef5043725dc5008be051 100644 (file)
@@ -1,5 +1,5 @@
 #
-%bcond_with    tests
+%bcond_without tests
 #
 %define snap   a7553da
 #
@@ -39,6 +39,8 @@ cd build
 
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.326653 seconds and 4 git commands to generate.